Permissions problems with automounted UDF partition

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Permissions problems with automounted UDF partition

Postby Dave85inVA on Wed Feb 13, 2013 11:21 pm

Dual-boot machine, Windows 7 Pro and Linux Mint 14 with Cinnamon 1.6 ... trying to set up a UDF partition. I created the partition in Windows but did not format it; went back over to Linux and ran mkudffs there, and now Windows apparently can access the partition just fine. But the Linux Mint side has problems when I try to automount it.

Here's the mount point when nothing is mounted on it:
$ ls -ld /xyzzy
drwxr-xr-x 2 root root 4096 Feb 12 12:45 /home2

and here is the entry I put in fstab:

/dev/xyzzy-dev /xyzzy udf iocharset=utf8 0 1

But with this line in /etc/fstab, after boot the UID, GID, and permissions are not useful, to wit:

$ ls -ld /xyzzy
drwx------ 8 999 999 712 Feb 12 14:02 /xyzzy

So I changed the line in /etc/fstab to read:

/dev/xyzzy-dev /xyzzy udf iocharset=utf8,uid=0,gid=0,umask=0022 0 1

What I want is for root to be the owner and group owner, and for the permissions to be 755, so this brute-force solution, although inelegant, should work. But it's only a partial success:

$ ls -ld /xyzzy
drwx------ 8 root root 712 Feb 12 14:02 /xyzzy

This implies that changing the /etc/fstab settings did affect the UID and GID, but not the permissions. I've been searching these and other fora, and all over the web, since yesterday but to no avail. Anyone have any suggestiong as to why this may be happening?
Dave85inVA
Level 1
Level 1
 
Posts: 3
Joined: Tue Jan 15, 2013 10:01 pm

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: mint22mint, oakhilltop and 22 guests