Grub Help

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Grub Help

Postby Saruk on Sat Feb 24, 2007 6:22 pm

I have a problem with Grub. I've had it for a while and would like to know if there is someone that can help...

Here is the problem, I get a scrolling GRUB on my screen if I boot from the hard drive. When I use the CD and choose "Boot from Harddrive" I get a Grub 22 error.

I have a strange setup and I'll try to describe it.

I have an IDE RAID card in my PC so I have 6 harddrives...:shock: It appears that linux sees the raid drives first, but DOS sees the 2 on the primary on the motherboard first.. If I use a SUSE install disk and choose install then boot an installed system, it lets me choose hdc1 (which is an ext3 linux partition) to boot and that is the only way I can boot Bianca.
Also, just to describe my drives, I have Windows XP on hda (the master on the primary connector on the motherboard). I have linux on the master on the secondary of the IDE RAID controller (which should be hde)..

Let me know if you need more info. Now for the next problem...

When I boot, it's looking for the modules for 2.6.16.13-4 and I have 2.6.17-11 installed. Where or how do I tell it to use the correct location/version...

Thanks much,
Chuck

Just an update, I was able to get GRUB to work when running the Bianca install disk and choosing boot an installation. Now if I could only get it to boot without the cd. Also by getting it to load from GRUB, the modules are loading correctly... :lol:
Saruk
Level 1
Level 1
 
Posts: 1
Joined: Sat Feb 24, 2007 6:02 pm

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: geertlpa and 13 guests