Colours in terminal

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

Colours in terminal

Postby linuxero on Sun Feb 24, 2013 3:00 pm

Hi all,

I have upgraded my version of Linux Mint from 13 to 14 and now the colours of the terminal aren't enabled.

How can I enable the colours?

Regards.
linuxero
Level 1
Level 1
 
Posts: 13
Joined: Sat Feb 23, 2013 11:05 am

Linux Mint is funded by ads and donations.
 

Re: Colours in terminal

Postby linuxero on Sun Feb 24, 2013 3:54 pm

I have upgraded my bash.bashrc with this content and now works fine:

Code: Select all
# System-wide .bashrc file for interactive bash(1) shells.
 
# To enable the settings / commands in this file for login shells as well,
# this file has to be sourced in /etc/profile.
 
# If not running interactively, don't do anything
[ -z "$PS1" ] && return
 
# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize
 
# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi
 
use_color=false
 
# Set colorful PS1 only on colorful terminals.
# dircolors --print-database uses its own built-in database
# instead of using /etc/DIR_COLORS.  Try to use the external file
# first to take advantage of user additions.  Use internal bash
# globbing instead of external grep binary.
safe_term=${TERM//[^[:alnum:]]/?}   # sanitize TERM
match_lhs=""
[[ -f ~/.dir_colors   ]] && match_lhs="${match_lhs}$(<~/.dir_colors)"
[[ -f /etc/DIR_COLORS ]] && match_lhs="${match_lhs}$(</etc/DIR_COLORS)"
[[ -z ${match_lhs}    ]] \
        && type -P dircolors >/dev/null \
        && match_lhs=$(dircolors --print-database)
[[ $'\n'${match_lhs} == *$'\n'"TERM "${safe_term}* ]] && use_color=true
 
if ${use_color} ; then
        # Enable colors for ls, etc.  Prefer ~/.dir_colors #64489
        if type -P dircolors >/dev/null ; then
                if [[ -f ~/.dir_colors ]] ; then
                        eval $(dircolors -b ~/.dir_colors)
                elif [[ -f /etc/DIR_COLORS ]] ; then
                        eval $(dircolors -b /etc/DIR_COLORS)
                fi
        fi
 
        if [[ ${EUID} == 0 ]] ; then
                PS1='${debian_chroot:+($debian_chroot)}\[\033[01;31m\]\h\[\033[01;34m\] \W \$\[\033[00m\] '
        else
                PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[01;34m\] \w \$\[\033[00m\] '
        fi
 
        alias ls='ls --color=auto'
        alias grep='grep --colour=auto'
else
        if [[ ${EUID} == 0 ]] ; then
                # show root@ when we don't have colors
                PS1='\u@\h \W \$ '
        else
                PS1='\u@\h \w \$ '
        fi
fi
 
# Try to keep environment pollution down, EPA loves us.
unset use_color safe_term match_lhs
 
# Commented out, don't overwrite xterm -T "title" -n "icontitle" by default.
# If this is an xterm set the title to user@host:dir
#case "$TERM" in
#xterm*|rxvt*)
#    PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME}: ${PWD}\007"'
#    ;;
#*)
#    ;;
#esac
 
# enable bash completion in interactive shells
if [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
fi
 
# if the command-not-found package is installed, use it
if [ -x /usr/lib/command-not-found ]; then
        function command_not_found_handle {
                # check because c-n-f could've been removed in the meantime
                if [ -x /usr/lib/command-not-found ]; then
                   /usr/bin/python /usr/lib/command-not-found -- $1
                   return $?
                else
                   return 127
                fi
        }
fi
linuxero
Level 1
Level 1
 
Posts: 13
Joined: Sat Feb 23, 2013 11:05 am

Re: Colours in terminal

Postby glg on Sat Mar 23, 2013 12:39 am

Hi linuxero,

I just ran into the same problem. If anyone else arrives here from google some more details about the problem and easy fix are given here:

"Upgrade an existing Mint using apt"
http://community.linuxmint.com/tutorial/view/62

Known Issues
No colour/Linux Mint customisations in terminals You may have overwritten /etc/bash.bashrc with a vanilla configuration. Simply copy /etc/bash.bashrc.dpkg-old to /etc/bash.bashrc as root, and reload the terminal. Failing that, here's the Linux Mint 8 version of /etc/bash.bashrc: http://pastebin.com/Kd3a1QJe


Hence this is what worked for me:

Code: Select all
sudo cp /etc/bash.bashrc.dpkg-old /etc/bash.bashrc


The next terminal you open should be fixed with glorious hues to brighten your days :)


Rgds,
G.
glg
Level 1
Level 1
 
Posts: 1
Joined: Sat Mar 23, 2013 12:24 am


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 18 guests