Mint 13 & 14 boot hangs, not always though

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Mint 13 & 14 boot hangs, not always though

Postby Hugo Notte on Tue Feb 26, 2013 4:36 pm

I have installed Mint 13 & 14 Cinnamon on my Lenovo Z580 laptop. Initially it was as dual boot with Win7 (UEFI boot), then alone with BIOS (legacy) boot and later again as UEFI boot. Live DVD works fine, installation works fine. However, after installation about 2 out of 3 boots would hang during the initalisation of USB / SCSI devices. I have tried the original kernels, the updated distro kernels and kernel 3.8 (for support of the bluetooth radio, which is not supported below 3.7).
Mint 13 with kernel 3.8 worked 100% for 2 or 3 days, booting everytime. It then started hanging. I tried reinstalling, but never got it to boot everytime. Once the system has finally booted up (after the 2nd or 3rd attempt) the system runs very stable, both on Mint 13 & 14.
I started thinking of faulty hardware, but WIN7 boots perfectly everytime. I have now installed OpenSuse 12.2 which too boots everytime.

Hardware:
cpu:
Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz, 2500 MHz
Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz, 2500 MHz
Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz, 2500 MHz
Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz, 1200 MHz
keyboard:
/dev/input/event0 AT Translated Set 2 keyboard
mouse:
/dev/input/mice SynPS/2 Synaptics TouchPad
graphics card:
Intel VGA compatible controller
sound:
Intel Audio device
storage:
Intel SATA controller
network:
eth0 Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller
wlan0 Intel WLAN controller
network interface:
wlan0 WLAN network interface
lo Loopback network interface
eth0 Ethernet network interface
disk:
/dev/sda ST750LM022 HN-M7
partition:
/dev/sda1 Partition
/dev/sda2 Partition
/dev/sda3 Partition
/dev/sda5 Partition
/dev/sda6 Partition
/dev/sda7 Partition
/dev/sda8 Partition
/dev/sda9 Partition
cdrom:
/dev/sr0 Optiarc DVD RW AD-7740H
usb controller:
Intel USB Controller
Intel USB Controller
Intel USB Controller
bios:
BIOS
bridge:
Intel Host bridge
Intel PCI bridge
Intel PCI bridge
Intel PCI bridge
Intel PCI bridge
Intel ISA bridge
hub:
Linux 3.4.28-2.20-desktop xhci_hcd xHCI Host Controller
Linux 3.4.28-2.20-desktop xhci_hcd xHCI Host Controller
Linux 3.4.28-2.20-desktop ehci_hcd EHCI Host Controller
Hub
Linux 3.4.28-2.20-desktop ehci_hcd EHCI Host Controller
Hub
memory:
Main Memory
unknown:
FPU
DMA controller
PIC
Timer
Keyboard controller
PS/2 Controller
Intel Communication controller
Intel SMBus
Lite-On BCM20702A0
/dev/input/event9 Vimicro Lenovo EasyCamera

Please let me know, whether I must supply any other details.
Hugo Notte
Level 1
Level 1
 
Posts: 43
Joined: Fri May 21, 2010 10:22 am

Linux Mint is funded by ads and donations.
 

Re: Mint 13 & 14 boot hangs, not always though

Postby Hugo Notte on Thu Feb 28, 2013 4:56 am

Any idea anybody, please? Even though OpenSuse works very well on this machine, I would rather go back to Mint.

From my trial & error attempts I have gathered, that the boot problem is probably not related to Grub2 issues, since Grub 2 does start to load the kernel. In normal boot mode, the screen either goes blank or shows a flashing cursor in the top left corner. Booting via recovery option, one can see boot process stops suddenly at loading usb or scsi drivers.

I have heard that there might be instances in which MDM & LightDM are loaded together casuing similar problems. Any idea whether that is applicable to Mint 13 AND Mint 14?

If anybody could give me at least an idea where to look and how to start trouble shooting, I would appreciate that! Thanks
Hugo Notte
Level 1
Level 1
 
Posts: 43
Joined: Fri May 21, 2010 10:22 am

Re: Mint 13 & 14 boot hangs, not always though

Postby Hugo Notte on Sun Mar 03, 2013 3:11 am

seriously? nobody?
Hugo Notte
Level 1
Level 1
 
Posts: 43
Joined: Fri May 21, 2010 10:22 am

Re: Mint 13 & 14 boot hangs, not always though

Postby mintyy on Sun Mar 03, 2013 11:10 am

Hi,

my problem seems to be related.

viewtopic.php?f=46&t=124510

I guess Mint does not support Intel HD graphics correctly. Have not found any solution yet, contemplating to try OpenSuse to save me the resetting :wink: .

greetings
mintyy
Level 1
Level 1
 
Posts: 16
Joined: Fri Feb 01, 2013 8:05 pm

Re: Mint 13 & 14 boot hangs, not always though

Postby Hugo Notte on Tue Mar 05, 2013 2:34 am

Mintyy, I am not saying you are wrong. But I would find it strange, that the Mint kernel, being essentially the Ubuntu Kernel, wouldn't be able to cope with HD4000 graphics. That Intel Ivy graphics is not that young anymore.

Is there anybody else out there who could PLEASE give me an idea of where to start looking?
Hugo Notte
Level 1
Level 1
 
Posts: 43
Joined: Fri May 21, 2010 10:22 am


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 9 guests