[Solved] KDE & Cinnamon 14 (64) Freeze booting Install Disk

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

[Solved] KDE & Cinnamon 14 (64) Freeze booting Install Disk

Postby juhygtf6 on Wed Feb 27, 2013 1:19 pm

Hello, thanks for reading my post.

I have found that the Linux Mint (Cinnamon 14.1 and KDE 14, both 64 bit) install disks fail to boot properly on my Dell Studio 17 / 1747 Laptop. The boot process starts, I see the Linux Mint boot screen with the flashing lights for a bit, and after a while the laptop freezes (more details below).

The laptop is:
Dell Studio 17 - 1747
CPU: Intel i7
Video: ATI Mobility Radeon HD 4650 (ChipID = 0x9480)

I tried all of the usual things to verify the installation media (checked MD5 checksums, wrote DVD ISOs to high quality Verbatim media at slow speed, verified that the install disks boot successfully on other computers, tried booting in "Compatibility Mode", etc.)

I tried numerous kernel boot options, some of which are listed in my previous post: http://forums.linuxmint.com/viewtopic.php?f=109&t=126234. But additionally I tried numerous other kernel boot options (I found some thorough lists online and I tried all the options that I could find related to the usual "trouble spots" of video or network. I also tried blacklisting the wireless card (b43.blacklist=yes). Nothing worked.

I am happy to report that I found a solution - a BIOS setting related to the built-in wireless card of the laptop was the culprit. The Dell Studio 17 / 1747 Laptop BIOS has an "Advanced" setting called "Internal WLAN" which must be disabled for the install disks to boot (detailed steps on how to make this BIOS setting change are given at the end of this post). This has the effect of disabling the built-in wireless network card of the laptop, which means that a wireless connection cannot be used during the install process (a regular wired connection worked fine for me, though). Note that the BIOS setting can be re-enabled after Mint has been installed.

Please note that I originally thought that my problem was only related to the KDE version of Mint, and that Cinnamon 14.1 installed fine, but now I realise that I accidentally had the necessary BIOS setting when I installed Cinnamon a few months back. I have since thoroughly tested both the Cinnamon and KDE (64-bit) install disks, and neither will successfully boot if the Laptop's BIOS have the default settings of (Internal WLAN = Enabled), and they both work fine if that BIOS setting is disabled.

I originally posted regarding this problem in the Mint KDE forum board here: http://forums.linuxmint.com/viewtopic.php?f=109&t=126234


Details

When I boot from the install DVD, the computer freezes. If I hit F12 as it boots, then I see the following text, and then the computer freezes (it doesn't respond to any key presses and needs to be hard-shutdown).

stdin: Not a typewriter
Generating locales...
en_US.UTF-8... up-to-date
Generation complete.
grep: /root/etc/default/apport: No such file or directory
using CD_ROM mount point /cdrom/
Identifying.. [de05264a619a326f10cfeb52f6b65365-2]
Scanning disc for index files..
Found 0 package indexes, 0 source indexes, 0 translation indexes and 0 signatures
E: Unable to locate any package files, perhaps this is not a Debian Disc or the wrong architecture?
* Starting Bridge socket events into upstart
* Stopping Mount network filesystems
* Starting configure network device security
* Starting SMB/CIPS File Server
* Starting configure network device
* Starting mDNS/DNS-SD daemon
* Stopping Failsafe Boot Delay
* Starting System V initialisation compatibility
* Starting set sysctls from /etc/sysctl.conf
* Starting configure network device security
* Starting configure network device
* Starting modem connection manager
* Stopping set sysctls from /etc/sysctl.conf
* Starting bluetooth daemon
* Starting configure network device security
* Starting configure network device
* Starting CPUS printing spooler/server
* Starting Samba Auto-reload Integration
* Stopping Samba Auto-reload Integration
* Starting SMB/CIPS File Server
* Starting network connection manager


There are reports online of this laptop and similar laptops working fine with Linux in general (for example the linux hardware compatibility list, google "Linux HCL"), and Mint specifically (the Mint Hardware database is here: http://community.linuxmint.com/hardware). But these sources do not indicate what BIOS settings were used when testing those laptops, so it is possible those reports were successful because they accidentally has the "Internal WLAN" setting disabled.


Detailed Solution

Making BIOS settings changes can mess up your computer, so please be careful. That said, it's relatively easy to affect the BIOS settings change needed. Here's detailed instructions:

Turn machine on and immediately start hitting F2 (function key 2) to enter the BIOS Setup Utility

Once you're in the BIOS Setup Utility, hit Cursor Right once to move to the "Advanced Screen"

Cursor Down to "Internal WLAN" which is second from the bottom.
(Note that this is not the same as "Internal WWAN" - make sure you get the correct one!)

Hit the SpaceBar to disable Internal WLAN.

Hit F10 to save your changes and exit. (You will need to hit Enter to confirm "yes", when it asks you whether to save and exit)

The machine will reboot - the Mint install disks should work now.


One more minor note: if you are using this laptop and you insert the install disk and you can't get it to stop booting from the hard drive instead of the CD/DVD drive, then hit F12 repeatedly as the machine boots and you'll see a menu from which you can select to boot from the CD/DVD Drive.
juhygtf6
Level 1
Level 1
 
Posts: 3
Joined: Wed Feb 20, 2013 2:58 am

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: expat_tony and 17 guests