Half a solution to failed boot

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Half a solution to failed boot

Postby Husse on Sun Feb 25, 2007 7:35 am

I've tried a lot of ways to boot with the Live CD - but I can't.
I thought it was my motherboard, nForce 4 a chipset that has tons of problems, but works like a charm if you don't get these problems. But it was the graphics card, Nvidia 6600 GT. For some reason the "out of the box" driver called in Xorg.conf does not support this card (and a few other nVidia and a bunch of ATI cards)
Ubuntu gives the choice of an alternate install CD. So I've installed Edgy, booted in recovery mode and edited xorg.conf so that I've changed the line 'Device "nv" ' to 'Device "vesa" ' and alas it is possible to reach the desktop but with horrible graphics performance. Then it is easy to install the nVidia driver with "envy".
This is as far as I can find out not possible with the live CD.
I thought of editing the ISO but realised that the xorg.conf most likely is generated dynamicaly.
Questins:
Does an alternate install CD exist for Bianca?
Is it possible to force the use of the vesa driver in the options using "F6" with the live CD?
Any other solution?
Last edited by Husse on Sun Feb 25, 2007 7:42 pm, edited 1 time in total.
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Linux Mint is funded by ads and donations.
 

Found the missing part of the solution

Postby Husse on Sun Feb 25, 2007 7:39 pm

Hi
I found this thread on the "regular Ubuntu forums" a short while ago and it works!
http://www.ubuntuforums.org/showthread.php?t=367358

What it says if you don't want to venture there is:

I had the same problem myself, the reason for it is that it's using the wrong graphics drivers. When the live cd starts up press F6 and delete the "quiet - splash" ending and type in "break=bottom" then boot with this. This will get rid of the ubuntu splash screen and stop half way through booting with a command prompt (ignore any error messages for now).

When you get to the prompt type in the following:

Code:

chroot /root nano /etc/X11/xorg.conf

this will let you edit your graphics configuration file. Using the arrow keys scroll down to the heading called "Device". Under this it should have "Driver" to the left and beside it the driver in inverted commas.
//Comment iserted by me//
It's the same for nVidia as ATI, only when it is a nVidia card the "word" you change to "vesa" is "nv". You could try nvidia, but... Please note that the X in X11 must be a major X//
For some reason this driver is always loaded for the X series cards and it never works. delete "ATI" and try either "radeon" (the drivers that are supposed to work) or, if those don't work "vesa" (the most basic graphics drivers).

Once you've done this press ctrl+O then ctrl+X to save and exit the text editor. //or Ctrl+x then y then enter//

This will bring you back to the command line, simply type:

Code:

exit

and, fingers crossed, ubuntu should boot.

End quote

And it did the trick!!!
I've seen Bianca!
I'll go on and install at a later time, don't have sparetime right now.

I think this might be sticky as there are lots of people with graphics cards that wont accept the "out of the box" driver.
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Wonderful post

Postby riktzvet on Wed Apr 04, 2007 12:21 am

Thank You so much for this find. It has helped me on both a Bianca install and an Edgy Elf install on the same machine.

I am installing on an older PIII 800 dual proc server that has onboard Cirrus Logic video as well as an nVidia M64 add-in video card. during the Live cd boot of both versions it would find the Cirrus Logic video first and not be able to progress beyond that, giving a "Video incorrectly configured" message. (Or something to that effect).

Anyway, using the same fix template, found where it showed DEVICE rather than Driver...

I changed the device setting in section DEVICEfrom
IDENTIFIER "Cirrus Logic" (or whatever yours may be) to the add-in card- "nVidia Corporation NV5M64". Then changed the DRIVER from "cirrus" to nv", then also had to change the BUS ID from PCI:xx:xx:xx" to the BUS ID address shown in the previous server error log. Also had to scroll down to the "Screen" section and change the DEVICE from "cirrus" to "nVidia" here also.

After exiting it continued into the normal GUI install!
riktzvet
Level 1
Level 1
 
Posts: 1
Joined: Tue Apr 03, 2007 11:24 pm


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 17 guests