Disable Swap after installation

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Disable Swap after installation

Postby Roland on Sun Mar 24, 2013 11:03 am

I installed Mint 14 on a SSD.
Afterwards I learned it is better not to use swap; my pc has 4GB memory.
I read some about swap and edititng fstab, but I do no understand it very well.
How to disable swap?

This is my fstab:

Code: Select all
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sdb1 during installation
errors=remount-ro,noatime,discard
# swap was on /dev/sdb5 during installation
UUID=6ca36406-3805-4504-88e9-11583c99c1bc none            swap    sw              0       0
none /tmp     tmpfs nodev,nosuid,mode=1777 0 0
Roland
Level 2
Level 2
 
Posts: 97
Joined: Sun Oct 04, 2009 9:44 am

Linux Mint is funded by ads and donations.
 

Re: Disable Swap after installation

Postby xenopeek on Sun Mar 24, 2013 12:37 pm

I think something went wrong when you copied your fstab here, as what you are showing above is not from a bootable system. So check again and make sure your actual fstab is different, or you have a big issue... This bit is broken:
Code: Select all
# / was on /dev/sdb1 during installation
errors=remount-ro,noatime,discard

All you need to do to disable swap is comment out the line (put a # in front of it):
Code: Select all
UUID=6ca36406-3805-4504-88e9-11583c99c1bc none            swap    sw              0       0

Then reboot and swap will be deactivated. You can boot from your Linux Mint installation DVD / USB and run GParted from there. There you can delete the swap partition and then resize your other partition to include that disk space.

Because you didn't tell us what desktop environment you have installed, can't tell you how to edit your file except from the terminal. You can do so with the following:
Code: Select all
sudo nano /etc/fstab

If you want to know how to do that with a graphical editor, include what desktop environment you are using...
Forum Rules | IRC Channel Rules
Image
Arch Linux / 64-bit / Gnome Shell
User avatar
xenopeek
Level 21
Level 21
 
Posts: 13700
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Disable Swap after installation

Postby Roland on Sun Mar 24, 2013 2:21 pm

Thank you.
I followed your instructions, and swap is diabled now.
:)
I checked my fstab before, and I did not make a mistake when copying it in my first message.
BTW: Mint 14 Cinnamon.
Roland
Level 2
Level 2
 
Posts: 97
Joined: Sun Oct 04, 2009 9:44 am


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 12 guests