[SOLVED] Mint not showing at UEFI-Bios menu

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

[SOLVED] Mint not showing at UEFI-Bios menu

Postby arealvel on Sun Mar 24, 2013 1:29 pm

Four months ago I install Mint 14 in dual boot with Windows 7 on my new ASUS (F301). I install it UEFI-mode from USB. Two months later I upgrade Windows 7 to Windows 8, without problems. Some days ago I was hearing music and something began not to work. There was a sudden crash which power off the computer. A little scared I switch on again and everything was apparently working. A couple of days after this strange crash, I wanted to enter Mint (which usually I do from the UEFI-Bios menu), but the Mint’s reference in the menu has disappeared. The Windows Boot Manager was the only option.

I'm really lost on what had gone, perhaps the problem was due to a option in the Bios as the PXE ROM was enabled, and in the crash the computer was complaining about something relative to the network card. I've now disabled that option.

I’d like to place again the option for Mint under the menu tab of UEFI-Bios, I can't access now to Mint. I know that this is not a "Mint topic", but perhaps someone has any idea. Otherwise I would be obliged to reinstall Mint.
Last edited by arealvel on Wed Mar 27, 2013 6:07 am, edited 2 times in total.
arealvel
Level 1
Level 1
 
Posts: 30
Joined: Wed Jan 02, 2013 7:07 am

Linux Mint is funded by ads and donations.
 

Re: Mint not showing at UEFI-Bios menu

Postby tdockery97 on Sun Mar 24, 2013 1:46 pm

You might want to run your live Mint 14 USB and use GParted to make sure your Mint partition is still there. Windows has a reputation of wiping the entire drive when it installs.
Image
Mint 17 Cinnamon
HP Pavilion 17 Notebook, 8GB DDR3, 2.5GHZ A10-APU, Radeon HD 8650G
Registered Linux User #520972
User avatar
tdockery97
Level 13
Level 13
 
Posts: 4862
Joined: Sun Jan 10, 2010 8:54 am
Location: Salem, Oregon

Re: Mint not showing at UEFI-Bios menu

Postby arealvel on Sun Mar 24, 2013 1:57 pm

Yes, I've done it before posting, the partition is safe, with all the folders there. And it doesn't seem a problem with Windows installation as for three months both systems were working in good terms between them. I see it more like a UEFI-Bios conflict caused by the network card, but I don't know really.
arealvel
Level 1
Level 1
 
Posts: 30
Joined: Wed Jan 02, 2013 7:07 am

Re: Mint not showing at UEFI-Bios menu

Postby srs5694 on Sun Mar 24, 2013 8:02 pm

Try downloading a CD-R or USB flash drive image of my rEFInd boot manager. You should be able to boot with it, and with any luck it will give you an explicit option to boot Mint. If so, select it. You can then either use "efibootmgr" to add GRUB back to the menu or install rEFInd to use it instead of or in addition to GRUB. For instructions on efibootmgr, see this page, and in particular the section "Announcing the Boot Loader to the EFI."
srs5694
Level 6
Level 6
 
Posts: 1020
Joined: Mon Feb 27, 2012 1:42 pm

Re: Mint not showing at UEFI-Bios menu

Postby arealvel on Wed Mar 27, 2013 5:38 am

Thanks srs5694 of your advice. It has been useful for me. I burn a CD with rEFInd boot disk. Both systems W8 and Mint were available from there. I was thinking to install rEFInd, but at least I solved the problem other way.

Using the EFI shell include in rEFInd disk I browse the filesystems and a light come to me.

My UEFI-Bios has a option to create a new boot entry. I had tried to create a new entry before unsuccessfully. The entry require a path for the bootlaoder, which I was giving incorrectly. The right path wasn't fs0:\EFI\linuxmint\grubx64.efi , but just \EFI\linuxmint\grubx64.efi . That was all. So simple. Previously I had check that the grub efi bootloader was there. Mint placed it there when I installed it in EFI mode.


Some pictures of this.

addboot.jpg
This is the tab for new boot entries. Require to put a name, select the filesystem -there is just one as I've just one EFI partition; give a path (here was my mistake), and finally create the entry with these data


addpath.jpg
For the path. See the expected form (fs0:\path\bootlader.efi) on the right part of the picture. This is Tricky as it doesn't work if fs0 is included


bootpriority.jpg
How the new entry is showed.
arealvel
Level 1
Level 1
 
Posts: 30
Joined: Wed Jan 02, 2013 7:07 am


Return to Installation & Boot

Who is online

Users browsing this forum: Google Adsense [Bot] and 18 guests