Log In Screen Resolution Incorrect

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Log In Screen Resolution Incorrect

Postby jordan on Mon Jun 02, 2008 6:06 pm

I reinstalled Mint three times. And in the process developed a resolution problem on the Log In screen.

First Install
The first time the was no resolution problem, but I had a crash due to power outage during the updates after fresh install.

Second Install
The Log In screen resolution was too large. I logged in and my account was also at a higher resolution. Luckily I found the task bar off-screen and drug it to the top and fixed the resolution. But, I had to reinstall because at the end of shutdown the Mint outro audio hung and the computer never shutdown.

Third Install
The Log In screen is still too large, but logged into the account the resolution was fine.

How do I fix the Log In screen resolution?
jordan
Level 1
Level 1
 
Posts: 40
Joined: Mon Jun 02, 2008 5:45 pm

Linux Mint is funded by ads and donations.
 

Re: Log In Screen Resolution Incorrect

Postby rivenought on Mon Jun 02, 2008 6:16 pm

Linux Mint is a great distro, though, every so often there is a slight adjustment that needs to be made depending on hardware. One issue can be the GRUB options for screen resolution during boot. Here is brief how-to that can hopefully be a quick fix.

First off, the exact resolution desired must be chosen. From this chart, pick the resolution necessary for your hardware. As an example, I need the 1024×768 16-bit resolution, so I choose the number 791. This chart may not exactly display properly, but I am just trying to get the info to you in some almost readable form.

640×480 800×600 1024×768 1280×1024 1600×1200
8bit 769 771 773 775 777
15bit 784 787 790 793 796
16bit 785 788 791 794 797
24bit 786 789 792 795 798

(This chart looks a whole lot better in my notes before copy and paste. Sorry.)

Once you know your number, here is what needs to be done:

Click on the mintMenu and choose Terminal. In Terminal, key in:

Code: Select all
gksudo gedit /boot/grub/menu.lst


Enter your password and click OK. Scroll down the page until you get to the ## End Default Options ## section. The third line under there reads something similar to:

Code: Select all
kernel /vmlinuz-2.6.24-16-generic root=/dev/sda6 ro quiet splash


Put your resolution number at the end of that line so it reads something similar to:

Code: Select all
kernel /vmlinuz-2.6.24-16-generic root=/dev/sda6 ro quiet splash vga=791


Once you have this done, save the “menu.lst file” and close the Terminal. Reboot the computer to verify the changes. You should hopefully boot up into the correct resolution. As always, your kilometerage may vary.
Good luck!

*** If anyone sees where I have made a mistake in my steps or notes, please tell me. I always hope to share the most correct advice possible. ***
rivenought
Level 5
Level 5
 
Posts: 780
Joined: Wed Apr 09, 2008 10:34 am

Re: Log In Screen Resolution Incorrect

Postby jordan on Thu Jun 26, 2008 8:55 am

I too have that same resolution and 16 bit. I tried it, but it did not fix the log in screen problem. I have reinstalled several times over the last few weeks. A couple of times, an Mint install mysteriously had the correct resolution for the log in screen without going into menu.lst. With the incorrect resolution after a reinstall, I've tried going in to menu.lst, but it does not correct the problem. There must be another way to correct this, right? Or could I be putting the the incorrect number in? I'm using vga=791. How do I know this is right?
jordan
Level 1
Level 1
 
Posts: 40
Joined: Mon Jun 02, 2008 5:45 pm

Re: Log In Screen Resolution Incorrect

Postby rivenought on Thu Jun 26, 2008 9:27 am

Jordan, the above works for me. Apparently, it depends on video cards/settings/drivers, etc. There may be an issue with Framebuffer graphics, or it might be the monitor. I use desktops with an NEC E700 CRT - no laptops. I know I can use VESA graphics on one box and ATI drivers on another box through a KVM switch and still get the same log-in screen on my only monitor. Maybe my setup is somewhat unusual. 67GTA had some good advice on this issue, but I cannot find that post right now. I think his solution worked better then mine - depending on the machines.

As long as I can see the log-in screen and be able to type in it, I am happy enough. Also, I only reboot about once every two or three weeks when I turn the systems off while I am out of town. So, I do not see that screen much anyway. VGA=791 is the 1024x768 resolution that works for me. You may have to experiment and research further. I am going to dig around a while on this end. If I come up with anything new, I shall post. Good luck.
rivenought
Level 5
Level 5
 
Posts: 780
Joined: Wed Apr 09, 2008 10:34 am


Return to Installation & Boot

Who is online

Users browsing this forum: flieger, Google [Bot], sumitra and 27 guests