SYSLINUX menu: no countdown nor automatic boot in Live USB

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

SYSLINUX menu: no countdown nor automatic boot in Live USB

Postby biluluki on Wed Apr 17, 2013 9:08 am

These last days I'm trying different new Linux Mint distros via Live USBs. I create them with usb-creator-gtk (the Startup Disk Creator). They work fine but there is no countdown on them. And the message "Automatic boot in 10 seconds" doesn't have effect, because if I wait 10 seconds (or more) the boot doesn't happen even without a countdown. The easy and quick workaround is to press the Enter key twice to boot the Live USBs "manually".

I've checked the syslinux.cfg file (inside the syslinux folder) and I have:
Code: Select all
default vesamenu.c32
timeout 100

So the automatic boot should take place after 10 seconds.

I cannot edit vesamenu.c32. Probably there is something inside this archive that prevents the countdown and automatic boot from executing?
biluluki
Level 1
Level 1
 
Posts: 32
Joined: Mon Apr 09, 2012 10:23 am

Linux Mint is funded by ads and donations.
 

Re: SYSLINUX menu: no countdown nor automatic boot in Live U

Postby biluluki on Wed Apr 17, 2013 1:38 pm

Replacing
Code: Select all
default vesamenu.c32
by
Code: Select all
default live
the automatic boot works but no menu nor splash.jpg image appear.

A solution is to delete all the content of the syslinux.cfg archive and replace it by:
Code: Select all
prompt 1
timeout 100
default 1
say -
say Enter the number of the desired option (automatic boot of 1 in 10 seconds)
say --------------------------------------
say -
label 1
say 1 Start Linux Mint
kernel /casper/vmlinuz
append noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/mint.seed boot=casper initrd=/casper/initrd.lz quiet splash --
label 2
say 2 Start in compatibility mode
kernel /casper/vmlinuz
append noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/mint.seed boot=casper xforcevesa nomodeset b43.blacklist=yes initrd=/casper/initrd.lz ramdisk_size=1048576 root=/dev/ram rw noapic noapci nosplash irqpoll --
label 3
say 3 Memory test
kernel memtest
label 4
say 4 Memory test 2
kernel /install/mt86plus

This way the automatic boot works and we can stop it pressing any key. And we can choose any option to be executed.

I have deleted the "Integrity check" option because it doesn't work, at least here. I have also removed the "Boot from local drive" option because here, instead of doing that, it boots from the USB flash drive itself. I have added a second memory test avaiable.

Does anybody know how to add to this proposed syslinux.cfg file the possibility of showing the splash.jpg image?

I think that these problems happen because the .iso files are designed specially for DVDs, not for USB flash drives.
biluluki
Level 1
Level 1
 
Posts: 32
Joined: Mon Apr 09, 2012 10:23 am

Re: SYSLINUX menu: no countdown nor automatic boot in Live U

Postby biluluki on Wed Apr 17, 2013 6:05 pm

Well, after checking a bit more, perhaps it's more correct to say that the "Integrity check" works but, because the iso images are specially made to be burnt into DVDs, when you run it on a Live USB you get 4 errors because it looks for 4 files inside the isolinux folder, when actually they are inside the syslinux directory.
biluluki
Level 1
Level 1
 
Posts: 32
Joined: Mon Apr 09, 2012 10:23 am


Return to Installation & Boot

Who is online

Users browsing this forum: jjjjj, scrognoid, ukrainerepresent, wgn and 30 guests