Apt-get destroyed?

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Apt-get destroyed?

Postby Anubisone on Wed Apr 17, 2013 3:27 pm

I have a tiny problem. I cannot run apt-get. Tried everything. So sudo isn't woirking for anything. Any ideas why and how to repair it? I unchecked bad repos.
User avatar
Anubisone
Level 2
Level 2
 
Posts: 50
Joined: Thu Jan 31, 2013 9:06 am
Location: Paris

Linux Mint is funded by ads and donations.
 

Re: Apt-get destroyed?

Postby catweazel on Wed Apr 17, 2013 4:38 pm

Anubisone wrote:I cannot run apt-get... sudo isn't woirking

You need to be more specific than simply saying 'it doesn't work'. What commands are you using? What is happening when you use those commands? What output do you get?
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1656
Joined: Fri Oct 12, 2012 9:44 pm

Re: Apt-get destroyed?

Postby xenopeek on Wed Apr 17, 2013 4:39 pm

What error are you getting? Please copy & paste the output from the terminal of this command:
Code: Select all
sudo apt-get update
Forum Rules | IRC Channel Rules
Image
Arch Linux / 64-bit / Gnome Shell
User avatar
xenopeek
Level 21
Level 21
 
Posts: 13708
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Apt-get destroyed?

Postby Anubisone on Thu Apr 18, 2013 9:55 am

catweazel wrote:
Anubisone wrote:I cannot run apt-get... sudo isn't woirking

You need to be more specific than simply saying 'it doesn't work'. What commands are you using? What is happening when you use those commands? What output do you get?

xenopeek wrote:What error are you getting? Please copy & paste the output from the terminal of this command:
Code: Select all
sudo apt-get update

I get this error and it is connected to Update I think, because it finishes only without ppa.launchpad and archive.getdeb.net in Software Sources.

What I want to do is to install Flightgear again since I deleted it by accident ...

I get those messages in the console:

Code: Select all
sudo apt-get -f install flightgear
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 fgfs-models-base : Breaks: fgfs-base (< 2.6.0) but 2.0.0-1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


After checking both ppa.launchpad repos -> update seems to be fine
After checking both archive.getdeb -> update seems to be fine too

so, I tried to check what is goin wrong by apt-cache show fgfs-base:

result:

Code: Select all
Package: fgfs-base
Priority: extra
Section: universe/games
Installed-Size: 298492
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian FlightGear Crew <pkg-fgfs-crew@lists.alioth.debian.org>
Architecture: all
Version: 2.0.0-1
Depends: tzdata
Conflicts: flightgear (<< 2.0.0)
Filename: pool/universe/f/fgfs-base/fgfs-base_2.0.0-1_all.deb
Size: 202226088
MD5sum: 1a94f431b7f7557fafb381ea25ae9573
SHA1: 1b1ebba28599d257815eb243b2869829ef470aec
SHA256: cf778783cc8c121664aec6ee8f38a7e26d720fa41f60e11463083c848bc7835e
Description-en: Flight Gear Flight Simulator -- base files
 Flight Gear is a free and highly sophisticated flight simulator.
 .
 This package contains graphics, sounds, models, and the minimum
 scenery you need to start Flight Gear.
 .
 This package does not contain the flight simulator itself.
 If you want to fly, install the flightgear package.
Homepage: http://www.flightgear.org/
Description-md5: 5f78c6ed4fcf31bab3f097021197e93a
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu

Package: fgfs-base
Version: 2.6.0-1~getdeb1
Architecture: all
Maintainer: GetDeb Package Ninjas <package.ninjas@getdeb.net>
Installed-Size: 734012
Depends: tzdata, ttf-liberation
Breaks: flightgear (<< 2.6.0)
Homepage: http://www.flightgear.org/
Priority: standard
Section: games
Filename: pool/games/f/fgfs-base/fgfs-base_2.6.0-1~getdeb1_all.deb
Size: 380429546
SHA256: 75fad4e7764aa7d4a4b2bc0f2e39c5834606198eaf3ac539fba68bab66f18803
SHA1: 50654a21166d221edd2991a873a483dc82043146
MD5sum: ce6a9da11b1c53a9eeec6e7b5977b4e3
Description: Flight Gear Flight Simulator -- base files
 Flight Gear is a free and highly sophisticated flight simulator.
 .
 This package contains graphics, sounds, models, and the minimum
 scenery you need to start Flight Gear.
 .
 This package does not contain the flight simulator itself.
 If you want to fly, install the flightgear package.


and I try search which repositiories I have available by apt-cache policy fgfs-base:

Code: Select all
fgfs-base:
  Installed: 2.0.0-1
  Candidate: 2.6.0-1~getdeb1
  Version table:
     2.6.0-1~getdeb1 0
        500 http://archive.getdeb.net/ubuntu/ oneiric-getdeb/games i386 Packages
 *** 2.0.0-1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe i386 Packages
        100 /var/lib/dpkg/status


I'm stuck. I am not a beginner, but now I feel like one ... don't know what to do step by step. Sorry for my confusion now.

Update:

I tried gksu synaptic to filter out and reinstall this base I mentioned and ...:

Currently it said "error 1" but the Broken filter doesn't show that it is broken now after removal.

I don't know. If that works then I'm relieved.
User avatar
Anubisone
Level 2
Level 2
 
Posts: 50
Joined: Thu Jan 31, 2013 9:06 am
Location: Paris

Re: Apt-get destroyed?

Postby uncle on Thu Apr 18, 2013 3:13 pm

There's a dependency missing for the prog you want to install it appears. You will need to track it down first

he following packages have unmet dependencies:
fgfs-models-base : Breaks: fgfs-base (< 2.6.0) but 2.0.0-1 is to be installed


you need version 2.6 and what's available is 2.0. track down 2.6.0 and install that from somewhere else? That's all I could think of.
uncle
Level 1
Level 1
 
Posts: 12
Joined: Sat Nov 19, 2011 4:58 pm


Return to Installation & Boot

Who is online

Users browsing this forum: eljeem and 19 guests