Dreaded Error 15

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Dreaded Error 15

Postby LinuxForever on Fri Jun 06, 2008 2:26 am

When I try to install 048 I get the Error 15 message. I have to ask if I'm doing this right because I get the same error message with everything based on Ubuntu 8.04.

I'm not using the whole drive for the install. I'm trying to install into a partition. The only other thing on the drive is a swap partition. This is my second drive I'm trying to install to. It's set up as slave.

So I use Custom install and set up to format with ext3 and set the partition as /. The install goes okay, then I click on reboot, the grub screen comes up showing Linux Mint at the top of the list with the little count down circle thing and then it goes to a text screen with the Error 15 message.

What am I doing wrong?

I should say two things. First, I installed PCLOS 2007 into that same partition without no problems. No Error 15 message. Never had any Error 15 messages from Mandriva, opensuse, debian and fedora. Never had Error 15 message from any Ubuntu before 8.04. Second I've only seen this Error 15 message with Ubuntu 8.04 and anything based on Ubuntu 8.04.

The last thing I had on this partition was freespire 2.0.3 which is based on Ubuntu 7.10 and no Error 15 message when I booted that distro.

There must be a solution to this 8.04 installer Error 15 message. Thankx for any help.

NB I have mandriva installed on my first drive. But I don't think that's the problem cus it didn't cause any problems with other distros I've installed in to the partition on my second drive.
LinuxForever
Level 3
Level 3
 
Posts: 136
Joined: Tue May 13, 2008 2:05 pm

Linux Mint is funded by ads and donations.
 

Re: Dreaded Error 15

Postby 67GTA on Fri Jun 06, 2008 1:22 pm

It sounds like the installer might have put grub in the MBR of the slave drive, and not in the MBR of the primary drive. Did the installer show both drives during installation? Post the output of
Code: Select all
sudo fdisk -l
from a terminal, and post your /boot/grub/menu.lst from the Mint install.
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke
User avatar
67GTA
Level 6
Level 6
 
Posts: 1301
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: Dreaded Error 15

Postby Nomad on Fri Jun 06, 2008 3:54 pm

This is a bug in Ubuntu 8.04. You might boot the live CD and see if the installer even put the /boot/grub in.
Nomad
Level 3
Level 3
 
Posts: 147
Joined: Mon Apr 21, 2008 7:48 pm

Re: Dreaded Error 15

Postby LinuxForever on Fri Jun 06, 2008 6:10 pm

Thandx for your help 67GTA and Nomad.

67GTA the installer did show all 3 of my drives in the installation menue or window or whatever you call it. I told the installer to put GRUB in the mbr of hdb. I have mandriva on my first drive and I didn't want to overwrite the mandriva GRUB. Are you saying I should overwrite it anyway with the Mint GRUB? I could try that first and see if it works. I've been using BIOS to change drives in the past.


Nomad a thread at ubuntu lead me to a bug report about the installer. It was something about the kernal and via. I should have bookmarked it. It said replace the kernal and the via something but who knows how to do that. I only know how to click on buttons. I'm not a command line kind of person I guess. I looked at the 048 live cd to see if it had a MintGRUB thing that I could access GRUB with and fix the GRUB but it doesn't. That might be a good thing to have for dummies like me.
LinuxForever
Level 3
Level 3
 
Posts: 136
Joined: Tue May 13, 2008 2:05 pm

Re: Dreaded Error 15

Postby 67GTA on Fri Jun 06, 2008 6:26 pm

I'm not sure what is what without actually looking at your info. Post the out put of
Code: Select all
sudo fdisk -l
and a copy of Mint's menu.lst.
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke
User avatar
67GTA
Level 6
Level 6
 
Posts: 1301
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: Dreaded Error 15

Postby merlwiz79 on Fri Jun 06, 2008 7:10 pm

When trying to boot into Elyssa edit the top line.
Which probably says something like this.
Code: Select all
root      (hd1,X)

Try changing it to:
Code: Select all
root      (hd0,X)

Don't change the value for X.
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: Dreaded Error 15

Postby LinuxForever on Fri Jun 06, 2008 10:46 pm

67GTA this is the info you asked for. Thankx for the help.

bruce@bruce-desktop ~ $ sudo fdisk -l



Disk /dev/sda: 40.0 GB, 40020664320 bytes

255 heads, 63 sectors/track, 4865 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

Disk identifier: 0x9d279d27



Device Boot Start End Blocks Id System

/dev/sda1 * 1 1019 8185086 83 Linux

/dev/sda2 1020 4865 30892995 5 Extended

/dev/sda5 1020 1528 4088511 82 Linux swap / Solaris

/dev/sda6 1529 4865 26804421 83 Linux



Disk /dev/sdb: 40.9 GB, 40971829248 bytes

255 heads, 63 sectors/track, 4981 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

Disk identifier: 0x90909090



Device Boot Start End Blocks Id System

/dev/sdb1 * 1 4888 39262828+ 83 Linux

/dev/sdb2 4889 4981 747022+ 5 Extended

/dev/sdb5 4889 4981 746991 82 Linux swap / Solaris



Disk /dev/sdc: 120.0 GB, 120034123776 bytes

255 heads, 63 sectors/track, 14593 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

Disk identifier: 0x00063242



Device Boot Start End Blocks Id System

/dev/sdc1 * 1 14469 116222211 83 Linux

/dev/sdc2 14470 14593 996030 5 Extended

/dev/sdc5 14470 14593 995998+ 82 Linux swap / Solaris

bruce@bruce-desktop ~ $






# menu.lst - See: grub(8), info grub, update-grub(8)

# grub-install(8), grub-floppy(8),

# grub-md5-crypt, /usr/share/doc/grub

# and /usr/share/doc/grub-legacy-doc/.



## default num

# Set the default entry to the entry number NUM. Numbering starts from 0, and

# the entry number 0 is the default if the command is not used.

#

# You can specify 'saved' instead of a number. In this case, the default entry

# is the entry saved with the command 'savedefault'.

# WARNING: If you are using dmraid do not change this entry to 'saved' or your

# array will desync and will not let you boot your system.

default 0



gfxmenu=/etc/grub/message.elyssa



## timeout sec

# Set a timeout, in SEC seconds, before automatically booting the default entry

# (normally the first entry defined).

timeout 10



# Pretty colours

color cyan/blue white/blue



## password ['--md5'] passwd

# If used in the first section of a menu file, disable all interactive editing

# control (menu entry editor and command-line) and entries protected by the

# command 'lock'

# e.g. password topsecret

# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/

# password topsecret



#

# examples

#

# title Windows 95/98/NT/2000

# root (hd0,0)

# makeactive

# chainloader +1

#

# title Linux

# root (hd0,1)

# kernel /vmlinuz root=/dev/hda2 ro

#



#

# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST



### BEGIN AUTOMAGIC KERNELS LIST

## lines between the AUTOMAGIC KERNELS LIST markers will be modified

## by the debian update-grub script except for the default options below



## DO NOT UNCOMMENT THEM, Just edit them to your needs



## ## Start Default Options ##

## default kernel options

## default kernel options for automagic boot options

## If you want special options for specific kernels use kopt_x_y_z

## where x.y.z is kernel version. Minor versions can be omitted.

## e.g. kopt=root=/dev/hda1 ro

## kopt_2_6_8=root=/dev/hdc1 ro

## kopt_2_6_8_2_686=root=/dev/hdc2 ro

# kopt=root=/dev/sdb1 ro



## default grub root device

## e.g. groot=(hd0,0)

Also this is what I got after the grub boot screen changed.
Root (hd1,0)
Filesytem type is ext2fs, partition type 0x83
kernel /boot/vmlinuz-2.6.24-16-generic root=/dev/sdb1 ro quiet splash

Error 15: File not found

Press any key to continue..._
LinuxForever
Level 3
Level 3
 
Posts: 136
Joined: Tue May 13, 2008 2:05 pm

Re: Dreaded Error 15

Postby LinuxForever on Fri Jun 06, 2008 11:03 pm

merlwiz79 I changed root (hd1,0) to root (hd0,0) and it worked! It booted Mint and went into the desktop which is where I'm posting this from. I tried rebooting but the fix wasn't there so I had to type it in again. Is there anyway to make this fix permanent? Thankx very much for the help.
LinuxForever
Level 3
Level 3
 
Posts: 136
Joined: Tue May 13, 2008 2:05 pm

Re: Dreaded Error 15

Postby merlwiz79 on Fri Jun 06, 2008 11:09 pm

LinuxForever wrote:merlwiz79 I changed root (hd1,0) to root (hd0,0) and it worked! It booted Mint and went into the desktop which is where I'm posting this from. I tried rebooting but the fix wasn't there so I had to type it in again. Is there anyway to make this fix permanent? Thankx very much for the help.

Back up the /boot/grub/menu.lst and edit it there.
Code: Select all
title      Linux Mint , kernel 2.6.24-16-generic
root      (hd0,0)
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: Dreaded Error 15

Postby LinuxForever on Sat Jun 07, 2008 2:44 am

merlwiz59 Okay, I turned my computer off for about an hour and when I booted it up again I changed root (hd1,0) to root (hd0,0) and it started booting Mint, the progress bar went back and forth 5 times and the Mint boot went to a text screen and started booting mandriva on sda1. So I'm back to first base again. I can't boot into Mint.

I've been trying to find a fix for this Ubuntu bug since April, 28th when I D/L'ed an iso of Kubuntu-kde-4-8.04 and I'm beginning to lose the will to live.

Has anyone ever thought about a distro of Linux Mint based on Debian or Mandriva?? Just a thought. Ubuntu's based on Debian.
LinuxForever
Level 3
Level 3
 
Posts: 136
Joined: Tue May 13, 2008 2:05 pm

Re: Dreaded Error 15

Postby merlwiz79 on Sat Jun 07, 2008 5:44 am

LinuxForever wrote:merlwiz59 Okay, I turned my computer off for about an hour and when I booted it up again I changed root (hd1,0) to root (hd0,0) and it started booting Mint, the progress bar went back and forth 5 times and the Mint boot went to a text screen and started booting mandriva on sda1. So I'm back to first base again. I can't boot into Mint.

I've been trying to find a fix for this Ubuntu bug since April, 28th when I D/L'ed an iso of Kubuntu-kde-4-8.04 and I'm beginning to lose the will to live.

Has anyone ever thought about a distro of Linux Mint based on Debian or Mandriva?? Just a thought. Ubuntu's based on Debian.

Why does the hard drive order keep changing?
What type of hard drives do you have?
Seems the hard drive master and slave changed after you turn off the pc.
This is what hard drive grub is installed to.
Code: Select all
root      (hd0,1)

This is the hard drive the Linux install is on.
kernel /boot/vmlinuz-2.6.22-14-generic root=/dev/sda1 ro quiet splash
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: Dreaded Error 15

Postby damnitdan on Sat Jun 07, 2008 9:36 am

I had the very same problem. It's really frustrating. Isn't it? I suspect you need to fix up grub (menu.lst). I found in my case that grub was pointed to partitions which were WAY off. For example (hd2,8) when my target partition was (hd0,8). My Win-Xp was set to (hd1,1) when in fact is was at (hd2,0). Also there seems to be a seriously disparity btwn gusty and hardy distros. For example ALL my hard drives are seen as /dev/sd<something> on ubuntu804 whereas with 7.10 an ide drive was (as I expected) a /dev/hd<something>. So LinxMint4 (7.10) sees /dev/hda1 but Mint5 (8.04) see /dev/sdc1. Confused? I was. I should point out that my first drive (from bios perspective) is an 80G ide, then 2 300G sata drives. So when Mint4/Hardy sees my setup, they are as I expected hda, sda,sdb - thus grub sees (hd0,x) for /dev/hdax, etc, But with Mint5/Gusty they become sda,sdb, and then sdc (the first ide (ie pri.master drive) - Pretty gusty I'd say.

I believe you can boot up from your 048.iso live CD and mount the troubled partition. Then try sudo gedit (I'm guessing here) /media/<your troubled partition>/boot/grub/menu.lst and have a look at how the partitions have been configured. You'll probably find that they are messed up. I think this is an issue with 8.04. Keep in mind that grub sees drives and partitions from 0. (hd0.0) is your first hdrive first partition). If you need help with grub you could try this https://help.ubuntu.com/community/GrubHowto for starters or just google "grub howto". Good luck.
User avatar
damnitdan
Level 1
Level 1
 
Posts: 2
Joined: Sat Jun 07, 2008 7:58 am
Location: Anrprior, Ontario, Canada

Re: Dreaded Error 15

Postby LinuxForever on Sat Jun 07, 2008 3:14 pm

Merlwiz79 The first drive is a 40GB Seagate, Second drive 40GB Maxtor DiamondMax VL, third drive 120GB Western Digital WD1200JB.

One other thing, when I install a distro on hdd0,0 I set my bios to boot from that drive after the floppy and cdrom. When I install a distro on hdd1,0 I set my bios to boot from that drive after the floppy and cdrom so after installing the distro my computer will boot right into the new install.

One thing I learned about 8.04 is if I set bios to boot hdd0,0 the 8.04 installer sees my drives out of order. If I set bios to boot from hdd1,0 the 8.04 installer sees my drives in the correct order.


Damintdan Thankx for the linkx.

In searching I also found this one Super Grub Disk http://www.supergrubdisk.org/

And this one Grub From the Ground Up http://www.troubleshooters.com/linux/grub/grub.htm

I'm busy this weekend so I'll have to get back to this Monday. I really appreciate all the help guys.
LinuxForever
Level 3
Level 3
 
Posts: 136
Joined: Tue May 13, 2008 2:05 pm

Re: Dreaded Error 15

Postby 67GTA on Sat Jun 07, 2008 3:29 pm

It sounds like you are making things overly complicated by constantly switching the bios drive order. It would be a lot simpler to learn how to add grub menu entries for the other operating systems to the OS you prefer to boot to by default. Leave one as the primary, and let the grub for the default OS boot the other ones from it's grub menu.
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke
User avatar
67GTA
Level 6
Level 6
 
Posts: 1301
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: Dreaded Error 15

Postby damnitdan on Sat Jun 07, 2008 8:41 pm

67GTA wrote:It sounds like you are making things overly complicated by constantly switching the bios drive order. It would be a lot simpler to learn how to add grub menu entries for the other operating systems to the OS you prefer to boot to by default. Leave one as the primary, and let the grub for the default OS boot the other ones from it's grub menu.


I agree. Fooling with bios isn't the way to go. I might change the boot order if I'm in a bind - say to load up win-xp directly or something like that, but once I've got my drives physically configured, grub's menu.lst takes care of things. Unfortunately in this case, Gusty had a problem correctly defining the drive(s).
User avatar
damnitdan
Level 1
Level 1
 
Posts: 2
Joined: Sat Jun 07, 2008 7:58 am
Location: Anrprior, Ontario, Canada

Re: Dreaded Error 15

Postby merlwiz79 on Sat Jun 07, 2008 8:52 pm

damnitdan wrote:
67GTA wrote:It sounds like you are making things overly complicated by constantly switching the bios drive order. It would be a lot simpler to learn how to add grub menu entries for the other operating systems to the OS you prefer to boot to by default. Leave one as the primary, and let the grub for the default OS boot the other ones from it's grub menu.


I agree. Fooling with bios isn't the way to go. I might change the boot order if I'm in a bind - say to load up win-xp directly or something like that, but once I've got my drives physically configured, grub's menu.lst takes care of things. Unfortunately in this case, Gusty had a problem correctly defining the drive(s).

This was caused by you making the 2nd as the boot drive in BIOS.(I do this too)
This is not a Gusty bug as when you installed it used everything was correct.
1st hard drive(master) was sda 2nd(slave) sdb.
Anytime you do this it's going to be incorrect when you try to boot with grub.
You need to leave it in one order then edit grub to use it in that order.
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: Dreaded Error 15

Postby LinuxForever on Sun Jun 08, 2008 3:29 pm

damnitdan wrote:
67GTA wrote:It sounds like you are making things overly complicated by constantly switching the bios drive order. It would be a lot simpler to learn how to add grub menu entries for the other operating systems to the OS you prefer to boot to by default. Leave one as the primary, and let the grub for the default OS boot the other ones from it's grub menu.


I agree. Fooling with bios isn't the way to go. I might change the boot order if I'm in a bind - say to load up win-xp directly or something like that, but once I've got my drives physically configured, grub's menu.lst takes care of things. Unfortunately in this case, Gusty had a problem correctly defining the drive(s).


Okay, but my boot distro is mandriva and it's not setup by default to find/see other installed OS's. I was thinking may be I should reformat my drives with Mint and install it on sda and not install any other distros on this computer.

Does every drive in a linux box need it's own swap partition? Say I use sda for Mint, should I put a swap partition on my second drive and format the empty space with ext3 and do the same for my backup drive? I've spent the last year trying out different distros so I'm way behind on learning command line stuff but I'm really good at burning CD's.

The thing I like about having two distros installed is that if I mess up one distro everything I need to do all the things I do with linux are on the other installed distro so I don't lose any time. I can just switch drives with bios so even if the grub on the messed up distro isn't working I can count on the other installed distros grub to work. It's kind of like a failsafe system. And I can use Krusader to copy any files I need from the drive the messed up distro is on and copy them to the working distro and or my backup drive. I think of it as kind of a linux heaven really. The perfect answer to my daily computing needs. Every family should have one.
LinuxForever
Level 3
Level 3
 
Posts: 136
Joined: Tue May 13, 2008 2:05 pm

Re: Dreaded Error 15

Postby LinuxForever on Mon Jun 09, 2008 2:29 pm

I solved the problem with the drives being out of order and not being able to boot both distros from the grub on hdd0. I installed Mint 5 on sda and PCLOS 2007 on sdb. I installed PCLOS first then Mint 5. Of course that meant installing Mint 5 messed up the fstab file in PCLOS so I had to reinstall PCLOS. And when I tried to boot PCLOS from the Mint GRUB and it wanted to load the initrd file from hd0,0 but after I changed that to hd1,0 it loaded PCLOS with out any problems.

So the nasty Error 15 message is no more. Thankx very much for all your help guys. Linux Mint has the best forum!
LinuxForever
Level 3
Level 3
 
Posts: 136
Joined: Tue May 13, 2008 2:05 pm

Re: Dreaded Error 15

Postby blues-guy on Thu Jun 12, 2008 3:32 pm

Interesting re HD boot order problem.

I also am having Error 15 problem with one PC - see my post - "Mint 5 and mix of IDE and SATA HDs"
viewtopic.php?f=46&t=13472

You dont say whether your drives are IDE or SATA.
blues-guy
Level 2
Level 2
 
Posts: 58
Joined: Sun Dec 30, 2007 11:52 pm

Re: Dreaded Error 15

Postby LinuxForever on Thu Sep 18, 2008 8:09 am

blues-guy all my drives are IDE PATA drives. I recently changed the distros I had installed from Ubuntu and PCLOS 2007 to Ubuntu and Mint 5 KDE and then to just Mint 5 KDE. I repartitioned and reformatted my 3 hard drives with the PCLOS live CD to change the size of the root and one swap partitions because the set up I had before wasn't the best in the world.

I tried to install Ubuntu first, on the first hard drive. The installer didn't see the 3 drives in their correct order. I rebooted and ran the installer again and still it didn't see the drives in their correct order.

I used the PCLOS live CD to look at the drives as root and found "lost+found" files on each drive and a ".directory" file, so I deleted those and the other few files PCLOS likes to put on every drive PCLOS formats.

I ran the installer on the Ubuntu live CD again and it saw the drives in their correct order. After installing Ubuntu and rebooting my computer, there was no Error 15 message.

The bottom line is I never had the Error 15 message with Ubuntu and Mint until Ubuntu version 8.04. I don't know what Ubuntu did but I wish they had stayed with the installer set up Debian uses because I've never had any problems with the Debian installer. Nor, with the installer in Mandriva and distros based on it.

So, when you install Ubuntu, or any distro based on it, and the installer doesn't see your drives in their correct order, look for configuration files on the drives from a different distro that might interfere with the Ubuntu installer seeing the drives in their correct order.
LinuxForever
Level 3
Level 3
 
Posts: 136
Joined: Tue May 13, 2008 2:05 pm

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 14 guests