[SOLVED]Boot /Grub/ Partition problems

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

[SOLVED]Boot /Grub/ Partition problems

Postby xixorro on Wed Apr 24, 2013 8:15 pm

Hi to all. First of all I want to say that i am sorry if i am reposing, and that I a searched quite a bit on this problem.

I had my PC running Win 7 and Debian with grub2 being the boot loader. everything was OK. But I decided to use Mint instead of debian.

So I stupidly formatted all the ext and swap partition. I realized that I had messed up when Win 7 didn't boot. But no worries, my Mint live usb was ready.

I then proceed to install Mint, selected custom partitioning and created the following partitions
sda5 2GB SWAP
sda6 150MB ext4 /boot
sda7 10Gb ext4 /
sda8 40Gb ext4 /home

then selected for the boot loader to be installed in sda6
clicked next and noticed something, when I installed debian it detected the win7 installation and asked witch boot loader i would like.
No such thing happened this time, but i proceed.
after the installation completed I rebooted, removed the drive, and got grub restore. now no win7 nor mint.

So I plugged in the live USB and tried to fix the problem.

found this site and tried it:
http://community.linuxmint.com/tutorial/view/245

no success. got some error when trying to install grub (in sda6 , witch is supposed to be the boot partition, keep in mend that i am a newbie)

so i surfed some more , and landed at a chroot thingy, I then could install and update grub, on sda (no number after ?????), updated and rebooted.now grub appears on boot, but only win7 is there (thankfully).

I really need some help here.

Note: I don't know if this really matters but partition wizard shows all my ext partitions as logical
Last edited by xixorro on Thu Apr 25, 2013 11:12 am, edited 1 time in total.
xixorro
Level 1
Level 1
 
Posts: 6
Joined: Wed Apr 24, 2013 7:56 pm

Linux Mint is funded by ads and donations.
 

Re: Boot /Grub/ Partition problems

Postby kc1di on Wed Apr 24, 2013 8:32 pm

Hello xixorro and welcome to mint.

I would download and run boot repair found here:
https://help.ubuntu.com/community/Boot-Repair
instruction are right on the page.
good luck :)
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1472
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Boot /Grub/ Partition problems

Postby xixorro on Wed Apr 24, 2013 9:20 pm

kc1di wrote:Hello xixorro and welcome to mint.

I would download and run boot repair found here:
https://help.ubuntu.com/community/Boot-Repair
instruction are right on the page.
good luck :)


Thanks. typing on mint now.

I have two win7 entries now, on two diferente partitions.dont know why but at least its working now
xixorro
Level 1
Level 1
 
Posts: 6
Joined: Wed Apr 24, 2013 7:56 pm

Re: Boot /Grub/ Partition problems

Postby kc1di on Thu Apr 25, 2013 6:48 am

xixorro wrote:
kc1di wrote:Hello xixorro and welcome to mint.


I have two win7 entries now, on two diferente partitions.dont know why but at least its working now


I have two on mine also one of them is the recovery partition that came from the factory. it contains the OEM windows install data.
Glad it's working for you thought :)
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1472
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA


Return to Installation & Boot

Who is online

Users browsing this forum: nonymous and 17 guests