Grub reboots computer after selecting Mint from GRUB menu

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Grub reboots computer after selecting Mint from GRUB menu

Postby Zorba on Wed May 01, 2013 3:35 am

I have Installed Linux Mint 13 Mate 64bit alongside Linux Mint 14 Cinnamon 64bit to replace Linux Mint 14 Mate 64bit on a Dell Inspiron i3 because of a boot problem, which I'm having again; Occasionally, When trying to boot on the first OS, which is Linux Mint 13 Mata 64bit, the computer restarts then freezes at grub menu that I have to remove the battery and force it to boot into recovery mode then update grub :shock:

HELP
Image
User avatar
Zorba
Level 8
Level 8
 
Posts: 2279
Joined: Tue May 29, 2012 10:12 pm
Location: Tunisia

Linux Mint is funded by ads and donations.
 

Re: Grub reboots computer after selecting Mint from GRUB me

Postby hal8000 on Wed May 01, 2013 5:19 pm

A few things you can try:

Ideally you need to watch the boot messages to see where your machine gets stuck.
You can remove the "quiet" option in grub2 but easier still you may be able to press escape
ket to watch the boot messages.

When you install Mint13 it will overwrite grub2 installed by Mint 14.
If you can boot into Mint14 try sudo update-grub which may overwrite the boot loader
with grub2 from Mint 14.

If you had same problem with Mint 14 then you need to remove "quiet option" in grub2 menu
entry.
This can be more easily done with grub-customizer which works with Ubuntu 11.10/12.04/12.10/13.04
and Linux Mint 13/14 follow these instructions:

http://www.noobslab.com/2013/04/customi ... er-in.html

After installing in general options, (against your entries for linux mint) delete the quiet
kernel parameter, this will show boot messages.

Alternatively see if anything has been logged in /var/log/boot.log although if your system locks
on starting, the file may not get written to.

Restarting can also be due to overheating/memory issues, so if you suspect hardware, try running
Mint from a Live CD/DVD. This wont touch your hard drive and if freezes, you can suspect memory
and/or power supply overheating.
You could try removing and re-inserting memory (use anti static strap) if you are confident with
hardware.
User avatar
hal8000
Level 4
Level 4
 
Posts: 233
Joined: Sun May 04, 2008 2:04 pm
Location: UK

Re: Grub reboots computer after selecting Mint from GRUB me

Postby Zorba on Thu May 02, 2013 6:33 pm

I want to notify that my this happens only occasionally and I want to know if this is related to my hardware, to the dual-boot of 2 Linux distros or to a GRUB bug?

This is my /var/log/boot.log:

Code: Select all
fsck from util-linux 2.20.1
/dev/sda7: clean, 287211/5865472 files, 3513574/23437312 blocks
modem-manager[802]: <info>  ModemManager (version 0.5.2.0) starting...


modem-manager[802]: <info>  Loaded plugin ZTE


modem-manager[802]: <info>  Loaded plugin Option


modem-manager[802]: <info>  Loaded plugin Ericsson MBM


modem-manager[802]: <info>  Loaded plugin Samsung


modem-manager[802]: <info>  Loaded plugin Sierra


modem-manager[802]: <info>  Loaded plugin Generic


modem-manager[802]: <info>  Loaded plugin Gobi


modem-manager[802]: <info>  Loaded plugin Option High-Speed


modem-manager[802]: <info>  Loaded plugin AnyData


modem-manager[802]: <info>  Loaded plugin Longcheer


modem-manager[802]: <info>  Loaded plugin Huawei


modem-manager[802]: <info>  Loaded plugin Novatel


modem-manager[802]: <info>  Loaded plugin Linktop


modem-manager[802]: <info>  Loaded plugin SimTech


modem-manager[802]: <info>  Loaded plugin MotoC


modem-manager[802]: <info>  Loaded plugin X22X


modem-manager[802]: <info>  Loaded plugin Nokia


modem-manager[802]: <info>  Loaded plugin Wavecom


 * Setting sensors limits        * Starting mDNS/DNS-SD daemon[ OK ]

[ OK ]
 * Starting CUPS printing spooler/server[ OK ]
 * Stopping System V initialisation compatibility[ OK ]
 * Starting System V runlevel compatibility[ OK ]
 * Starting restore sound card(s') mixer state(s)[ OK ]
 * Starting ACPI daemon[ OK ]
 * Starting anac(h)ronistic cron[ OK ]
 * Starting save kernel messages[ OK ]
 * Starting CPU interrupts balancing daemon[ OK ]
 * Starting crash report submission daemon[ OK ]
 * Stopping restore sound card(s') mixer state(s)[ OK ]
 * Starting regular background program processing daemon[ OK ]
 * Starting deferred execution scheduler[ OK ]
 * Loading cpufreq kernel modules...       
[ OK ]
 * CPU0...         * CPU1...         * CPU2...         * CPU3...         * Stopping save kernel messages[ OK ]
 * CPUFreq Utilities: Setting ondemand CPUFreq governor...       
[ OK ]
 * Stopping anac(h)ronistic cron[ OK ]
speech-dispatcher disabled; edit /etc/default/speech-dispatcher
 * VirtualBox Additions disabled, not in a Virtual Machine
 * Starting MDM Display Manager mdm       
[ OK ]
saned disabled; edit /etc/default/saned
Image
User avatar
Zorba
Level 8
Level 8
 
Posts: 2279
Joined: Tue May 29, 2012 10:12 pm
Location: Tunisia

Re: Grub reboots computer after selecting Mint from GRUB me

Postby Zorba on Sun May 05, 2013 6:57 pm

Administrators HEEEEEEEEEEEEEEEEEEEEEEEEELP :roll: :?: :?: :?: :?:

Image
Image
User avatar
Zorba
Level 8
Level 8
 
Posts: 2279
Joined: Tue May 29, 2012 10:12 pm
Location: Tunisia

Re: Grub reboots computer after selecting Mint from GRUB me

Postby hal8000 on Mon May 06, 2013 3:59 pm

Intermittent faults are more difficult to fix.
Mint 14 will run from the DVD in kive mode.

If you can boot successfully from the Mint 14 DVD (you may have to try this many times) and it works
without problems, then it may possibly be down to grub2.

The grub2 version that ships with Mint14 should be newer, so perhaps this is the version to
have installed to your mbr.
User avatar
hal8000
Level 4
Level 4
 
Posts: 233
Joined: Sun May 04, 2008 2:04 pm
Location: UK


Return to Installation & Boot

Who is online

Users browsing this forum: dbvoss, Google Adsense [Bot] and 20 guests