Mint will not install on dev/sda/

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Mint will not install on dev/sda/

Postby EE_Aaron on Tue Jun 18, 2013 6:21 pm

I have a new H8-1520z desktop (AMD 970 chipset with RAID). It came with Windows 8 install on a HDD connected to SATA0 port. I want to install Linux Mint over windows (Linux only). I disabled the Windows 8 boot manager in bios, enable legacy boot and boot to Mint 15 live CD. The SATA0 drive is visible in GParted and I can edit partitions, etc. but for some reason I cannot get Mint to install to ANY drive connected to the SATA0 port. When in install, there is no option to choose the SATA0 (dev/sda) drive as boot partition. I have tried three different HDD’s connected to SATA0 but none are available for Linux install. Strangely, if I connect same HDD to any other SATA port, install works great. Besides disabling SATA0 and using another port, is there some solution for this? Could this be a driver issue, windows 8 thing...

thanks
EE_Aaron
Level 1
Level 1
 
Posts: 4
Joined: Tue Jun 18, 2013 6:11 pm

Linux Mint is funded by ads and donations.
 

Re: Mint will not install on dev/sda/

Postby eanfrid on Tue Jun 18, 2013 6:35 pm

/dev/sda will always be on the lower numbered SATA port you will use, so why bother if you connect your first (boot) drive on SATA1 ? However, I would rather check the BIOS parameters related to SATA0 and probably to any legacy PATA-related compatibility config here.
Main desktop: Debian GNU/Linux Wheezy 64bit w/custom 3.14 longterm kernel - MATE 1.8.1
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
User avatar
eanfrid
Level 7
Level 7
 
Posts: 1560
Joined: Mon Apr 30, 2012 2:49 am
Location: there is no place like ~

Re: Mint will not install on dev/sda/

Postby EE_Aaron on Tue Jun 18, 2013 6:44 pm

Thanks for the reply.
I could, as you suggest, avoid/disable the SATA0 port, but I need all four and really prefer to have boot drive on lowest assignment. I have poked-around the BIOS a lot and cannot find any setting that solves this. This is most likely something specific with this system and not with Mint, however it is very frustrating.
EE_Aaron
Level 1
Level 1
 
Posts: 4
Joined: Tue Jun 18, 2013 6:11 pm

Re: Mint will not install on dev/sda/

Postby DrHu on Tue Jun 18, 2013 6:57 pm

http://linuxaria.com/howto/how-to-measu ... ux?lang=en
--you can check the sata assignments being used, you do say Linux can sea the SATA0 device: at least the drive

Code: Select all
dmesg (see link above..) to check after it is booted to desktop:since you say gpart can read state of that device (sata0..)

--on a terminal screen

Hdparm is utiliy that can check the device for you as well.
--maybe put that utility on a usb syck if it isn't available on the install set (*.iso): I am guessing it probably isn't.

Possibly BIOS setting for sata device names/controller mode..
http://www.wikihow.com/Install-AHCI-Sup ... tallations
http://www.cyberciti.biz/faq/linux-sata ... recognize/
--an example

When windows OS was running, thne sata mode would have been available, or you could boot windows OS again and check if that install works, sees the sata0 device and the mode it is using..
http://en.wikipedia.org/wiki/Serial_ATA
    Advanced Host Controller Interface[edit]
    Advanced Host Controller Interface (AHCI) is an open host controller interface published and used by Intel, which has become a de facto standard. It allows the use of advanced features of SATA such as hotplug and native command queuing (NCQ). If AHCI is not enabled by the motherboard and chipset, SATA controllers typically operate in "IDE emulation" mode, which does not allow access to device features not supported by the ATA/IDE standard.
--that would be BIOS setting ahci mode..
User avatar
DrHu
Level 16
Level 16
 
Posts: 6599
Joined: Wed Jun 17, 2009 8:20 pm

Re: Mint will not install on dev/sda/

Postby EE_Aaron on Wed Jun 19, 2013 9:43 am

Thanks.

I can install other OS's (e.g. Windows 7) on SATA0 drive with no problem. I moved the target to SATA1-installed mint no problem. But minit will not boot-can't find file system. Geezzzz- last time I buy a preconfigured system. I really think it is some BIOS setting that cannot be changed by end-user. I have contacted HP, but I have little confidence that they will offer any solutions. I was told by others that windows 8 is evil-I can see why.
EE_Aaron
Level 1
Level 1
 
Posts: 4
Joined: Tue Jun 18, 2013 6:11 pm

Re: Mint will not install on dev/sda/

Postby EE_Aaron on Thu Jun 20, 2013 6:20 pm

So, this was a problem with the UEFI. I finally got Mint to install and boot. Here is how:

Installation:
1) in the UEFI disable secure boot, UEFI boot options, enable legacy boot as only option.
2) SATA0 seems to be only for UEFI secure boot (in my case), disable it and put the install HDD on another SATA port.
3) Boot to Live CD/USB and make sure Gparted can "see" your installation HDD.
4) Run install from Live CD/USB and chose "do something else"
5) Create a msdos partition table for installation HDD
6) continue as usual.

to boot after install:
If you can boot-great. You are done. If not...
1) It is most likely that grub/grub2 did not install properly for the UEFI to find the boot loader. Run Boot-repair from a bootable CD/USB.
EE_Aaron
Level 1
Level 1
 
Posts: 4
Joined: Tue Jun 18, 2013 6:11 pm


Return to Installation & Boot

Who is online

Users browsing this forum: lostfarmer and 17 guests