Mint Boot

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Mint Boot

Postby Pushkar on Sun Jun 22, 2008 1:34 pm

Hello, im running Mint via my WD External HDD, works fine by the way; with my main internal HDD running XP also working fine.

I just connect the Ext HDD when i want to just IM or just play with linux, but everytime I need to change my boot options so it boots from sdb1 instead of the default sda1.

Is there a way so it can automatically use the sdb1 partition instead of sda1.

Thanks.

(mint5)
Pushkar
Level 1
Level 1
 
Posts: 12
Joined: Sat Apr 19, 2008 3:15 am

Linux Mint is funded by ads and donations.
 

Re: Mint Boot

Postby Husse on Sun Jun 22, 2008 3:04 pm

This is an interesting question
I suppose you connect via USB - there are other methods and the answer is perhaps the same
What is controlling boot when the external disk is not connected?
I read this as you only have XP on the internal disk. If so then the boot order of the disks must be set so the external is first, which is somewhat confusing.....
Where do you change boot options? At boot time?
If you have a consistent boot order you could edit menu.lst
Code: Select all
gksu gedit /boot/grub/menu.lst

Then change as follows
title Linux Mint, kernel 2.6.24-16-generic
root (hd1,0)
kernel /boot/vmlinuz-2.6.24-16-generic root=/dev/sdb1 ro quiet splash
initrd /boot/initrd.img-2.6.24-16-generic

Maybe you should leave recovery mode as it is just in case
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Mint Boot

Postby Pushkar on Mon Jun 23, 2008 4:11 am

Yes, my boot device order is USB, CD and then HDD.
So obviously when the USB HDD isn't connected it will ignore USB, then CD if there is one in there, then goes to Windows HDD.

And the boot options I edit was at the Grub Menu where I change Linux Mint, kernel 2.6.24-16-generic options "root=/dev/sda1 ro quiet splash" to "root=/dev/sdb1 ro quiet splash"

I followed your instructions:

Code: Select all
title Linux Mint, kernel 2.6.24-16-generic
root (hd1,0)
kernel /boot/vmlinuz-2.6.24-16-generic root=/dev/sdb1 ro quiet splash
initrd /boot/initrd.img-2.6.24-16-generic


That lead to the disk being unmountable, and I followed the Recovery option, but changed the disk to sdb1 instead of the default sda1.
The disk was unmountable due to the option "root (hd1,0)" being changed from the "root(hd0,0)"

I therefore used this configuration:

Code: Select all
title Linux Mint, kernel 2.6.24-16-generic
root (hd0,0)
kernel /boot/vmlinuz-2.6.24-16-generic root=/dev/sdb1 ro quiet splash
initrd /boot/initrd.img-2.6.24-16-generic


Thanks for the help Husse, :)
Pushkar
Level 1
Level 1
 
Posts: 12
Joined: Sat Apr 19, 2008 3:15 am

Re: Mint Boot

Postby Husse on Mon Jun 23, 2008 8:13 am

Did this
Code: Select all
    title Linux Mint, kernel 2.6.24-16-generic
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.24-16-generic root=/dev/sdb1 ro quiet splash
    initrd /boot/initrd.img-2.6.24-16-generic

get you to to boot Mint?
Strange
You see (hd0,0) is sda1....
Which is either your internal disk or your external depending on how grub sees it....
So if it is the external disk I would expect sda1 to be correct
However this is complicated (and if we mix in Windows it can get hopelessly bizarre)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 14 guests