Mint on Bare Meta GPT & UEFI. OK, but where is grub?

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

Mint on Bare Meta GPT & UEFI. OK, but where is grub?

Postby pgmer6809 on Wed Sep 11, 2013 6:53 pm

Hi,
Most of the posts regarding UEFI and installs seem to center around working with Win7 or Win8.
I had a mobo with a bare disk. No OS at all.
Mobo is ASUS p8Z68-V/ProGen3
Disk is 1TB.
Mobo has UEFI BIOS.
I don't want or need windows on this system but I would like to be able to multiboot different flavors of Linux.

I booted a Nadia 64 bit Live CD.
Ran gparted and first created a GPT. I wanted the convenience of having more than just 4 partitions on the disk.
I then created the following partitions
Name fs size Label Flags
sda1 fat32 200MB EFI boot
sda2 none 5mb none biosgrub
sda3 ext4 10GB BOOT
sda5 swap 8GB swap
sda6 ext4 200GB home
sda7 ext4 20GB LinuxOS1
sda8 ext4 20GB LinuxOS2

I then proceeded to install Linux Mint Nadia 64 bit.
I specified the /, home, and boot partitions as well as the biosgrub partitions.
Much to my surprise the install went off without a problem. Very impressive.
After install I restart the computer and boot into MINT login screen.

I was a bit surprised not to get a grub menu, so one of the first things I did after the inevitable Update to packages, was to
a) check the contents of /boot. Sure enough there are the usual memtest86, etc. images in there.
b) so then I run
sudo update-grub.
It completed OK. and it created a /boot/grub/grub.cfg file. In that file there are entries for Mint 14, Mint 14 recovery mode, and memtest86.

i also did an
ls -l /sys/firmware
but there is no "efi" file or directory there.
I further mounted the /dev/sda1 partition on /boot/efi but it is empty. ls -al just shows the . and .. directories.

I power cycle the machine but still no grub menu.

Everything is fine except I have two or three questions:
1) Why did I not get a grub menu prompt at the boot up?
1b) If I cnt get a grub prompt will this affect my ability to multiboot different linux OS's?
2) Why is there no /sys/firmware/efi directory/file? My MOBO does not have the option of choosing efi or legacy boot that I can find.
I presume that in spite of the GPT, that the computer is booting in legacy BIOS mode and that is why I needed to create /dev/sda2 (the bios_grub partition).
3) The stuff on the net implies that the EFI partition (ESP) should contain bootloader's, ddrivers, a DOS like shell etc.
Where would I get that stuff and how would I put it in there?

4) Is all of the above due to the Mint 14 installer? ie. If i was using Mint 15 would it work better?

Thanks very much for any replies.

pgmer6809
pgmer6809
Level 3
Level 3
 
Posts: 103
Joined: Sun Mar 04, 2012 9:06 pm

Linux Mint is funded by ads and donations.
 

Re: Mint on Bare Meta GPT & UEFI. OK, but where is grub?

Postby wayne128 on Wed Sep 11, 2013 7:19 pm

1) Why did I not get a grub menu prompt at the boot up?


check to see if your /etc/default/grub has a timeout set to zero on the line

GRUB_TIMEOUT=5

if it is set to zero, change to something like 5, then do a update-grub and reboot to see what happen.
wayne128
Level 10
Level 10
 
Posts: 3325
Joined: Tue Jul 13, 2010 12:15 am

Re: Mint on Bare Meta GPT & UEFI. OK, but where is grub?

Postby pgmer6809 on Wed Sep 11, 2013 8:00 pm

Thanks for the suggestion.
I have since gone and installed MINT 15 alongside Mint 14.
Now I get a grub menu, complete with the memtest, Mint 14, Mint 15, and Mint 15 recovery mode entries.
So either
a) MINT 15 installer works better or
b) with only one Linux installed grub bypasses the menu on boot.
Either way looks that question is answered.

BTW I checked to see if there was a GRUB_TIMEOUT line in the /boot/grub.d/grug.cfg file and there is no such line.
Don't know if there was one before, and MINT 15 overwrote it or not. (Same /boot partition for both installs.)

thanks
greg morse.
pgmer6809
Level 3
Level 3
 
Posts: 103
Joined: Sun Mar 04, 2012 9:06 pm

Re: Mint on Bare Meta GPT & UEFI. OK, but where is grub?

Postby twbutler on Sun Oct 13, 2013 4:33 pm

Hello - I am trying to do pretty much the same install that you did, i.e. clean hard drive, installing only Linux Mint 15, no Windows dual boot.

My machine is a Dell Inspiron 660. It can be configured for UEFI boot or Legacy boot. I want to try GPT on the drive and I also wanted to use UEFI as I hear it is faster at booting the OS, so I have the BIOS configured for UEFI boot with Secure boot disabled. Does this sound right?

I then formatted the hard disk similar to you using GParted (see the attached image below). Your table formatting got squashed, so I was not sure which partition should be Flagged as "boot". I chose sda1 to Flag as boot. Is this correct? I also set sda2 as biosgrub, but I now think this might be a mistake (more later).
gpt partitions.png
GPT Partitions I configured


I then installed, and chose "Something else" under Installation Type. The installer found the partitions that GParted created. I had to click "Change..." for the following to specify that they be used as mount points: sda3, sda5, sda6, sda7, and sdb1. Note that I am using sda7 as a shared "data" partition (I plan to run Windows 7 as a VM). Sdb is a second drive to be used for backups. (See my two images below: )
install-specify-partitions1.png
Mint Installation dialog - #1

install-specify-partitions2.png
Mint Installation dialog - #2


The installation went fine, but then on reboot, the UEFI booter could not find the OS to boot it.

After reading some more online, I think the second partition (biosgrub) is not right for me. You have it, and say that you are using UEFI boot, but then later, you say that you "presume that in spite of the GPT, that the computer is booting in legacy BIOS mode and that is why I needed to create /dev/sda2 (the bios_grub partition)." This makes me think that I should NOT have a biosgrub partition. If I re-partition and this time create the same partitions minus biosgrub, would it work?

Thanks for any help...
Trevor
twbutler
Level 1
Level 1
 
Posts: 8
Joined: Sat Oct 12, 2013 5:30 pm

Re: Mint on Bare Meta GPT & UEFI. OK, but where is grub?

Postby twbutler on Sun Oct 13, 2013 6:15 pm

Well, I went ahead and tried what I asked about in my previous post: I recreated the partitions without the bios_grub one and reinstalled. Here are the new images of the partitions and how I configured them during the install:

gpt_partitions.png
second attempt - GPT partitions I configured


installation-specify-partitions1.png
Mint Installation dialog #1


installation-specify-partitions2.png
Mint Installation dialog #2


The install went fine again until I rebooted, and once again, I have the same problem that the UEFI booter is not finding the OS to boot it. I see a message like "No OS could be found".

I now see there is a note about EFI in the Mint 15 release notes:
If your system is using secureBoot, turn it off.

If you installed Linux Mint in Virtualbox in EFI mode and it cannot boot post-install, type "exit", choose "Boot Maintenance Manager", "Boot from file" and select EFI/linuxmint/grubx64.efi.

Post-installation, the EFI boot file is located in /boot/efi/EFI/linuxmint/grubx64.efi. If your system is unable to find this file, copy it to /boot/efi/boot/bootx64.efi (alternatively you can write "fs0:\EFI\linuxmint\grubx64.efi" into a /boot/efi/startup.nsh file).


I have Secure boot disabled - check. Not using VBox. The last paragraph looks like it might apply to me, though. However, I am not sure how to accomplish copying the EFI boot file as the note suggests when I cannot boot into the OS. I am now running the Mint 15 CD in live mode, and I can mount the /boot partition. There is a /boot/efi folder present, but it is empty! :-(

Any suggestions?
twbutler
Level 1
Level 1
 
Posts: 8
Joined: Sat Oct 12, 2013 5:30 pm

Re: Mint on Bare Meta GPT & UEFI. OK, but where is grub?

Postby srs5694 on Sun Oct 13, 2013 7:07 pm

pgmer6809 wrote:i also did an
ls -l /sys/firmware
but there is no "efi" file or directory there.
I further mounted the /dev/sda1 partition on /boot/efi but it is empty. ls -al just shows the . and .. directories.
...
2) Why is there no /sys/firmware/efi directory/file? My MOBO does not have the option of choosing efi or legacy boot that I can find.
I presume that in spite of the GPT, that the computer is booting in legacy BIOS mode and that is why I needed to create /dev/sda2 (the bios_grub partition).


Correct; all clues indicate that you're booting in BIOS/CSM/legacy mode, not in EFI/UEFI mode.

pgmer6809 wrote:3) The stuff on the net implies that the EFI partition (ESP) should contain bootloader's, ddrivers, a DOS like shell etc.
Where would I get that stuff and how would I put it in there?


See my Web page, Managing EFI Boot Loaders for Linux.

twbutler wrote:I was not sure which partition should be Flagged as "boot". I chose sda1 to Flag as boot. Is this correct? I also set sda2 as biosgrub, but I now think this might be a mistake (more later).


On a GPT disk, what parted or GParted reports as a "boot flag" is actually a partition type code for an EFI System Partition (ESP). This is unfortunate, because a parted/GParted "boot flag" has an entirely different meaning on MBR disks, which can lead to serious misunderstandings. Furthermore, other partitioning tools (such as gdisk or tools in other OSes) don't use the "boot flag" terminology to refer to ESPs. For these reasons, the "boot flag" terminology should be avoided except when describing how to create an ESP in parted or GParted; instead, it's best to think of and refer to the ESP as such. With that in mind, the ESP is a FAT partition (normally FAT32, in fact, although FAT16 can work in some cases) that holds boot loader files. The ESP can be any partition number and it can exist anywhere on the disk, although it's conventionally one of the first partitions on the disk.

The "bios_grub" flag sets the type code for a BIOS Boot Partition, which is where GRUB stores BIOS-mode boot files. It's perfectly acceptable to have both an ESP and a BIOS Boot Partition on the disk. The problems you had were not related to the mere presence of this partition; the Mint installer installs an EFI-mode boot loader (using an ESP) if it was booted in EFI mode, and a BIOS-mode boot loader (using a BIOS Boot Partition) if it was booted in BIOS/CSM/legacy mode. The trick is in controlling the boot mode of the installation medium. This is easy with some computers, hard with others, and impossible with some. When it's possible, the details of how to do it vary from one computer to another, so giving general instructions is impossible.

twbutler wrote:Note that I am using sda7 as a shared "data" partition (I plan to run Windows 7 as a VM).


In that case, I would instead recommend using networking tools like Samba to share files. Some virtual machines, like VirtualBox, make it very easy to set up this sort of thing. Sharing with a VM in this way will be much more flexible and reliable than sharing with a partition on your hard disk that's accessed directly from the VM.

twbutler wrote:The installation went fine, but then on reboot, the UEFI booter could not find the OS to boot it.


A number of problems can cause this symptom. See my EFI Boot Loaders page for general background information. Three solutions can often help with this problem:

  • Disable Secure Boot. Most computers that ship with Windows 8 ship with Secure Boot enabled, but this feature can often cause problems, so disabling it can often help. Unfortunately, the details of how to do this vary greatly from one computer to another, so you'll just have to figure out those details for yourself.
  • Download the USB flash drive or CD-R version of my rEFInd boot manager and prepare a boot medium from same. You should be able to boot from it, and it should show you at least one Linux option to boot a "vmlinuz*" file. Highlight it and hit F2 or Insert twice. This will produce a text-mode line editor. Add "ro root=/dev/sda4" to the list of options and hit Enter. If Linux boots, install the Debian package version of rEFInd. When you reboot, you should see rEFInd and you should be able to boot to Linux by selecting a "vmlinuz*" option and hitting Enter, without editing the options. If all this works, rEFInd replaces GRUB as your boot manager.
  • Run the Boot Repair tool from an emergency disc booted in EFI mode. The trick is to get it to boot in EFI mode, and details of how to do this vary from one computer to another. If you run Boot Repair in EFI mode, it should be able to get GRUB up and running in EFI mode; however, sometimes it fails.

You should definitely ensure that Secure Boot is not enabled as your first step. If that doesn't help, try either rEFInd or Boot Repair as your second step.

If you need more help, post the URL that Boot Repair generates. This will provide more technical details about your installation.
srs5694
Level 6
Level 6
 
Posts: 1020
Joined: Mon Feb 27, 2012 1:42 pm

Re: Mint on Bare Meta GPT & UEFI. OK, but where is grub?

Postby twbutler on Tue Oct 15, 2013 9:27 pm

Thank you for the tips. I had already disabled Secure boot, so that was not an issue.

I must admit, I do not know much about EFI/UEFI, but since I heard others were able to install Linux Mint on machines with UEFI using GPT, I figured I could do the same. I had heard from many sources that Mint "just works", so I expected it to work, and was taken aback when it didn't.

Perhaps it is Grub that is to blame. I gave your refind tool a try, using the bootable CD rom image. When I boot from CD, I see the neat graphical boot screen (I am just now understanding that EFI supports graphics and not just text like LILO and Grub). Anyway, refind located the Linux Mint ESP partition and presented an option to boot it. I also saw the option to boot a "vmlinuz*" file, but figured since Mint had been detected, the first option was the one to use. After selecting the Mint boot option, I then see the Grub menu. So, Grub is in play also. I select the first option to boot Mint, and then Mint boots up to the desktop.

So, there just appears to be a missing linkage between the EFI booter and Grub? Once I got into Mint, I figured I could fix this by performing the copy mentioned in the Mint release notes:
Post-installation, the EFI boot file is located in /boot/efi/EFI/linuxmint/grubx64.efi. If your system is unable to find this file, copy it to /boot/efi/boot/bootx64.efi (alternatively you can write "fs0:\EFI\linuxmint\grubx64.efi" into a /boot/efi/startup.nsh file).

I performed the copy, then I shut down Mint, removed the refind CD, and tried to reboot, thinking that the efi file would be found in the new location. It wasn't. :( I again see the message about no OS being found. So, the fix in the release notes did not work for me.

I wanted to see if I understand your suggestion to use refind instead of Grub - are you saying that once I use the CD to boot Mint, I can install the refind package using Software Manager and that the installation of the refind package will replace Grub? I have no objection to doing this, especially if it works. BTW, I searched for "refind" in Software Manager, but found nothing. I am still bothered by the fact that the the Mint installer did not set up the EFI mode boot loader correctly to begin with. I would prefer to have something that is in the Mint or Ubuntu repositories just for the sake of safety. Please do not be offended, but how can one know that refind does not contain malicious code, or spyware of some sort? That would be my only reservation about using it.

Also thanks for the reco of Samba. I was planning to use Samba already, but I suppose I can get rid of my /data partition and combine that space with /home, and place everything there. I assume Samba allws you to selectively share only certain folders, etc (I would not want to share all of /home with the Windows VM).
twbutler
Level 1
Level 1
 
Posts: 8
Joined: Sat Oct 12, 2013 5:30 pm

Re: Mint on Bare Meta GPT & UEFI. OK, but where is grub?

Postby srs5694 on Wed Oct 16, 2013 11:57 am

twbutler wrote:I had heard from many sources that Mint "just works", so I expected it to work, and was taken aback when it didn't.


There are many possible causes of such a failure. Sometimes the installer just gets something wrong, but other times there are bugs in the firmware. You mentioned that you've got a Dell computer, but I don't know offhand how common firmware bugs are on Dells, so I'm not sure if that might be a factor in your problems. If a firmware bug is an issue, there are ways around that, but IMHO it's better to try other approaches before implementing a workaround for a firmware bug, since such workarounds tend to be hackish and ugly.

To begin, try typing the following command:

Code: Select all
sudo efibootmgr -v


Post the output here, between code tags (as I used in presenting the command).

Perhaps it is Grub that is to blame. I gave your refind tool a try, using the bootable CD rom image. When I boot from CD, I see the neat graphical boot screen (I am just now understanding that EFI supports graphics and not just text like LILO and Grub). Anyway, refind located the Linux Mint ESP partition and presented an option to boot it. I also saw the option to boot a "vmlinuz*" file, but figured since Mint had been detected, the first option was the one to use. After selecting the Mint boot option, I then see the Grub menu. So, Grub is in play also. I select the first option to boot Mint, and then Mint boots up to the desktop.


You can boot more directly by selecting the vmlinuz* option -- at least in theory. If you've got a separate /boot partition, you'd need to either enter extra options or create a /boot/refind_linux.conf file. At the very least, it's worth testing a boot in this manner.

So, there just appears to be a missing linkage between the EFI booter and Grub?


That's what the "efibootmgr" command will reveal.

I wanted to see if I understand your suggestion to use refind instead of Grub - are you saying that once I use the CD to boot Mint, I can install the refind package using Software Manager and that the installation of the refind package will replace Grub?


More or less. I'd use "dpkg" to do the trick, as in "dpkg -i refind_0.7.4-1_amd64.deb". I'm not sure if Software Manager will work to install a package you download from outside the Mint repositories.

I am still bothered by the fact that the the Mint installer did not set up the EFI mode boot loader correctly to begin with.


There are still far too many bugs in the EFI world. Some of these are inside Linux, because Linux developers are still trying to wrap their brains around this EFI thing. Others are in specific EFI implementations, because firmware developers are still trying to wrap their brains around this EFI thing. Unfortunately, firmware bugs are harder to fix than OS bugs, so it's likely that we'll be living with EFI firmware bugs for years to come.

I would prefer to have something that is in the Mint or Ubuntu repositories just for the sake of safety. Please do not be offended, but how can one know that refind does not contain malicious code, or spyware of some sort? That would be my only reservation about using it.


I'm not offended. You can always examine the source code and compile it yourself. Of course, if you lack programming skill, that won't do much good, but the fact that people who are skilled at programming can do the same thing means that it's harder to hide malware inside an open source program such as rEFInd than in a closed-source program.

Also thanks for the reco of Samba. I was planning to use Samba already, but I suppose I can get rid of my /data partition and combine that space with /home, and place everything there. I assume Samba allws you to selectively share only certain folders, etc (I would not want to share all of /home with the Windows VM).


Yes, you can set up Samba shares for just some directories. There are lots of Samba tutorials on the net, as well as books on Samba.
srs5694
Level 6
Level 6
 
Posts: 1020
Joined: Mon Feb 27, 2012 1:42 pm

Re: Mint on Bare Meta GPT & UEFI. OK, but where is grub?

Postby twbutler on Wed Oct 16, 2013 9:22 pm

Here is the output you requested. It appears to me that there is only a boot entry for the CD drive:

Code: Select all
$ sudo efibootmgr -v
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001
Boot0001* UEFI: TSSTcorp DVD+/-RW SH-216CB   ACPI(a0341d0,0)PCI(1f,2)03120a000400ffff0000CD-ROM(0,4f,21c0)AMBO


I will need to check to see if my Dell BIOS firmware is up to date (in case there is a better newer version).

It is hard to believe that there are still bugs in EFI - hasn't it been out for three years now? I guess this should not surprise me. Can I add an entry to sources.list so that I can find refind using apt and get updates?

Thanks,
Trevor
twbutler
Level 1
Level 1
 
Posts: 8
Joined: Sat Oct 12, 2013 5:30 pm

Re: Mint on Bare Meta GPT & UEFI. OK, but where is grub?

Postby srs5694 on Thu Oct 17, 2013 12:29 pm

twbutler wrote:Here is the output you requested. It appears to me that there is only a boot entry for the CD drive:

Code: Select all
$ sudo efibootmgr -v
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001
Boot0001* UEFI: TSSTcorp DVD+/-RW SH-216CB   ACPI(a0341d0,0)PCI(1f,2)03120a000400ffff0000CD-ROM(0,4f,21c0)AMBO


This indicates that there are no entries for any boot loaders, just a default entry for your DVD drive. On a working installation, it should look more like this:

Code: Select all
$ sudo efibootmgr -v
Timeout: 10 seconds
BootOrder: 0001,0008,0006,0007
Boot0001* rEFInd Boot Manager   HD(2,1b8,64000,f1b7598e-baa8-16ea-4ef6-3ff3b606ac1e)File(\EFI\refind\refind_x64.efi)
Boot0006* Hard Drive   BIOS(2,0,00)SATA: ST32000542AS            .
Boot0007* CD/DVD Drive   BIOS(3,0,00)PATA: HP DVD Writer 1040r     .
Boot0008* INTERNAL EFI SHELL: ST32000542AS   ACPI(a0341d0,0)PCI(1f,2)ATAPI(1,0,0)HD(2,1b8,64000,f1b7598e-baa8-16ea-4ef6-3ff3b606ac1e)File(\EFI\BOOT\BOOTX64.EFI)


The last three of those entries are for BIOS-mode boots or the built-in firmware configuration tool, but the first one (Boot0001) is for a boot manager (rEFInd, in my case). The BootOrder variable specifies the order in which these entries are to be tried. Note that 0001 is the first of these, indicating that the computer will try to boot using rEFInd, and proceed to others only if rEFInd fails. Note that many details will vary between systems, so don't try to get yours to look exactly like this. The key is that the BootOrder line's first value points to an entry that points to whatever boot loader/manager file you want to use.

In your case, you can try creating a new NVRAM entry by using efibootmgr. The command would look something like this:

Code: Select all
sudo efibootmgr -c -d /dev/sda -p 1 -l \\EFI\\linuxmint\\grubx64.efi -L Mint


You may need to change some of these details, especially the "-d" and "-p" options (these collectively point to your ESP, which is /dev/sda1 in this example). Once you make this change, try typing "sudo efibootmgr -v" again to see if it "took." Even if it looks good, though, some computers erase their NVRAM entries when they reboot, so you could still have problems.

If this fails, then you're running into bugs -- either in efibootmgr (which is a real possibility because of changes to the kernel and efibootmgr; if your versions are out of sync, they won't work right) or in the firmware itself. See the Alternative Naming Options section of the rEFInd documentation for some suggestions on workarounds. The same tricks work with GRUB; or you can use Boot Repair to do some of this automatically. (You'll need to use the Advanced menu and select the option to back up and rename Windows boot files.)

I will need to check to see if my Dell BIOS firmware is up to date (in case there is a better newer version).


This is definitely worth doing. In fact, do it before you try anything else.

It is hard to believe that there are still bugs in EFI - hasn't it been out for three years now? I guess this should not surprise me.


EFI has been around for about ten years, in fact. The troubles have multiple causes. One is that, until the release of Windows 8, EFI was relatively rare, which means that it's seen very little testing in the real world. Another problem is that EFI is big -- it's about as big as the Linux kernel, minus its drivers. This means there's plenty of space in which bugs can hide. Another issue is that it's open source, but every firmware vendor has forked their own proprietary version, so there are lots of implementation-specific bugs that have crept in. This last issue is maddening to people like me who try to write EFI applications, since what works fine on one computer can fail miserably on another one. Another issue is that most manufacturers test with Windows and then stop, so bugs that don't affect Windows get passed through.

Can I add an entry to sources.list so that I can find refind using apt and get updates?


I'm afraid not.
srs5694
Level 6
Level 6
 
Posts: 1020
Joined: Mon Feb 27, 2012 1:42 pm

Re: Mint on Bare Meta GPT & UEFI. OK, but where is grub?

Postby twbutler on Fri Oct 18, 2013 5:34 pm

OK...
Code: Select all
$ sudo efibootmgr -c -d /dev/sda -p 1 -l \\EFI\\linuxmint\\grubx64.efi -L "Linux Mint 15"
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0003,0001,0002,0000
Boot0000  P4: TSSTcorp DVD+/-RW SH-216CB
Boot0001* UEFI: TSSTcorp DVD+/-RW SH-216CB
Boot0002  P0: WDC WD1002FAEX-00Z3A0     
Boot0003* Linux Mint 15

$ sudo efibootmgr -v
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0003,0001,0002,0000
Boot0000  P4: TSSTcorp DVD+/-RW SH-216CB   Vendor(99e275e7-75a0-4b37-a2e6-c5385e6c00cb,)
Boot0001* UEFI: TSSTcorp DVD+/-RW SH-216CB   ACPI(a0341d0,0)PCI(1f,2)03120a000400ffff0000CD-ROM(0,4f,21c0)AMBO
Boot0002  P0: WDC WD1002FAEX-00Z3A0        Vendor(99e275e7-75a0-4b37-a2e6-c5385e6c00cb,)
Boot0003* Linux Mint 15   HD(1,800,64000,8f8690ca-00d4-433e-9f1c-49306bf89209)File(\EFI\linuxmint\grubx64.efi)

Going to reboot now and try it...
twbutler
Level 1
Level 1
 
Posts: 8
Joined: Sat Oct 12, 2013 5:30 pm

Re: Mint on Bare Meta GPT & UEFI. OK, but where is grub?

Postby twbutler on Fri Oct 18, 2013 5:45 pm

Good news - it seems to work now. I can boot without the refind CD - after the Dell logo the Grub menu comes up now and I can hit the first option to boot into Mint.

BTW, I also upgraded my machine's firmware. The BIOS had a later version available. I am not sure if that made any difference or not, but better to have the latest.

Thank you for your help. I will keep refind in mind in case of any future problems. Your help was very valuable.

Regards,
Trevor
twbutler
Level 1
Level 1
 
Posts: 8
Joined: Sat Oct 12, 2013 5:30 pm

Re: Mint on Bare Meta GPT & UEFI. OK, but where is grub?

Postby twbutler on Sun Mar 16, 2014 9:50 pm

Due to a hard drive problem, I had to reinstall (Linux Mint 16). I remembered this thread and wanted to update it for any interested.

Here is my latest partition layout (from using GParted):

gpt-partitions_gparted.png
Partitions using GParted for GPT setup

Note that /dev/sda1 is the EFI Boot partition and it has a flag of "boot".

I also finally figured out why my previous installation attempts had the issue of the OS not being found on system reboot. I went through the Mint installer dialogs using "Something Else" as before, but this time, I set "Device for boot loader installation" to be /dev/sda1 (i.e. the EFI boot partition), rather than the default of /dev/sda. I got that from reading a few other forum posts. When I did this, the install worked fine and Mint booted as soon as the machine restarted. It would be nice if the installer could be enhanced to make it easier for folks to perform a GPT/UEFI installation without getting caught by things like this. I hope this is of help to others following this post.
twbutler
Level 1
Level 1
 
Posts: 8
Joined: Sat Oct 12, 2013 5:30 pm

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: mspaint and 21 guests