Can I stop gRUB from loading every time?

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

Can I stop gRUB from loading every time?

Postby dcora87 on Sat Oct 12, 2013 9:53 pm

I know that with my Cinnamon install, that gRUB didn't load before every time. But it does now with KDE and I know it's not a big deal but I just want it load if I want it to if that makes sense
dcora87
Level 1
Level 1
 
Posts: 9
Joined: Sat Oct 12, 2013 9:41 pm

Linux Mint is funded by ads and donations.
 

Re: Can I stop gRUB from loading every time?

Postby nerdtron on Wed Oct 16, 2013 11:18 pm

What do you mean it doesn't load and it loads? Grub always loads no matter what version of mint you use.
You mean you see it on boot and wait for about 10 seconds?

Then you should edit the grub menu to lessen your wait time.
Code: Select all
sudo nano /etc/default/grub

Find the line GRUB_TIMEOUT = 10 and change the value to 1 or 0 so that grub will only show for about 1 sec.
Then update grub
Code: Select all
sudo update-grub

After that try rebooting and see it it works.
"I learned a lot from repeatedly breaking my system and then reinstalling. Oh, and a lot of GOOGLE searches too!"
User avatar
nerdtron
Level 4
Level 4
 
Posts: 456
Joined: Sun Jan 31, 2010 10:46 am

Re: Can I stop gRUB from loading every time?

Postby Sekles Bernhard on Thu Oct 17, 2013 1:23 am

I installed Ubuntu but now I don't want to have to choose between Windows and Ubuntu,rc heli model, I just want Windows to start up unless I change it so just Ubuntu starts up.It's kind of annoying having to choose every time.
Sekles Bernhard
Level 1
Level 1
 
Posts: 1
Joined: Thu Oct 17, 2013 1:20 am

Re: Can I stop gRUB from loading every time?

Postby piovrauz on Thu Oct 17, 2013 9:11 am

I have a question about this too: when I installed, mint15 (64bit, efi, secureboot off) would boot without showing grub at all, and with a nice green mint logo.

I hit the special key that makes grub menu pop up while rebooting, and I while in the grub command line, I did a ls. Then rebooted.
Now not only the grub menu appears for 5 seconds, but the boot process is verbose, no more mint logo.

I tried to use the suggestion here (sudo nano /etc/default/grub, GRUB_TIMEOUT = 1, save, sudo update-grub) but I don't have the /etc/default/grub file at all.
I'm puzzled.
piovrauz
Level 1
Level 1
 
Posts: 47
Joined: Mon Oct 24, 2011 11:34 am

Re: Can I stop gRUB from loading every time?

Postby srs5694 on Thu Oct 17, 2013 12:03 pm

First, it's important to distinguish between a BIOS-mode installation and an EFI-mode installation. Most computers sold until mid-2011 used BIOS firmware, which means that they necessarily use the BIOS version of GRUB or some other BIOS boot loader. Beginning in mid-2011, though, manufacturers began switching from BIOS to EFI (although most confuse matters by using the acronym "BIOS" to refer to their firmware). EFI-based computers use EFI-mode boot loader natively, although most of them can also use BIOS-mode boot loaders (often called "legacy-mode" or "CSM-mode" in this context). With the release of Windows 8, most computers now boot Windows in EFI mode, although if you've removed or re-installed Windows on such a computer, all bets are off. See this page for information on how to determine your boot mode. Understanding this detail is important because your boot mode determines the boot loaders you can use, and to some extent how they're configured.

Second, if you boot Linux, you must use either GRUB or some other Linux boot loader. (Versions of GRUB are available for both BIOS and EFI.) Mint installs GRUB 2 by default, but if the installer detects no other OS, it may set the default entry to boot Mint with a timeout of 0, so you won't notice GRUB working. If the installer detects another OS, or if you've got multiple kernels, chances are the timeout will be set to a higher value (I don't recall what the default is, offhand), so you'll see a GRUB menu.

Adjusting GRUB defaults can be tricky because they're spread across various files, which are then read by the "grub-mkconfig" or "update-grub" scripts and assembled into the actual GRUB configuration file (typically /boot/grub/grub.cfg, although it can be elsewhere with some configurations). The most notable GRUB configuration files are /etc/default/grub and most of the files in the /etc/grub.d directory. (Note that's /etc/grub.d, not /etc/grub.) The /etc/default/grub file holds the default entry and timeout values (GRUB_DEFAULT and GRUB_TIMEOUT, respectively).

In some cases, it makes sense to abandon GRUB 2 entirely in favor of another boot loader or boot manager. This is especially true if you're having problems getting GRUB 2 to do what you want -- it's finicky and difficult to configure beyond a few basics. On a BIOS-based computer, GRUB Legacy, LILO, and SYSLINUX are all alternatives. They're all simpler and easier to configure "from scratch" than GRUB 2, but because they aren't integrated as tightly into Mint as GRUB 2, these alternatives can actually be harder to set up -- you'll need to do stuff manually that's done automatically by support scripts for GRUB 2. Under EFI, a patched version of GRUB Legacy, ELILO, SYSLINUX, gummiboot, and rEFInd are all possibilities. Of these, rEFInd is likely to be the easiest to set up, since it scans for bootable OSes and creates a menu dynamically rather than relying on a configuration file to spell out every detail. The others, like the BIOS alternatives, are easier to configure than GRUB 2 in a theoretical sense, but in practice the fact that Mint explicitly supports GRUB 2 can make it easier to use -- until something goes wrong with GRUB 2!
srs5694
Level 6
Level 6
 
Posts: 1020
Joined: Mon Feb 27, 2012 1:42 pm

Re: Can I stop gRUB from loading every time?

Postby piovrauz on Thu Oct 17, 2013 12:33 pm

@ srs5694: you are everywhere! XD
My notebook is new, has windows 8 preinstalled (EFI-GPT). I installed mint 15, so I'm using the grub(efi) shipped with mint15.
It boots in EFI mode ("linuxmint" is first entry on my FW boot order).

Before giving that "ls" on the grub commandline (to check partitions) grub indeed skipped the menu and went straight into mint (linux kernel).
Now it shows it. Strange.

After that command I added the windows 8 menu entry to grub: I did edit the /etc/grub.d/40_custom and did update-grub. (ref, arclinux wiki),
It works, so right now I don't care if the menu appears, but I find strange that there's no /etc/default/grub (I think I do need it to add some options, like the timeout for example).

Side note, the rEFInd docs are bookmarked since day0, there's a lot of pertinent info there, I think I read like 60% of them. ;)
piovrauz
Level 1
Level 1
 
Posts: 47
Joined: Mon Oct 24, 2011 11:34 am


Return to Installation & Boot

Who is online

Users browsing this forum: mihai88_ and 22 guests