Dual boot with Windows 8 minor issue

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Dual boot with Windows 8 minor issue

Postby blindcorp on Sat Oct 12, 2013 10:32 pm

I am currently running Olivia on a Toshiba Satellite with Windows 8 also installed. Both systems work well, but I still have to change BIOS's boot mode to UEFI manually if I want to boot Windows. This isn't a problem currently, but I am considering installing Solaris as well for compatibility with the machines at my current job. How can I get grub to recognize all systems installed and give me the option to boot from any system without having to manually change any BIOS settings every boot? Much thanks,
-Ben
blindcorp
Level 1
Level 1
 
Posts: 3
Joined: Sat Oct 12, 2013 10:23 pm

Linux Mint is funded by ads and donations.
 

Re: Dual boot with Windows 8 minor issue

Postby srs5694 on Sun Oct 13, 2013 7:16 pm

blindcorp wrote:I am currently running Olivia on a Toshiba Satellite with Windows 8 also installed. Both systems work well, but I still have to change BIOS's boot mode to UEFI manually if I want to boot Windows. This isn't a problem currently, but I am considering installing Solaris as well for compatibility with the machines at my current job. How can I get grub to recognize all systems installed and give me the option to boot from any system without having to manually change any BIOS settings every boot? Much thanks,


Do you know if Solaris supports an EFI-mode installation? If not, I know of only three ways to get this to work:

  • Use the firmware's built-in boot manager to switch between EFI-mode and BIOS-mode boot loaders. This is what you're doing now.
  • Install my rEFInd boot manager, which supports both direct EFI-mode boots and boots via a BIOS-mode boot loader. To get the latter working, though, you must uncomment the "scanfor" line in the refind.conf configuration file and ensure that "hdbios" is among the options. Furthermore, this feature doesn't work on all EFIs, although it does work on most modern ones.
  • Convert your partition table from GPT to MBR and either re-install Windows in BIOS mode or convert your existing Windows installation to boot in BIOS mode. Converting Windows is theoretically possible, but I don't know the exact procedure offhand, and I don't have a pointer to a Web site that describes it.

Of the three, rEFInd is likely to be the easiest way to go. If you're booting Linux in BIOS mode now, I recommend either using the USB flash drive or CD-R version to boot Linux in EFI mode (you should see a directory called /sys/firmware/efi) and then install the Debian package version; or install rEFInd from Windows, being sure to add the EFI driver for whatever filesystem holds your kernels in /boot. The end result should be that rEFInd will boot both Windows and Linux in EFI mode, meaning that a BIOS-mode Solaris should be able to take over the MBR's boot code area without creating new problems.
srs5694
Level 6
Level 6
 
Posts: 1014
Joined: Mon Feb 27, 2012 1:42 pm

Re: Dual boot with Windows 8 minor issue

Postby blindcorp on Thu Oct 17, 2013 5:51 am

I have tried to install rEFInd using the install.sh script, however install.sh returns that //boot/efi is not on a VFAT file system. /boot, however, is on an ext4 filesystem. How can I proceed? Do I need to manually install under Windows instead? Thanks.
blindcorp
Level 1
Level 1
 
Posts: 3
Joined: Sat Oct 12, 2013 10:23 pm

Re: Dual boot with Windows 8 minor issue

Postby srs5694 on Thu Oct 17, 2013 12:05 pm

blindcorp wrote:I have tried to install rEFInd using the install.sh script, however install.sh returns that //boot/efi is not on a VFAT file system. /boot, however, is on an ext4 filesystem. How can I proceed? Do I need to manually install under Windows instead? Thanks.


You need to mount your EFI System Partition (ESP) to /boot/efi. (You may need to create that directory first.) Your ESP is a FAT partition that will show up in parted or GParted as having its "boot flag" set, or under gdisk as having a type code of EF00. It's usually one of the first two or three partitions on the disk, but it doesn't have to be that.
srs5694
Level 6
Level 6
 
Posts: 1014
Joined: Mon Feb 27, 2012 1:42 pm

Re: Dual boot with Windows 8 minor issue

Postby blindcorp on Thu Oct 17, 2013 10:53 pm

rEFInd is working, and I can boot both Mint and Windows 8 with my boot mode set to EFI. However, to boot Mint I must select the vmlinuz option in refind rather than the option labeled "Linux Mint." Mint works fine booting the kernel this way, except now the X server boots automatically on startup. With grub I had edited grub.conf to boot in text mode only, so that I could choose to start and stop Xwindows at my leisure. Is there a way I can configure rEFInd to allow the same? Thanks so much for all your help and your awesome software!
blindcorp
Level 1
Level 1
 
Posts: 3
Joined: Sat Oct 12, 2013 10:23 pm

Re: Dual boot with Windows 8 minor issue

Postby srs5694 on Fri Oct 18, 2013 10:31 pm

blindcorp wrote:rEFInd is working, and I can boot both Mint and Windows 8 with my boot mode set to EFI. However, to boot Mint I must select the vmlinuz option in refind rather than the option labeled "Linux Mint."


The "Linux Mint" option is probably trying to boot GRUB. If it's not working, you can remove it either by removing GRUB from the ESP (probably in /boot/efi/EFI/linuxmint) or by editing /boot/efi/EFI/refind/refind.conf and using the "dont_scan_files" or "dont_scan_dirs" options to remove Mint's version of GRUB from the menu. You can also set the default option in refind.conf by using the "default_selection" option -- for instance, "default_selection vmlinuz" sets it to boot the most recently installed kernel file by default.

Mint works fine booting the kernel this way, except now the X server boots automatically on startup. With grub I had edited grub.conf to boot in text mode only, so that I could choose to start and stop Xwindows at my leisure. Is there a way I can configure rEFInd to allow the same? Thanks so much for all your help and your awesome software!


Yes; you can edit your kernel options in /boot/refind_linux.conf. If that file doesn't exist, run the mkrlconf.sh script that came with rEFInd. (If you installed the Debian package, it should be on your path, so just type "sudo mkrlconf.sh".)
srs5694
Level 6
Level 6
 
Posts: 1014
Joined: Mon Feb 27, 2012 1:42 pm


Return to Installation & Boot

Who is online

Users browsing this forum: lawrencep, Mute Ant and 22 guests