Mint 16 installer crash starting X

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Mint 16 installer crash starting X

Postby strowger on Tue Dec 03, 2013 5:17 am

Hi,

I'm trying to install Mint 16 MATE edition on an Asus X102BA laptop. This has AMD Radeon 8180G graphics, which appear to be causing a problem here.

The installer starts to boot correctly from a USB stick, but crashes when starting X.

I get a message "Failed to start the X server". I've tried booting the installer into compatability mode but that has the same problem.

Xorg.log: https://gist.github.com/anonymous/7766412
dmesg output: https://gist.github.com/anonymous/7766396
lsusb output: https://gist.github.com/anonymous/7766401
lspci output: https://gist.github.com/anonymous/7766404

Any suggestions appreciated.

Cheers
strowger
Level 1
Level 1
 
Posts: 2
Joined: Tue Dec 03, 2013 5:01 am

Linux Mint is funded by ads and donations.
 

Re: Mint 16 installer crash starting X

Postby strowger on Wed Dec 04, 2013 7:26 am

I've resolved this as follows:

1. Boot the installer with the kernel commandline options "nomodeset xforcevesa" and allow it to run.

2. The first boot of the installed system will fail in the same way (can't start X). Log in as root after this and edit the kernel commandline in /etc/default/grub to add "nomodeset xforcevesa" (and optionally remove "quiet" and "splash" if you don't find those useful - this provides logging to the screen in place of the boot graphic).

3. Run "update-grub" and then reboot.

The system performance is acceptable in this mode.

It's possible, but optional, to install the fglrx (binary blob, non-free) drivers. Note that if you do this, you're more likely to have trouble with upgrades (to new driver versions, or newer versions of Mint) in the future. I did this as follows:

1. apt-get update && apt-get dist-upgrade
2. apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
3. apt-get install fglrx-updates
4. amdconfig --initial
5. edit the kernel commandline in /etc/default/grub and remove "nomodeset xforcevesa" if they were set.
6. Run "update-grub" and then reboot.
strowger
Level 1
Level 1
 
Posts: 2
Joined: Tue Dec 03, 2013 5:01 am


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 11 guests