??? ??? error while installing Linux 16 Cinnamon

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

??? ??? error while installing Linux 16 Cinnamon

Postby tinyflames on Mon Jan 06, 2014 12:24 am

I have been trying to install Linux Mint 16 on my computer. I get to the part just after the Partition configuration, and I get an error that comes up as just questions marks. It looks exactly like this " ??? ???" Not really sure why it is doing this, but it does freeze the installation process right there, and i cannot go any further.

I was trying to do a fresh install on my laptop, and erase everything that was on my computer. I have already backed up everything, so I am not worried about losing anything on my computer as well as not worried about any previous operating systems.

My computer is a MSI Laptop with a first generation Core i7 processor, with 2 1tb of hard disk space, 6gb of ram, nvidia gtx 825m GPU with 1 gb decitaded memory.

Any insight into this problem would be great.
tinyflames
Level 1
Level 1
 
Posts: 9
Joined: Wed Jan 01, 2014 9:15 pm

Linux Mint is funded by ads and donations.
 

Re: ??? ??? error while installing Linux 16 Cinnamon

Postby computerbob on Mon Jan 06, 2014 1:02 am

I haven't seen that yet and I've done a lot of Mint installs.

Just for fun make sure the ram and hdd are ok.

Boot from a live cd of just about any linux distro
Run memtest 100%

Esc and boot to live cd desktop
Open Menu
Find Disks (aka Gnome-disk-utility)
All drives should say "Disk is OK"
Any bad sectors means replace the drive.

If all that is ok, I would burn my iso to a dvd and do a "something else" Install
I'd make a new partition table first. Hopefully that would clear out the partition section of the first 512 bytes of the boot sector. But if I had a boot sector virus, I'd have had to write zeros to that area.

That would be done by writing
sudo dd if=/dev/zero of=/dev/sda bs=512 count=1
in terminal. But that's usually not necessary, and I'd do that in a gparted live cd.

Back to the fresh install: After making a new partition
On the install screen
right under - + change
Device for bootloader installation
Hit the arrow on the right
pick your target sda not sda1
You want the grub to be in the boot sector of the drive.

If you're dual booting You can load the linux /, swap, and /home in an extended partition.

If your doing a fresh install in a Win8 computer, You may have to disable secure boot in bios. This is a subject with which I am not familiar.
re http://www.rodsbooks.com/linux-uefi/
computerbob
Level 4
Level 4
 
Posts: 284
Joined: Wed Jan 01, 2014 1:55 pm

Re: ??? ??? error while installing Linux 16 Cinnamon

Postby tinyflames on Mon Jan 06, 2014 2:02 am

I am working on the memory test right now, just out of curiosity though, I have 2 hard drives in raid 0. Could that have any impact on this issue.
tinyflames
Level 1
Level 1
 
Posts: 9
Joined: Wed Jan 01, 2014 9:15 pm

Re: ??? ??? error while installing Linux 16 Cinnamon

Postby computerbob on Mon Jan 06, 2014 2:18 am

How do you know that those drives are good? I would never use raid 0 because error recovery is impossible. SSDs are faster. I would load my OS and programs to an SSD and use a spinning drive for file storage.
computerbob
Level 4
Level 4
 
Posts: 284
Joined: Wed Jan 01, 2014 1:55 pm

Re: ??? ??? error while installing Linux 16 Cinnamon

Postby tinyflames on Mon Jan 06, 2014 2:33 am

I didn't set it up that way. It came like that from the factory, and I am thinking about taking it down, seeing as how the are no longer any partitions on it. There wasn't any errors on the drive that I am aware of when my computer had windows 7 still installed.
tinyflames
Level 1
Level 1
 
Posts: 9
Joined: Wed Jan 01, 2014 9:15 pm

Re: ??? ??? error while installing Linux 16 Cinnamon

Postby tinyflames on Mon Jan 06, 2014 2:47 am

I got rid of the raid. Is there a way that these drives should be partitioned, as far as root, home, swap? I am not dealing with the headache of dual booting, I have other computers to use if I want a different OS.

Right now I have 2 physical drives on my computer instead of the raid.
tinyflames
Level 1
Level 1
 
Posts: 9
Joined: Wed Jan 01, 2014 9:15 pm

Re: ??? ??? error while installing Linux 16 Cinnamon

Postby computerbob on Mon Jan 06, 2014 8:36 am

Make sure Disks says both drives are ok.

I always do the "something else" install. Make a new partition table on each drive. On the first drive / = 12GB ext4, swap=amount of ram, /home is the rest ext4. You can format the 2nd drive ext4 now if you like.
computerbob
Level 4
Level 4
 
Posts: 284
Joined: Wed Jan 01, 2014 1:55 pm

Re: ??? ??? error while installing Linux 16 Cinnamon

Postby tinyflames on Mon Jan 06, 2014 12:59 pm

I took down the raid and it installed like a charm. I put the root and swap on the first hard drive and put the home on the second hard drive (as I will be replacing the drives in this computer probably with a SSD for the first drive). It just seemed easier that way, like I said I uninstalled windows so I have 2 500gb hard drives dedicated to this install.

Also I am using this as an experiment for Linux gaming and will probably quite a few programs installed so I wanted a lot of space for the program files (which I found out go into the root partition.)

Thank you for your insight, very much appreciated!
tinyflames
Level 1
Level 1
 
Posts: 9
Joined: Wed Jan 01, 2014 9:15 pm

Re: ??? ??? error while installing Linux 16 Cinnamon

Postby bcd on Mon Jan 06, 2014 4:54 pm

I ran into that weird error dialog, also. I was NOT using raid (I was using encrypted partitions). I posted a screen shot and my log files here
bcd
Level 1
Level 1
 
Posts: 2
Joined: Wed Jan 01, 2014 5:37 pm

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: Bing [Bot] and 17 guests