Screen goes black when booting MINT

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Screen goes black when booting MINT

Postby oceanfirehawk on Mon Jan 06, 2014 2:14 pm

Hello everyone,

I try either by USB installer or DVD to install the latest 64 bit version of mint on my Lenovo. However, after the boot screen that allows me to select to boot Linux mint, the screen goes black. The computer is still booting Mint, because I can hear my PC going crazy. However, the screen never comes back. I have a NVIDIA GEforce GT 650M. Any ideas?
oceanfirehawk
Level 1
Level 1
 
Posts: 8
Joined: Tue Oct 27, 2009 11:02 am

Linux Mint is funded by ads and donations.
 

Re: Screen goes black when booting MINT

Postby computerbob on Mon Jan 06, 2014 2:46 pm

Try installing in compatibility mode. They have to have that in there for something.
computerbob
Level 4
Level 4
 
Posts: 284
Joined: Wed Jan 01, 2014 1:55 pm

Re: Screen goes black when booting MINT

Postby aligorith on Mon Jan 06, 2014 11:48 pm

Chances are, if this laptop is relatively new then you're running into Nvidia Optimus support issues.

Specifically, by default, Linux Mint will try to use the open source "Nouveau" drivers, which are a fat lot of use when confronted with modern Nvidia cards in optimus setups. To actually get things booting, you'll need to add "nouveau.modeset=0" (without the " s) to the boot instruction that GRUB uses to start Linux.

Here's how I got it working my HP with Nvidia GeForce 740M
2) Booting into Linux from GRUB(2)
If you've done everything right, when you reboot, you should be presented with a black screen, with white/gray lettering on it, and a list of items drawn inside a simple box. The top of the screen should say something to the effect of "GRUB 2.xxx-ubuntu" or similar.

Unless you have a radically different setup (mainly, no NVidia card, or perhaps an ATI instead), your mileage may vary a bit here, and you may be able to boot into Linux with either one of the first two entries. But, chances are, neither is going to work - i.e. you'll be left staring at a black screen, with an unresponsive machine that you'll have to hard reset (i.e. hold down the power button until you hear a "blip" sound, and then power it back up again).

To get Linux booting from here:
2.1) With either "Start Linux Mint" or "Start Linux Mint (Compatability Mode)" selected (both of these work if you apply the tweaks below, but if the first gives you trouble, stick with the second for now), press 'e' on your keyboard
2.2) You're now presented with a screen that contains 2-3 long command lines. These are essentially the commands that GRUB will execute in order to boot up Linux. Of particular interest is the second line - the one that starts with "linux" and ends with "--" (and is followed by a line with "initram.d" or something similar)
2.3) Navigate the cursor to just before the "--". Do this by pressing the down-arrow 2-3 times, Home/End, and left-arrow a few times.
2.4) Append the following text before the "--", leaving a space before what you type and after what you type:
acpi_backlight=vendor nouveau.modeset=1

The first bit of this tells the Linux kernel about your screen's backlight (so that it gets initialised on startup, and you aren't left with a dim login screen or similar at any point in time), while the second part tells Linux Mint NOT to use the default open-source drivers for NVidia graphics cards (which ends up fighting with the Intel integrated card for control of the monitor; remember that the Intel is the only one which really has "write access" to it - at least from what I gather about the problems here). With these two tweaks, everything should work, though when you boot into Linux, your NVidia graphics card won't be usable yet - getting that working is something to worry about AFTER you've managed to get the dual boot setup working!

2.5) Press F10 to boot Linux using your modified boot instructions. I know what the info text at the bottom of the screen says about Ctrl-X, but from experience, that does not work at all. Only F10 (boot using modified config) and Esc (go back to GRUB menu) work.

2.6) All going well, you'll either get a Mint logo in the middle of your screen which gets brighter (Standard option) or pages of terminal text blasting past (Compatability Mode), followed by a screen where a cursor appears on a black screen, followed by the Mint desktop appearing before your eyes.



Hope that helps
aligorith
Level 1
Level 1
 
Posts: 16
Joined: Thu Oct 03, 2013 8:07 pm


Return to Installation & Boot

Who is online

Users browsing this forum: MSNbot Media, Pastcal and 17 guests