UEFI Boot problems in Linux Mint15 on Dell 14z (Solved)

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

UEFI Boot problems in Linux Mint15 on Dell 14z (Solved)

Postby ktan60 on Tue Jan 07, 2014 2:57 pm

Several months ago I bought a new notebook DELL Inspiron 14z 5423 i5 with Windows 8 installed. My Apologies for this lengthy story.
laptop specs:
Code: Select all
Inspiron 14z (BMW) (i14z-2203sLV)
    Processor: 3rd Generation Intel® Core i5-3337U processor (3M Cache, up to 2.7 GHz)
    Display: 14 inch High Definition LED Display (1366 x 768) with Truelife
    Operating system: Windows® 8 Home, English (not anymore)
    Memory (RAM): 6GB Shared Dual Channel DDR3 Memory
    Storage (hard drive): 500GB 5400 RPM SATA HDD and 32GB mSATA SSD
    Optical drive: 8X DVD±RW
    Video graphics: Integrated Intel® HD Graphics*
    Media card reader: 3-in-1 Media Card Reader and USB 3.0
    Bluetooth®: Bluetooth® tied to wireless card
    Audio: Skullcandy® Speakers with Waves MaxxAudio®

I downloaded Linux Mint 15 Cinnamon and tried to install it to dual boot to windows 8. After may days and a lot less hair I got rid of Windows 8,- nearly got rid of the laptop to in frustration, by installing Mint over it. It was a cathartic experience. I also voided the warranty. I was informed by Dell support that this notebook was designed only for windows.
The Linux mint install went relatively smoothly if I set up the BIOS to use Legacy and not UEFI with Secure Boot OFF.
Now my admission is that I did not use the standard install - I created separate home and user partitions.
The problem occurred on boot. if I used UEFI I would get a black screen and no disk activity. Anyway, I seemed to get over that using Legacy mode and all was well. In the mean time I came up to speed with Linux Mint and love it. I downloaded and installed several other distributions and played with them. When I deleted the other distros using gparted I had a problem on boot up again. All I did was install another distribution. Recently I installed Ubuntu, the way I installed it seemed to make it want to dominate my laptop. There was a separate /boot grub/ partition - nothing that I could do with Grub Customiser would change boot order or anything because I was in the wrong environment/partition. I downloaded Boot-Repair Disk and tried that. Eventually again in frustration used gparted and deleted the Ubuntu partitions. I now only have Linux Mint 15 Cinnamon and I have moved all my data from Windows computers.

The problem I have now is on boot:
If I set the BIOS to UEFI secure boot OFF I get:
black screen with
Loading Linux 3.8.0-31-Generic.
Loading Initial Ramdisk. . .

If I set the BIOS to Legacy mode I get:
Error no such Partition
Grub Rescue>
If I press F12 on boot up and select any option other than USB under the UEFI title Mint starts up.

Output from command parted:
Code: Select all
$ sudo parted -l
Model: ATA WDC WD5000LPVT-7 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number  Start   End     Size    File system     Name  Flags
 1      1049kB  214MB   213MB   fat32                 boot
 2      215MB   50.2GB  50.0GB  ext4       (Mint15)
 4      50.2GB  165GB   114GB   ext4       (/home)
 5      165GB   187GB   22.0GB  ext4       (/usr)
 8      237GB   487GB   250GB   ext4
 3      494GB   500GB   6302MB  linux-swap(v1)

Model: ATA Micron C400 Real (scsi)
Disk /dev/sdb: 32.0GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Number  Start   End     Size    File system  Name                  Flags
 1      1049kB  8589MB  8588MB               Basic data partition


output from disk-repair:
http://paste.ubuntu.com/6708694/

Any advice on how to do resolve my Linux Mint boot problems would be greatly appreciated. Thanks in advance.
Last edited by ktan60 on Mon Jan 27, 2014 5:23 pm, edited 1 time in total.
ktan60
Level 1
Level 1
 
Posts: 10
Joined: Thu Sep 26, 2013 3:43 pm

Linux Mint is funded by ads and donations.
 

Re: UEFI Boot problems in Linux Mint15 on Dell 14z

Postby Derek_S on Tue Jan 07, 2014 6:03 pm

Hello ktan60 - I read the output from boot repair, it seems that it has chosen to install grub to sda2, not sda1 as it should have. Why it did this, I do not know. The next time you boot using F12, open the terminal and enter these commands:

sudo grub-install /dev/sda1
sudo update-grub
Then close the terminal and reboot.

If this does not fix things for you, I have a feeling you might have installed Mint 15 with UEFI disabled in your BIOS settings. If you enable UEFI boot in BIOS and reinstall Mint, the installer will recognize this, and use the proper bootloader and efi files. Leave Secure Boot disabled. Be aware that your drive is partitioned GPT, not MBR, and this means that there should be an EFI boot partition, formatted FAT32. This appears as sda1 on the partition table, and this is where grub should be installed. DO NOT select sda, or any other partition. Please post back and let us know the results. - Derek
Derek_S
Level 3
Level 3
 
Posts: 151
Joined: Sat Dec 28, 2013 5:36 pm
Location: Long Island, N.Y.

Re: UEFI Boot problems in Linux Mint15 on Dell 14z

Postby gold_finger on Tue Jan 07, 2014 9:38 pm

@ktan60,

Along the lines of what Derek_S was saying -- you have GPT partitioning with a special ESP boot partition formatted FAT32 in position 1 now.

Did you use GPT partitions when you first installed Mint?

If not, then I suspect that somehow Ubuntu's installation converted the disk to GPT partitions when you installed it.

Not sure what the best way to proceed is. If Mint wasn't initially installed in UEFI mode, don't know if you can add whatever needs to be added to the ESP partition now or not. If that's the situation, you may be better off trying to convert the partitioning back to MBR. I can't personally guide you through that, but here is the info you need to do it:
http://www.rodsbooks.com/gdisk/. There is a section on that page specifically dealing with converting b/w GPT and MBR partition formats.

Whatever you do, if there is anything you need to back-up on your installed Mint system do that before messing around with the partitions. Boot with a live DVD/USB and you should be able to access the partitions. If you boot up and can't see the partitions, shutdown and go into UEFI settings to enable UEFI booting (not Legacy). If you boot the live disk in Legacy mode it probably won't read the drive correctly.
Add "Solved" to title of thread if solution is found. (Go to your first post and hit "Edit" button.) This helps make it easier for others to find solutions that work.

Try Linux Beginner Search Engine for Linux questions.
gold_finger
Level 6
Level 6
 
Posts: 1077
Joined: Mon Mar 11, 2013 11:39 pm

Re: UEFI Boot problems in Linux Mint15 on Dell 14z

Postby ktan60 on Thu Jan 09, 2014 5:19 pm

@Derek_S thanks for you response, thanks also for taking the time to read throught the Boot-Repair output. I tried the grub-install and update-grub. It gave me another entry in the BIOS EFI and Legecy menus. I still had to use Legacy mode and F12 and select the entry under UEFI. It was a nice try though. sda1 is the EFI boot partition, formatted FAT32, 200MiB in size. Many thanks.

@gold_finger thanks for you response. I was aware that this was ESP and GPT. I could not run the sudo fdisk -l command and had to use GNU parted. It may be that the Disk-Repair utility for Ubuntu converted GPT partitions. Having played with various boot options over the last few months I could well have done something else. I'm confused at this point hence putting the question out there and hoping someone may have come across the same issues.I have trawled the web for Linux Mint issues on Dell Inspiron notebooks with little success. The only issue is the Video Graphics which I don't think applies in this case as it is not a NVIDIA driver issue.

I downloaded Mint 16 Petra and created a live USB using UNetbootin. I have never been able to start any Linux distribution in UEFI mode with secure boot disabled. I am presented with nothingness - a blank screen. If in recovery mode I may get the echo:
[list=]Loading Linux 3.8.0-31-Generic.
Loading Initial Ramdisk. . .[/list]

To start either Mint Olivia or Petra I have to do the following:
BIOS is set to Legacy mode.
I have to press F12 on boot, select any option other than USB under the UEFI title Mint starts up.


I think I may well have to start with a clean slate and wipe the drive and install Linux Mint again. Having done this once before, months ago, Microsoft files seem tenacious as the option still appears in the UEFI boot menu. The UEFI, ESP and GPT has been a steep learning curve, which I hope one day to understand just a little bit about.
ktan60
Level 1
Level 1
 
Posts: 10
Joined: Thu Sep 26, 2013 3:43 pm

Re: UEFI Boot problems in Linux Mint15 on Dell 14z

Postby gold_finger on Thu Jan 09, 2014 6:53 pm

@ ktan60,

Don't know if possible or how hard would be to fix your situation. Two other possible sources of info for fixing may be: Managing EFI Boot Loaders for Linux: EFI Boot Loader Installation and/or FixParts Tutorial.

ktan60 wrote:Microsoft files seem tenacious as the option still appears in the UEFI boot menu.

There is a way to get rid of that. Seem to remember reading somewhere in here (probably in a post made by srs5694 -- author of links I referred you to) that those entries are stored in something called NVRAM and that there is a way to edit that. Don't know how to do that, but try using the search engine listed in my signature area (below) for "editing NVRAM in UEFI" or something along those lines. Or, maybe there is a way within the UEFI settings menu itself to delete old entries.

ktan60 wrote:The UEFI, ESP and GPT has been a steep learning curve, which I hope one day to understand just a little bit about.

You are not alone on this!!! Many of us, myself included, are grappling with trying to understand all of the differences. A very good starting point for gaining some understanding of UEFI is here: Linux on UEFI: A Quick Installation Guide.

If you choose to go the route of re-installing and starting from scratch decide ahead of time which mode you want to install in -- UEFI or MBR? Then, delete all partitions on the drive and have GParted to create a new partition table (GParted -> Device -> Create Partition Table -> either "msdos" or "GPT"). Either create partitions ahead of time with GParted, or do it from within the installer's partitioning tool.

Try finding info on getting leftover entries in NVRAM removed and do that too if you can.

From a fresh disk (with no leftovers from prior installs) you should be fine in either mode. If choosing UEFI, I think you need to use GPT partitions. In MBR mode, I believe you can use either, but more common to use msdos partitions.

Once you've decide the mode, go into UEFI settings menu and make sure all settings for booting are made for that mode -- the general boot mode of computer AND (if it exists separately) the mode for booting DVD's and USB's. If all settings are consistent you shouldn't run into many problems. After making those changes, then disable "secure boot" only because it has been known to cause problems for many. I know you didn't succeed in booting Mint before with it disabled, but try one more time now that everything is starting fresh. If it still won't work then re-enable it.

After all of above, go ahead and boot with Mint DVD/USB and install. Good luck!
Add "Solved" to title of thread if solution is found. (Go to your first post and hit "Edit" button.) This helps make it easier for others to find solutions that work.

Try Linux Beginner Search Engine for Linux questions.
gold_finger
Level 6
Level 6
 
Posts: 1077
Joined: Mon Mar 11, 2013 11:39 pm

Re: UEFI Boot problems in Linux Mint15 on Dell 14z

Postby ktan60 on Fri Jan 10, 2014 8:01 am

gold_finger, thanks the links and info . To reinstall Linux is going to take awhile as I have very slow internet access. I have read the info in the links before from Rod Smith, when I was desperate to get some sort of response from the computer after intstalling Linux. I hope this time it makes more sense. I did consider using the rEFInd loader but thought that was going to complicate things more.

gold_finger wrote:If you choose to go the route of re-installing and starting from scratch decide ahead of time which mode you want to install in -- UEFI or MBR?

I would rather use UEFI to install Linux. If I stay with MBR then I may as well have stayed with Windows H8 and I really really don't want to go there. This computer has 32 Gig of SSD to speed things up.

What I am baffled about is when the BIOS is set to UEFI, regardless of Live USB or DVD, I am just presented with a black screen.
Thanks again for your help.
ktan60
Level 1
Level 1
 
Posts: 10
Joined: Thu Sep 26, 2013 3:43 pm

Re: UEFI Boot problems in Linux Mint15 on Dell 14z

Postby gold_finger on Fri Jan 10, 2014 12:02 pm

@ktan60,

Hopefully some good news!

I just looked through your original post and the output from "Boot-Repair" again and think (I'm hoping at least) I may have found what is wrong. Will work up a potential fix and post later.

In the meantime ...

ktan60 wrote:I have read the info in the links before from Rod Smith, when I was desperate to get some sort of response from the computer after intstalling Linux. I hope this time it makes more sense.

Just to try gaining a better understanding of UEFI, don't bother right now with any other linked info except for this one: Linux on UEFI: A Quick Installation Guide. Take your time reading it and read more than once if necessary. It's not an easy subject matter, especially if you haven't done a lot of partitioning and fiddling with BIOS/UEFI settings in the past. Part of the confusion I think comes from the fact that there is no set standard amongst manufacturers for implementing UEFI. In an effort to account for various possibilities, Rod ends up describing multiple possible scenarios (some of which may not apply to you) which can make it a bit harder to follow. Your best bet is to read through and make notes of only the points that seem to apply to your computer's UEFI -- disregard anything that doesn't apply to you. When notes are complete, go back through article with notes in hand to double-check what you wrote and see if it gets any clearer to understand.
Add "Solved" to title of thread if solution is found. (Go to your first post and hit "Edit" button.) This helps make it easier for others to find solutions that work.

Try Linux Beginner Search Engine for Linux questions.
gold_finger
Level 6
Level 6
 
Posts: 1077
Joined: Mon Mar 11, 2013 11:39 pm

Re: UEFI Boot problems in Linux Mint15 on Dell 14z

Postby gold_finger on Fri Jan 10, 2014 3:28 pm

Okay, hopefully this solves the boot problem!

This output from the "Boot-Repair" program shows that currently your "/usr" partition is not set to mount at boot-up. It should be, so that's definitely a problem.
Code: Select all
=============================== sda2/etc/fstab: ================================

--------------------------------------------------------------------------------
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=7badd462-c9b6-4559-b1aa-42c89de47322 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
#UUID=8756-9A39  /boot/efi       vfat    defaults        0       1
# /home was on /dev/sda4 during installation
UUID=b9c4ff84-f1bc-4004-b05d-1a6c5c9a8c22 /home           ext4    defaults        0       2
# /usr was on /dev/sda5 during installation
#UUID=83f03045-9deb-4abf-abb4-8f27f1feb2f6 /usr            ext4    defaults        0       2
# swap was on /dev/sda3 during installation
UUID=86fff753-708e-407b-aa1a-6713515708df none            swap    sw              0       0
UUID=83f03045-9deb-4abf-abb4-8f27f1feb2f6   /usr   ext4   defaults   0   2
UUID=8756-9A39   /boot/efi   vfat   defaults   0   1


Specifically, the line right under "# /usr was on /dev/sda5 during installation" needs to have the comment (#) removed so it ends up reading:
Code: Select all
UUID=83f03045-9deb-4abf-abb4-8f27f1feb2f6 /usr            ext4    defaults        0       2


Boot-up with your live DVD/USB and open a terminal.

Make a directory to mount the root partition of your installed Mint:
Code: Select all
sudo mkdir /mnt/olivia

Mount that partition:
Code: Select all
sudo mount -t ext4 /dev/sda2 /mnt/olivia

Open the /etc/fstab file in your installed system with nano editor:
Code: Select all
sudo nano /mnt/olivia/etc/fstab

Use arrow keys to move the cursor down to the beginning of this line (the line right under "# /usr was on /dev/sda5 during installation"):
Code: Select all
#UUID=83f03045-9deb-4abf-abb4-8f27f1feb2f6 /usr            ext4    defaults        0       2

Use "Delete" key to delete the "#" at beginning of the line.

Hit Ctrl+o (Ctrl key and letter "O" at the same time) to write the change to the file.

Hit Ctrl+x to exit nano and return to terminal prompt

Now, before closing out terminal, enter the following to display your /etc/fstab file and copy/paste that output back here for me to look at just in case something doesn't work when you reboot:
Code: Select all
cat /mnt/olivia/etc/fstab

Copy/Paste that output back here in the forum.

Now, unmount the drive:
Code: Select all
sudo umount /mnt/olivia
(Note: spelling of the command does not have an "n" between the "u" and "m".)

Close out the terminal, reboot computer without live DVD/USB and cross your fingers that this solves the problem.

Good luck.

P.s. Try booting in UEFI mode.
Add "Solved" to title of thread if solution is found. (Go to your first post and hit "Edit" button.) This helps make it easier for others to find solutions that work.

Try Linux Beginner Search Engine for Linux questions.
gold_finger
Level 6
Level 6
 
Posts: 1077
Joined: Mon Mar 11, 2013 11:39 pm

Re: UEFI Boot problems in Linux Mint15 on Dell 14z

Postby ktan60 on Sun Jan 12, 2014 10:03 am

goldfinger, many thanks for your time and effort to resolve my boot problem. After reinstalling my network-manager (another story - oops) I did as you suggested.

The fstab is as follows:
Code: Select all
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=7badd462-c9b6-4559-b1aa-42c89de47322 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
#UUID=8756-9A39  /boot/efi       vfat    defaults        0       1
# /home was on /dev/sda4 during installation
UUID=b9c4ff84-f1bc-4004-b05d-1a6c5c9a8c22 /home           ext4    defaults        0       2
# /usr was on /dev/sda5 during installation
UUID=83f03045-9deb-4abf-abb4-8f27f1feb2f6 /usr            ext4    defaults        0       2
# swap was on /dev/sda3 during installation
UUID=86fff753-708e-407b-aa1a-6713515708df none            swap    sw              0       0
UUID=83f03045-9deb-4abf-abb4-8f27f1feb2f6   /usr   ext4   defaults   0   2
UUID=8756-9A39   /boot/efi   vfat   defaults   0   1


I changed the boot options to UEFI, secure boot OFF and was surprised to see the linuxmint, ubuntu and grub options available for a change. There being quite a few entries is ,I'm sure, a result of my using boot-repair and grub-customiser too many times. The machine booted and I was presented with the GRUB 2 menu listing Mint Olivia and Mint Petra. I selected Mint Olivia - I was presented with the black screen. I attempted to boot Mint Petra and was presented with the same unresponsive black screen. I changed the boot options to Legacy and used F12 to selected Linuxmint and all was back to normal. No matter what live-USB distro I use I have never been able to get past the unresponsive black screen after the GRUB menu is displayed.

I really appreciate your efforts in trying to resolve this boot problem. Your help, advice and the forum make the linux learning curve considerably less stressful, as long as one has the patience and persistence to learn. I hope to arrive in a place that has faster internet access in a few days. If that is the case I will go about reading the Rod Smiths UEFI info then reinstall Mint Petra.
ktan60
Level 1
Level 1
 
Posts: 10
Joined: Thu Sep 26, 2013 3:43 pm

Re: UEFI Boot problems in Linux Mint15 on Dell 14z

Postby FreedomOfTheOpenCode on Sun Jan 12, 2014 12:56 pm

I have just spent most of the weekend experimenting with GPT and various distros, and I found the following:

1) Unless a distro (or Windows) needs the EFI partition, you can have a GPT disk without it, and just install GRUB to the MBR (on the GPT disk).

2) If a distro (such as OpenSUSE 13.1) creates an EFI partition then it will automatically be the first boot option in the BIOS, and GRUB in the MBR will be ignored (and so will the DVD drive.) In this case you may be able to change the boot order or disable the EFI boot in the BIOS. (I did this and then used OpenSUSE's Boot Loader to write a GRUB2 menu to the MBR and it works. Again this was done on a GPT disk.

3) If you lose control of the boot menu, get into BIOS to change the options or override them.

4) It helps to have Gparted on a rescue DVD (such as Parted Magic OS that came on the cover of Linux Format 176).

5) Don't even think about installing the current Fedora 20 unless you have nothing else on the disk. (The worst installer I have ever seen.)

Anyway, all those frustrating hours spent reinstalling have at least given me the confidence to switch to GPT now, with all its benefits, but I will avoid EFI partitions as far as possible. What are they good for anyway?
Remember BlueJ 2005
FreedomOfTheOpenCode
Level 2
Level 2
 
Posts: 76
Joined: Thu Mar 14, 2013 3:16 pm

Re: UEFI Boot problems in Linux Mint15 on Dell 14z

Postby gold_finger on Sun Jan 12, 2014 2:45 pm

@ktan60,
I feel like an idiot now. Just looked back over that output and realized that Boot Repair added the /usr partition to /etc/fstab near the end of that output. So, after following my last instructions, you now have two entries for that one partition. Duh! :shock: Sorry for the misplaced optimism and for having you go through an unnecessary procedure.

Anyway, at this point I think everything is just so convoluted from all the various installs, etc. that your best bet is to just wipe out the drive and start fresh.

Try using info on link below to see if you can get booting with your new Mint 16 USB to work in UEFI mode.
https://wiki.archlinux.org/index.php/Kernel_Mode_Setting#Disabling_modesetting

If that works for booting, go ahead and boot into Mint 16 USB. Then, if you don't find GParted under Menu -> Administration (or System) -> GParted, install it to live environment with this command in a terminal:
Code: Select all
sudo apt-get install gparted

Press "y" to accept and hit "Enter".

*** Open GParted, right-click on "swap" partition and choose "Swapoff".

*** Then, right-click on every partition you see and select "Delete".

*** Hit "Apply" (probably shown as one of the arrow buttons along top of interface) to confirm and execute the deletions.

*** Then go to Device -> Create Partition Table -> Advanced -> gpt (if UEFI booting; otherwise msdos or gpt if booting in Legacy mode)

*** For simplicy sake, leave disk empty and close out GParted.

Now double-click the "Install" icon on the live desktop.

When asked how/where to install on drive, choose the option that let's the installer do everything itself automatically -- not "Something else". After you've used Mint for a while and have a better handle on things you can try changing aspects of your set-up if you decide you want to try something different.

If you end up having to use "Legacy" mode again, just follow same instructions as outlined above with possible exception being to set-up "msdos" partition table.

Good luck.

************************************************************************************************

FreedomOfTheOpenCode wrote:I have just spent most of the weekend experimenting with GPT and various distros, and I found the following:

@FreedomOfTheOpenCode,
Many thanks FreedomOfTheOpenCode for your test results. They confirm that one can use GPT partitioning while booting in BIOS/Legacy mode on computers using UEFI firmware; and (by extension) on computers using the old BIOS firmware.

Just to clarify any terminology confusion for those unfamiliar with all this and who may have read some of the other sources referenced here:
-- the technically correct name for the "EFI" partition is the "ESP" (EFI System Partition) partition.
-- BIOS firmware and EFI/UEFI firmware are two separate things -- older computers use BIOS; many new computers use UEFI.
-- If on a computer using UEFI, any reference to "BIOS" settings (here, or by the manufacturer) is just a generic term commonly substituted for "UEFI" settings (since that's what most people think of it as).
-- Many new systems with UEFI firmware allow for booting in either UEFI mode or something called BIOS/Legacy/CSM compatibility mode (which emulates the old BIOS mode) enabling the use of the old MBR partitioning scheme. As FreedomOfTheOpenCode showed, Linux also allows for GPT partitioning in the old BIOS mode -- (Windows does not allow for that).

____________________________________________________________________
Edited 2/14/14 to add some clarifications to above.
Last edited by gold_finger on Fri Feb 14, 2014 4:24 am, edited 1 time in total.
Add "Solved" to title of thread if solution is found. (Go to your first post and hit "Edit" button.) This helps make it easier for others to find solutions that work.

Try Linux Beginner Search Engine for Linux questions.
gold_finger
Level 6
Level 6
 
Posts: 1077
Joined: Mon Mar 11, 2013 11:39 pm

Re: UEFI Boot problems in Linux Mint15 on Dell 14z

Postby ktan60 on Sun Jan 19, 2014 10:31 am

Thank you @goldfinger, I really appreciate your help. If it weren’t for the forum and people like you I would have ditched the laptop. The ultimate test, which it will never pass :) can't fly and can't float. I think my installation of Mint Olivia has become so convoluted and I concur that a complete new install is needed. I still don't know why I'm unable to boot a live USB with Linux (any linux distro) in UEFI mode, secure boot off. This may have something to do with the harware Dell Inspiron 14z. I have used

Current EFI Boot:
Code: Select all
Inspiron-5423 # efibootmgr -v
BootCurrent: 0005
Timeout: 0 seconds
BootOrder: 0000,0001,0002,0003,0005,000B
Boot0000* P0: WDC WD5000LPVT-75G33T0   BIOS(10,0,00)AMBO
Boot0001* P4: TSSTcorp DVD+/-RW SU-208BB   BIOS(12,0,00)AMBO
Boot0002* Atheros Boot Agent   BIOS(14,0,00)AMBO
Boot0003* P1: Micron C400 RealSSD mSATA 32   BIOS(15,0,00)AMBO
Boot0005* linuxmint   HD(1,800,65800,af21ef67-e54d-4821-9e4e-6303d474cc0d)File(\EFI\linuxmint\grubx64.efi)
Boot000B* Windows Boot Manager   HD(1,800,65800,af21ef67-e54d-4821-9e4e-6303d474cc0d)File(\EFI\Microsoft\Boot\bootmgfw.efi)


The interesting thing from your last post is deleting all the partitions, then creating a new GPT partition. When I did the initial install (Mint 15) I used the "Something else" option and create separate "Home" and "usr". Not sure why I created the "usr" partition. I like the idea of having a separate home partition. Anyway, I shall back up all my precious data and do a new install using the default install.

Again, thanks very much for you help @goldfinger. :?
ktan60
Level 1
Level 1
 
Posts: 10
Joined: Thu Sep 26, 2013 3:43 pm

Re: UEFI Boot problems in Linux Mint15 on Dell 14z

Postby ktan60 on Thu Jan 23, 2014 1:31 pm

@goldfinger thanks for the tip on mode setting. I had a look at several other posts related to this subject. No new clean install done yet.

The interesting thing was finding a key sequence ie. Ctrl+Alt+Del which enabled the notebook to reboot cleanly or Ctrl+Alt+F1 which, displayed a command screen when the blank screen appeared. This indicates to me that it is a video, graphics card or screen problem. It may be th Linux Distros that I have installed are unable to detect the video card correctly on my Dell 14z - I think. Being a little confused with having read so much about Booting, ESP, UEFI, GPT and all that over the last few months I am not sure. If one wants to know the right answer, then one has to ask the right question.

Fixing the black screen after grub boot-up - Linux Mint Community
https://community.linuxmint.com/tutorial/view/842

output from xrandr:
Code: Select all
Inspiron-5423 ~ $ xrandr --verbose -q
Screen 0: minimum 320 x 200, current 1360 x 768, maximum 32767 x 32767
LVDS1 connected 1360x768+0+0 (0x49) normal (normal left inverted right x axis y axis) 309mm x 174mm
    Identifier: 0x42
    Timestamp:  62849
    Subpixel:   horizontal rgb
    Gamma:      1.0:1.0:1.0
    Brightness: 1.0
    Clones:   
    CRTC:       0
    CRTCs:      0 1 2
    Transform:  1.000000 0.000000 0.000000
                0.000000 1.000000 0.000000
                0.000000 0.000000 1.000000
               filter:
    EDID:
        00ffffffffffff000dae761400000000
        33150104901f1178022b359757548f29
        23505400000001010101010101010101
        010101010101f21d56d5500029302144
        4d0035ae1000001af71356d550002930
        21444d0035ae1000001a000000fe0059
        3950374e803134314247450a00000000
        00004131940110000001010a20200014
    BACKLIGHT: 40 (0x00000028)    range:  (0,100)
    Backlight: 40 (0x00000028)    range:  (0,100)
    scaling mode:    Full aspect
        supported: None         Full         Center       Full aspect
  1366x768 (0x47)   76.7MHz +HSync -VSync +preferred
        h: width  1366 start 1399 end 1467 total 1579 skew    0 clock   48.5KHz
        v: height  768 start  772 end  785 total  809           clock   60.0Hz
  1366x768 (0x48)   51.1MHz +HSync -VSync
        h: width  1366 start 1399 end 1467 total 1579 skew    0 clock   32.4KHz
        v: height  768 start  772 end  785 total  809           clock   40.0Hz
  1360x768 (0x49)   84.8MHz -HSync +VSync *current
        h: width  1360 start 1432 end 1568 total 1776 skew    0 clock   47.7KHz
        v: height  768 start  771 end  781 total  798           clock   59.8Hz
  1360x768 (0x4a)   72.0MHz +HSync -VSync
        h: width  1360 start 1408 end 1440 total 1520 skew    0 clock   47.4KHz
        v: height  768 start  771 end  781 total  790           clock   60.0Hz
  1024x768 (0x4b)   65.0MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   48.4KHz
        v: height  768 start  771 end  777 total  806           clock   60.0Hz
  800x600 (0x4c)   40.0MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock   37.9KHz
        v: height  600 start  601 end  605 total  628           clock   60.3Hz
  800x600 (0x4d)   36.0MHz +HSync +VSync
        h: width   800 start  824 end  896 total 1024 skew    0 clock   35.2KHz
        v: height  600 start  601 end  603 total  625           clock   56.2Hz
  640x480 (0x4e)   25.2MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock   31.5KHz
        v: height  480 start  490 end  492 total  525           clock   59.9Hz
VGA1 disconnected (normal left inverted right x axis y axis)
    Identifier: 0x43
    Timestamp:  62849
    Subpixel:   unknown
    Clones:   
    CRTCs:      0 1 2
    Transform:  1.000000 0.000000 0.000000
                0.000000 1.000000 0.000000
                0.000000 0.000000 1.000000
               filter:
HDMI1 disconnected (normal left inverted right x axis y axis)
    Identifier: 0x44
    Timestamp:  62849
    Subpixel:   unknown
    Clones:   
    CRTCs:      0 1 2
    Transform:  1.000000 0.000000 0.000000
                0.000000 1.000000 0.000000
                0.000000 0.000000 1.000000
               filter:
    Broadcast RGB:    Full
        supported: Full         Limited 16:2
    audio:    auto
        supported: force-dvi    off          auto         on         
DP1 disconnected (normal left inverted right x axis y axis)
    Identifier: 0x45
    Timestamp:  62849
    Subpixel:   unknown
    Clones:   
    CRTCs:      0 1 2
    Transform:  1.000000 0.000000 0.000000
                0.000000 1.000000 0.000000
                0.000000 0.000000 1.000000
               filter:
    Broadcast RGB:    Full
        supported: Full         Limited 16:2
    audio:    auto
        supported: force-dvi    off          auto         on   


I then installed a program called pastebinit:
Code: Select all
[[ -z $(dpkg -l|grep  pastebinit) ]] && sudo apt-get install pastebinit


then output the Xorg log file to pastebinit:
Code: Select all
cat /var/log/Xorg.0.log|pastebinit


The output can be found at:
http://pastebin.com/HG4w5RFV

Not a lot of the Xorg output makes much sense to me. But I did notice a line not too far from the top that said "No Layout section", then "monitor default monitor". If anyone has any ideas or suggestions as to where I can go next, and I am lost enough already :) I would greatly appreciate it.
ktan60
Level 1
Level 1
 
Posts: 10
Joined: Thu Sep 26, 2013 3:43 pm

Re: UEFI Boot problems in Linux Mint15 on Dell 14z

Postby gold_finger on Thu Jan 23, 2014 3:41 pm

@ktan60,

Back on your post from Sun Jan 12, 2014 7:03 am you said:
I changed the boot options to UEFI, secure boot OFF and was surprised to see the linuxmint, ubuntu and grub options available for a change. There being quite a few entries is ,I'm sure, a result of my using boot-repair and grub-customiser too many times. The machine booted and I was presented with the GRUB 2 menu listing Mint Olivia and Mint Petra.


Were you booting the computer's hard drive or a USB when you said that?

If hard drive, then am I to understand that you somehow did succeed in getting Mint 16 (Petra) installed? I thought you couldn't because you couldn't boot the USB without getting a black screen.


As far as black screen problem when booting the USB goes, I'm not much of an expert on that but let's try something from this Arch wiki page.

Boot your UNetbootin Mint 16 USB
-- hit the "Tab" key when you select your boot choice ("Default" probably).
-- Near bottom of window you'll see some code ending in something like "quiet splash".
-- After that phrase, enter a <space>, then type: nomodeset i915.modeset=0
(NOTE: there is a space between "nomodeset" and "i915.modeset=0". And the end is a zero, not the uppercase letter "O".)
-- Double-check your entries, then hit enter and give it 5-10 seconds to start booting.
-- Hopefully you end up seeing the desktop instead of black screen.

Post back result of that USB test and answer to questions above.


After reading through what FreedomOfTheOpenCode wrote on Sun Jan 12, 2014 9:56am, I have a new idea on what may have happened to your Mint 15 -- but am not sure how to resolve the issue. Will save my thoughts on that for after your next post.

We'll leave /etc/X11/xorg.conf alone for now. I could be wrong, but don't think that is the primary problem right now.
Add "Solved" to title of thread if solution is found. (Go to your first post and hit "Edit" button.) This helps make it easier for others to find solutions that work.

Try Linux Beginner Search Engine for Linux questions.
gold_finger
Level 6
Level 6
 
Posts: 1077
Joined: Mon Mar 11, 2013 11:39 pm

Re: UEFI Boot problems in Linux Mint15 on Dell 14z

Postby ktan60 on Fri Jan 24, 2014 4:50 pm

@ktan60: I changed the boot options to UEFI, secure boot OFF and was surprised to see the linuxmint, ubuntu and grub options available for a change. There being quite a few entries is ,I'm sure, a result of my using boot-repair and grub-customiser too many times. The machine booted and I was presented with the GRUB 2 menu listing Mint Olivia and Mint Petra.

@goldfinger question: Were you booting the computer's hard drive or a USB when you said that?
If hard drive, then am I to understand that you somehow did succeed in getting Mint 16 (Petra) installed? I thought you couldn't because you couldn't boot the USB without getting a black screen.was


@Ktan60 resonse: The computer was booted from the HDD. BIOS in Legacy Mode. While booting I press F12 to bring up the choice of Legacy or UEFI options. I select LinuxMint under UEFI. I am then presented with the GRUB menu. I select either Mint Olivia 15 or Mint Petra 16, then presented with the relevent OS.

If I change the BIOS to UEFI with secure boot off, then leave the boot process to run - I am presented with the GRUB menu with Mint Olivia 15 or Mint Petra 16 and recovery options. After I select this I am presented with a black screen. If I press Ctrl+Alt+Del the system reboots. If I press the Off button while it is hung on the black screen the computer instantly shuts down.

I have successfully installed Linux Petra 16 from live USB alongside Olivia 15. To do this I had to leave the BIOS in Legacy mode and select the USB drive. then boot from there. I don't need to press F12 it just booted into the Linux Petra 16 OS and I installed it from there.

I have never been able to get passed the black screen when in UEFI mode with secure boot off or on.

@Goldfinger: As far as black screen problem when booting the USB goes, I'm not much of an expert on that but let's try something from this Arch wiki page.
Boot your UNetbootin Mint 16 USB

@Ktan60:
1. I used my live USB with Petra created using UNetbootin.
2. I changed the BIOS to UEFI, secure boot off, with USB device first.
3. When presented with the GRUB menu I pressed "e" on the Petra boot choice.
4. I edited the line with "quiet splash" and added " nomodeset i915.modeset=0" without quotes.
5. Pressed F10 to boot with the changes.
6. I also added some echo commands to see if the changes I applied went through.
7. The echo commands were displayed and a static cursor then the black screen and nothing.
8. I am able to press Ctrl+Alt+Del to reboot the computer.

For the Ctrl+Alt+Del to work after the black screen means the computer is waiting for something? This is why I mentioned the Screen video driver possible issue.

If I could use UEFI mode secure boot off and get past the black screen I would wipe the HDD and load a new version of Mint.
@FreedomOfTheOpenCode is using a MBR instead of UEFI but somehow is also using GPT. Thanks for your info @FreedomOfTheOpenCode - no offence but I have not figured out how to implement the MBR and GPT option.
I find it hard to believe that I am the only one with this issue on a dell 14z 5423 i5. I am inclined to think that the issue maybe video or screen related. The defaults provided by Mint are not suitable in UEFI mode, but somehow work in legacy mode under the UEFI option. Anyway still confused if not more so.
ktan60
Level 1
Level 1
 
Posts: 10
Joined: Thu Sep 26, 2013 3:43 pm

Re: UEFI Boot problems in Linux Mint15 on Dell 14z (Resolved

Postby ktan60 on Sat Jan 25, 2014 12:21 pm

To @gold_finger, @FreedomOfTheOpenCode and the forum thanks for all your help and suggestions.

I eventually decided on a complete fresh install with Mint Petra 16. I set the BIOS to Legacy mode and booted from live USB. I installed Petra to over write everything - no UEFI or GPT pre-setup.
After updating Petra I changed the BIOS to UEFI, Secure Boot off and guess what Mint appeared - no Grub Menu!
I apologise for having wasted your timed, I am very grateful to you and the forum for all the help. The forum works.

My reluctance to do a complete reinstall comes from my experience of reinstalling windows Vista Home edition a few years ago. It took 4 hours a day over 4 days and that was a base install no additional software. That is just an excuse for not trusting Linux to install correctly - my error! I did a complete new install of Mint Petra and restored my data and email client in around 3 hours. The limiting factor being the sporadic WiFi connection. Mint is a sweet system.
ktan60
Level 1
Level 1
 
Posts: 10
Joined: Thu Sep 26, 2013 3:43 pm

Re: UEFI Boot problems in Linux Mint15 on Dell 14z

Postby gold_finger on Sat Jan 25, 2014 1:08 pm

@ktan60,

Very happy to see you got it resolved and now are up and running.

Quick note: to mark your post "Solved", you need to edit the title of your first post on this thread. Right now it only shows under your last post instead of on the post that everyone sees when looking at list of posts.

I'm curious to see a few things from your current set-up if you don't mind. Sounds like you changed UEFI boot mode after you installed and the system is now working fine. I didn't think that was supposed to work. If you post back, can you tell me what mode the UEFI settings for booting are in right now when you use the computer? Also, can you open a terminal and post the output of these commands (both commands end in lowercase letter "L"):
Code: Select all
sudo parted -l

Code: Select all
sudo fdisk -l

If it's not too much trouble, can you also post a screenshot of the hard drive from GParted?

Thanks.

P.s. If GParted is not installed, you can install it from Software Center or using terminal with this command:
Code: Select all
sudo apt-get install gparted
Add "Solved" to title of thread if solution is found. (Go to your first post and hit "Edit" button.) This helps make it easier for others to find solutions that work.

Try Linux Beginner Search Engine for Linux questions.
gold_finger
Level 6
Level 6
 
Posts: 1077
Joined: Mon Mar 11, 2013 11:39 pm

Re: UEFI Boot problems in Linux Mint15 on Dell 14z

Postby ktan60 on Mon Jan 27, 2014 5:22 pm

Thanks @gold_finger. Please note I shunk the sda1 partition and I created a home partition post Mint 16 install. I left some space to play with other distros. Otherwise, I used the default install on Mint 16 Petra. No problems on providing a screen shot from gParted - I just have not figured out how to insert the image :?

output from sudo parted -l:
Code: Select all
Model: ATA WDC WD5000LPVT-7 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos

Number  Start   End    Size    Type      File system     Flags
 1      1049kB  105GB  105GB   primary   ext4            boot
 3      105GB   315GB  210GB   primary   ext4
 2      494GB   500GB  6301MB  extended
 5      494GB   500GB  6301MB  logical   linux-swap(v1)

Model: ATA Micron C400 Real (scsi)
Disk /dev/sdb: 32.0GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End     Size    File system  Name                  Flags
 1      1049kB  8589MB  8588MB               Basic data partition


Output from sudo fdisk -l:
Code: Select all
Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x00023930

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   204822527   102410240   83  Linux
/dev/sda2       964464638   976771071     6153217    5  Extended
Partition 2 does not start on physical sector boundary.
/dev/sda3       204822528   615028735   205103104   83  Linux
/dev/sda5       964464640   976771071     6153216   82  Linux swap / Solaris

Partition table entries are not in disk order

WARNING: GPT (GUID Partition Table) detected on '/dev/sdb'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/sdb: 32.0 GB, 32017047552 bytes
255 heads, 63 sectors/track, 3892 cylinders, total 62533296 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xf521f231

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1    62533295    31266647+  ee  GPT


Thanks again for you help and the tip on updating the post with "Solved"
ktan60
Level 1
Level 1
 
Posts: 10
Joined: Thu Sep 26, 2013 3:43 pm

Re: UEFI Boot problems in Linux Mint15 on Dell 14z (Solved)

Postby gold_finger on Mon Jan 27, 2014 10:59 pm

Interesting.

Your main drive (/dev/sda) with Mint on it is installed in BIOS/Legacy mode because the partition table shows msdos. Whatever that second drive (/dev/sdb) is, that one is using GPT partitions. As FreedomOfTheOpenCode showed, that's not a problem in and of itself. (Just don't install an O.S. to it in UEFI mode.)

Your UEFI firmware probably detects that Mint is installed in BIOS mode and then uses that to boot the system. I've seen from other peoples posts something labeled in their UEFI settings as "CSM" mode, which does exactly that -- figures out what mode to boot in depending on what the operating system needs. (At least that's my understanding of it.) Yours must do that also, but maybe you don't have it labeled as such in the settings menu. (If I remember right, someone had a "UEFI Only" mode, a "UEFI/CSM mode" and a "BIOS Only" mode -- or something along those lines.)

EDIT (1/30/14): Since this original post, I've read something else that indicates my theory on what "CSM" mode is may be incorrect as stated in above paragraph. I'm still not 100% sure what the differences are, but for anyone reading this later -- don't put too much stock in my attempted description of the "CSM" mode above.

The problems arise when there are two or more operating systems that need different boot modes to operate in. I'm not sure exactly what happened in your case, but some leftover something-or-other must have been triggering some kind of mis-read on startup. Anyway, good to see you up and running.

Be forewarned though, if you decide to install any other O.S. (Windows or Linux), change those settings back to BIOS/Legacy for the installation so they end up in the same mode as your Mint install. Otherwise, you'll end up with the same problems again.

ktan60 wrote:No problems on providing a screen shot from gParted - I just have not figured out how to insert the image

Don't worry about the screenshot. Not necessary -- your other output told me what I wanted to know. For future reference if you need to post one, use the "Upload attachment" tab below where you type in the forum interface. If image is too big for that, or you can't get that to work, you can post it on a site like this one (http://imagebin.ca/) and post the link it produces back here in the forum. (You could also scale down the size of the pic, but I won't get into that here.)
Add "Solved" to title of thread if solution is found. (Go to your first post and hit "Edit" button.) This helps make it easier for others to find solutions that work.

Try Linux Beginner Search Engine for Linux questions.
gold_finger
Level 6
Level 6
 
Posts: 1077
Joined: Mon Mar 11, 2013 11:39 pm

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: Google Adsense [Bot] and 21 guests