<Solved> Bianca Session Automatically Saves

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

<Solved> Bianca Session Automatically Saves

Postby donlinux on Mon Mar 12, 2007 8:53 am

Interesting quirk here. I'm using Bianca and love it! In my configuration, under apps/gnomesession/options, I do not have the autosave session box checked, yet each time I reboot, it saves my session. Am I missing something else?

Thanks,
Last edited by donlinux on Sun Apr 15, 2007 7:03 am, edited 1 time in total.
donlinux
Level 2
Level 2
 
Posts: 99
Joined: Tue Feb 27, 2007 4:17 pm

Linux Mint is funded by ads and donations.
 

Postby Husse on Mon Mar 26, 2007 8:00 am

Do you still have the problem?
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Bianca saves session

Postby donlinux on Tue Mar 27, 2007 6:44 am

Yes, I've not been able to get back to a normal boot. Even when I close all programs, windows etc... and save my session, when I reboot, it comes up with the first session I ever closed with, which has one file browser window open, the sys config. window open and Mailwasher automatically starts. It's not overly bothersome, as I just close the windows, but I would eventually like to fix it.
donlinux
Level 2
Level 2
 
Posts: 99
Joined: Tue Feb 27, 2007 4:17 pm

another interesting quirk

Postby donlinux on Sat Apr 14, 2007 7:38 am

yet another interesting quirk upon boot. Suddenly, Open Office Writer wants to open each time I boot up. I've even gone as far as checking off "save session", closing all open apps., and rebooting. Same thing happens. I also checked my startup programs folder and O.O. is not listed as starting upon boot.

Any ideas anyone ?

Thanks,

Don
donlinux
Level 2
Level 2
 
Posts: 99
Joined: Tue Feb 27, 2007 4:17 pm

Postby Husse on Sat Apr 14, 2007 2:52 pm

Sounds like when Windows gets its registry messed up. Linux does not have a registry, but config files. To me it seems like some config file(s) are messed up.
This is probably not much help but you could try to find something this way:
Open a terminal
use the following command:
locate relevant_file | grep "relevant_word"
note that relevant_file must not have quotes, but "relevant_word" must have, and that you can use a part of what you are looking for (locate open gives you open office and a lot more "open things") and that it is case sensitive. (wildcards accepted n*idia gives nvidia and nVidia)
This searches your entire system for relevant_file and checks if "relevant_word" is found in the file and if so tells you the file name.
So what I was thinking of is something like this
locate open | grep "session"
but that only gives openssh
If you try some combinations you might come up with something. And this is really fast - if you're used to searching in Windows - forget it - this is a quadrillion times faster. :)
//edit// I forgot - you should do "sudo updatedb" before you use locate - it updates the index locate uses
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Boo on Sat Apr 14, 2007 10:32 pm

gnome session save info is kept in these 2 places:
default gnome user session

/usr/share/gnome/default.session

user save session

$HOME/.gnome2/session

I would look in these 2 files but the user one is where your changes should be.
if you dont save a session (uncheck save) the user session file should be deleted.
you could manually delete this file and your session should go back to the default one.

gnome could also have some bug where it doesn't delete the session or saves it to the wrong place....
:D
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Appears to have worked!

Postby donlinux on Sun Apr 15, 2007 7:02 am

found an entry for Open Office in $HOME/.gnome2/session. Edited it out, rebooted and everything appears to work nicely.

Many thanks for the help.
donlinux
Level 2
Level 2
 
Posts: 99
Joined: Tue Feb 27, 2007 4:17 pm

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: Google [Bot], lostfarmer, Resistor and 12 guests