Error 15

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Error 15

Postby blacknail on Sat Aug 09, 2008 11:11 am

Hi all,

I have in my laptop 4 partitons: first with Linux Mint Daryna, second for swap, third with Windows XP and a fourth one for data. Yesterday I installed Elyssa (formatted the Daryna partition with the live cd and made a clean install of Elyssa). Now I can't access de grub menu, it stops in the typical error message:

Code: Select all
GRUB loading, please wait...
Error 15


Somehow I feel this is a very easy issue to solve, like booting with the live cd and editing some file(s) but I don't know which ones specifically. I am thinking wrong? I have searched this forum and a couple of other ones but I couldn't find a similar situation...

I would appreciate if someone could help me.

Thanks a lot,
João

P.S.: Sorry if it is a very noobish question :]
blacknail
Level 1
Level 1
 
Posts: 37
Joined: Mon Jun 09, 2008 11:00 am

Linux Mint is funded by ads and donations.
 

Re: Error 15

Postby Astronomiconal on Sat Aug 09, 2008 11:27 am

Hi.

What appears to have happened is you installed Linux Mint "Daryna" to the MBR when you first installed it, but then when you installed Linux Mint "Elyssa" you erased your old installation but not the master boot record (MBR). So, GRUB is still trying to load the old operating system (in this case, Linux Mint "Daryna") when it should be loading the new operating system. This appears to be the problem, anyhow.

So, boot up from the live CD (you were correct! Ha!). Open up a terminal, type 'sudo grub-install /dev/sda'. I think that's correct, anyhow. It should work. This will rewrite your master boot record, loading the new operating system and Windows XP.

If you're really interested, here's some stuff to read up on:

4. Grub Error 15

Situation

This error can occur in two different stages of the GRUB configuration, either during the initial configuration (installing GRUB in the master boot record) or after booting the system and attempting to launch Linux (or any other entry).

Code Listing 4.1: Grub Output - Initial Configuration

grub> root (hd0,0)
Filesystem type is xfs, partition type 0x83

grub> setup (hd0)
Checking if "/boot/grub/stage1" exists... no
Checking if "/grub/stage1" exists... no

Error 15: File not found

Code Listing 4.2: Grub Output - Booting an Entry

Booting 'gentoo Linux'

root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
kernel (hd0,0)/boot/kernel-2.4.20 root=/dev/hda3 vga=792

Error 15: File not found
Press any key to continue...



Astronomiconal
Astronomiconal
 

Re: Error 15

Postby blacknail on Mon Aug 11, 2008 1:55 pm

Hello,

Unfortunately the error persists, when I run the command Astronomical provided ('sudo grub-install /dev/sda') the information on the shell is (the first time I did it was slightly different but now is always this):

Could not find device for /boot: Not found or not a block device.


Any guesses? :S

Thanks,
Joao
blacknail
Level 1
Level 1
 
Posts: 37
Joined: Mon Jun 09, 2008 11:00 am

Re: Error 15

Postby chattr on Mon Aug 11, 2008 3:33 pm

blacknail wrote:Hello,

Unfortunately the error persists, when I run the command Astronomical provided ('sudo grub-install /dev/sda') the information on the shell is (the first time I did it was slightly different but now is always this):

Could not find device for /boot: Not found or not a block device.


Any guesses? :S

Thanks,
Joao

Post your /boot/grub/menu.lst and post the output in a terminal of ' sudo fdisk -l ' and those may help troubleshooting this.
chattr
Level 2
Level 2
 
Posts: 58
Joined: Thu Jul 03, 2008 2:43 pm

Re: Error 15

Postby blacknail on Tue Aug 12, 2008 1:24 pm

Ok, thanks!

Here it goes:

/boot/grub/menu.lst

The problem is... I think I don't have that file :S Is that possible? Even showing hidden files it only shows:

mint@mint /boot $ ls
abi-2.6.24-16-generic memtest86+.bin
config-2.6.24-16-generic System.map-2.6.24-16-generic
initrd.img-2.6.24-16-generic vmlinuz-2.6.24-16-generic
initrd.img-2.6.24-16-generic.bak

Maybe I'm missing something... I don't know :|

sudo fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x56ea56ea

Device Boot Start End Blocks Id System
/dev/sda1 * 1 3825 30719776+ 7 HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2 3826 7472 29294527+ 83 Linux
/dev/sda3 7473 7596 996030 82 Linux swap / Solaris
/dev/sda4 7597 9729 17133322+ 7 HPFS/NTFS


Thanks in advance
blacknail
Level 1
Level 1
 
Posts: 37
Joined: Mon Jun 09, 2008 11:00 am

Re: Error 15

Postby blacknail on Thu Aug 21, 2008 7:13 pm

I solved my problem. The soution: reinstall Mint. I used the same dvd and installed it the same way and it worked... weird.
Anyway, thanks everybody for the support :)
blacknail
Level 1
Level 1
 
Posts: 37
Joined: Mon Jun 09, 2008 11:00 am


Return to Installation & Boot

Who is online

Users browsing this forum: Derek_S, Open Source and 11 guests