"intel_rng: FWH not detected" error with LiveCD

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

"intel_rng: FWH not detected" error with LiveCD

Postby NoSmokingBandit on Thu Aug 28, 2008 8:53 pm

Im trying to install Elyssa on an old Dell Inspiron 8100 and i get the random number generator error every time. I tried it in both normal and compatibility mode with no success. Any ideas what i can do?
NoSmokingBandit
Level 1
Level 1
 
Posts: 5
Joined: Sat Jul 05, 2008 5:55 pm

Linux Mint is funded by ads and donations.
 

Re: "intel_rng: FWH not detected" error with LiveCD

Postby Husse on Fri Aug 29, 2008 7:36 am

Can you boot anyway?
And do you have Intel wifi? (Not quite sure but it may have to do with that)
It seems this means you do not have the hardware for using Intel’s hardware-based “true” random number generator (specifically a firmware hub no longer in production).
As far as I understand you can just stop this module from being loaded
In an installed working system just add blacklist intel_rng to /etc/modprobe.d/blacklist
Code: Select all
echo "blacklist intel_rng" | sudo tee -a  /etc/modprobe.d/blacklist

Edited a typo (missing ")
If this means that the live CD does not boot follow the advice in the troubleshooter -
Edit the boot options*- remove "quiet splash --" and add "ro single" (no quotes) which will take you to "Recovery mode"
Mint will start booting, but kick you out to a command prompt; at the prompt type the command above then type exit (+enter)
* I'm not quite sure how in Elyssa, but you could probably press F6 as in earlier version or press any key + Tab to get to the options
(while the live CD counts down)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Installation & Boot

Who is online

Users browsing this forum: Derek_S, windmike and 10 guests