fstab failed with ntfs-3g entry

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

fstab failed with ntfs-3g entry

Postby T J Tulley on Wed Sep 10, 2008 9:43 pm

Recently I was advised to specify ntfs-3g as format type for mounting instead of ntfs.

This has caused booting of the system (Elyssa4) to fail. I have 4 ntfs partitions specified in fstab; only 2 of them appear on my desktop although the specs are the same.
I had changed the entries to ntfs-3g and that caused boot to abort into a terranova prompt.
Removing the -3g by editing while booted into a different installation (Elyssa3) has removed the fault and Elyssa4 now boots successfully.
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Linux Mint is funded by ads and donations.
 

Re: fstab failed with ntfs-3g entry

Postby msuggs on Wed Sep 17, 2008 5:36 pm

Please post the contents of /etc/fstab :)
msuggs
Level 5
Level 5
 
Posts: 882
Joined: Thu Jul 10, 2008 8:25 am
Location: non-local

Re: fstab failed with ntfs-3g entry

Postby AK Dave on Wed Sep 17, 2008 5:54 pm

Make sure you have actually installed the ntfs-3g driver before attempting to use it. Since I install it pretty much by default in a synaptic script that I run on every system, it didn't occur to me that anyone would NOT have ntfs-3g.
User avatar
AK Dave
Level 6
Level 6
 
Posts: 1042
Joined: Wed May 14, 2008 3:39 pm
Location: Anchorage, AK USA

Re: fstab failed with ntfs-3g entry

Postby msuggs on Wed Sep 17, 2008 6:40 pm

ntfs-3g is installed by default in Elyssa main
msuggs
Level 5
Level 5
 
Posts: 882
Joined: Thu Jul 10, 2008 8:25 am
Location: non-local

Re: fstab failed with ntfs-3g entry

Postby T J Tulley on Thu Sep 18, 2008 11:46 am

Thanks, omns. I did install ntfs-config before trying it, and read its manual. As I said, it prevented my system from booting. None of my ntfs partitions is a working Windows installation - 3 are images (XP-Pro) with errors preventing them from booting - I use them as data repositories.

You requested a copy of my /etc/fstab, and the current version is below. This is currently the subject of a topic in Hardware Support:
"Please help! Obstinate card reader - some commands fail." Currently discussion is about labels and 'escaping' spaces in them. However the main problem there is solved - it was the basis of the present topic, which was essentially a report for information.

From Elyssa4 - 18/9/08 - Theo Tulley. Annotated.

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sdc5
UUID=8800ae5a-0d95-4c44-bb35-8b027f4ba2a4 / ext2 relatime,errors=remount-ro 0 1
# /dev/sdc6
UUID=449de6a1-a21d-438a-a19f-431ddcbb7843 /home ext3 relatime 0 2
# /dev/sdb3
UUID=cf721c13-6670-49e3-95a4-ef51eb7787af none swap sw 0 0
# /dev/sdc7
UUID=2486fda4-a0e5-49e2-b424-988f2829e3b5 none swap sw 0 0
# /dev/sdd9
UUID=879da11d-4d05-4c1c-8a60-dbc03454f2ac none swap sw 0 0
LABEL=(E)DI8:H7R /media/sdb1 ntfs defaults 0 0 Mounted at boot
LABEL=Backups /media/Backups ntfs defaults 0 0 Mounted at boot
LABEL=PC\x20Scheduled /media/PC\x20Scheduled ntfs defaults 0 0 Fails to mount (LABEL problem) at boot, will mount on command
LABEL=D\x26S\x20Scheduled /media/D\x26S\x20Scheduled defaults 0 0 Fails to mount (LABEL problem) at boot, will mount on command
LABEL=SATABkps /media/sdd1 ntfs rw,uid=1000,nodev,relatime 0 0 Mounted at boot
LABEL=root-Daryna /media/sdd8 ext3 defaults 0 0 Fails to mount at boot, will mount on command
LABEL=home-Daryna /media/sdd10 ext3 defaults 0 0 Fails to mount at boot, will mount on command
LABEL=SATA-5 media/sdd5 ext3 defaults 0 0 Mounted at boot
LABEL=SATA-6 media/sdd6 ext3 defaults 0 0 Mounted at boot
LABEL=SATA-7 media/sdd7 ext3 defaults 0 0 Mounted at boot
/dev/scd1 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/scd0 /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
/dev/sdf1 /media/Cardreader vfat umask=0000,uid=1000,gid=1000,auto,rw,users 0 0 Now auto-mounts on connection
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Re: fstab failed with ntfs-3g entry

Postby msuggs on Thu Sep 18, 2008 4:17 pm

I don't understand the necessity to label everything. I usually create a folder with a name I want then just mount into that. Below is a copy of my fstab on a machine I have that mounts 3 ntfs partitions with rw access. I'd also suggest getting the UUID for each partition and mounting them that way. Run the command 'sudo blkid' to get the UUID info for each partition.

hth

Code: Select all
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sdb1
UUID=b9e8d09a-a9af-4727-bc48-8016b23179cb /               ext3    relatime,errors=remount-ro 0       1
# /dev/sda1
UUID=2E2C539B2C535D41 /dos            ntfs    defaults,umask=007,gid=46 0       1
# /dev/sda5
UUID=E8F0938FF093629C /gtajk          ntfs    defaults,umask=007,gid=46 0       1
# /dev/sdb3
UUID=ef94cd4a-c7fc-4bf6-9bf4-6e93f6847877 /home           ext3    relatime        0       2
# /dev/sda6
UUID=8CB0BE56B0BE468C /photos         ntfs    defaults,umask=007,gid=46 0       1
# /dev/sdb2
UUID=4b988a2f-5ab8-4975-9033-35924e5146f7 none            swap    sw              0       0
/dev/scd1       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/scd0       /media/cdrom1   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
msuggs
Level 5
Level 5
 
Posts: 882
Joined: Thu Jul 10, 2008 8:25 am
Location: non-local

Re: fstab failed with ntfs-3g entry

Postby T J Tulley on Thu Sep 18, 2008 5:22 pm

Thanks, omns.

Husse isn't at all keen on UUIDs! See his Wiki article - referenced in a locked post in Installation & boot forum.

For me, the problem is exacerbated because 3 of my ntfs partitions are images of a single original - they all have identical UUIDs! Their labels were created subsequently under Win XP-Pro. A problem arises because 2 of the labels include spaces.

I have used the partition-identities in the past - in some installations these have mounted, but in this one they don't.

I'm now considering creating a new installation - more than an hour's work by the time updates are installed, to say nothing of supplementary software. In particular, there is a Gnome problem in Elyssa4 which I believe I transferred from Elyssa3 by copying my entire /home partition into the new one - it arose late during the life of Elyssa3 (which can still boot).

I'll try abandoning the labels for the non-mounting ntfs partitions and see what emerges. It's not very important - I rarely want them.
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Re: fstab failed with ntfs-3g entry

Postby msuggs on Fri Sep 19, 2008 7:47 am

Interesting article on UUID's. There's pluses and minuses for everything I guess.

As for your labelling problem, there's no need to stick to the original windows labels. As long as you create the directory for the partition to mount into and use that in your fstab entry, then you can call it whatever you like.
msuggs
Level 5
Level 5
 
Posts: 882
Joined: Thu Jul 10, 2008 8:25 am
Location: non-local

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: administrollaattori, xfrank and 25 guests