Press S to skip mounting or M for manual Recovery [SOLVED]

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

Press S to skip mounting or M for manual Recovery [SOLVED]

Postby jettdigitals on Tue Jun 24, 2014 9:56 am

Greetings!

I have read and read until cross eyed... Most likely been asked here but being new perhaps I have overlooked by not know correct terminology.

At this point I am learning LinuxMint and doing so on a "scratch drive". This way I learn form my mistakes and will remember them:)

Anyway, getting this message at startup when rebooting:

"keys:Continue to wait, or Press S to skip mounting or M for manual recovery"

Have played around with gparted and deleted, reformatted and even increased some partitions. Most likely this is what caused my issue. But as I said learning and what better way then mess something up.

Here is contents of my fstab:

Code: Select all
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=6041ee18-ccfd-4d34-9ef9-66dfee292e1e /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=c25b5e07-1bf9-4558-b43d-bef5b98b31ed none            swap    sw              0       0
/dev/disk/by-uuid/e0814fe9-6baa-4278-8eac-bd269306eba0 /mnt/e0814fe9-6baa-4278-8eac-bd269306eba0 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/6c5d33b2-1438-4b88-bb8e-c0a8953d45ae /mnt/6c5d33b2-1438-4b88-bb8e-c0a8953d45ae auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/01CE91F1DA75C460 /mnt/01CE91F1DA75C460 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/4FB389F3526BFD5B /mnt/4FB389F3526BFD5B auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/16930D8C043DBA1A /mnt/16930D8C043DBA1A auto nosuid,nodev,nofail,x-gvfs-show,noauto 0 0


Anyone care to pinpoint the issue? What should I change to get rid of "keys:Continue to wait, or Press S to skip mounting or M for manual recovery" ?

Note: I can boot up fine by pressing "S".

Many thanks!
Last edited by jettdigitals on Tue Jun 24, 2014 5:10 pm, edited 1 time in total.
Being old has it advantages...
jettdigitals
Level 1
Level 1
 
Posts: 4
Joined: Thu Jun 19, 2014 9:20 am
Location: Texas

Linux Mint is funded by ads and donations.
 

Re: Press S to skip mounting or M for manual Recovery

Postby altair4 on Tue Jun 24, 2014 12:48 pm

The short answer for the cause of your dilemma is the use of the "Disks" utility.

Don't use it.

Use templates instead. Here are some generic templates for an ntfs and ext4 formatted partitions:
Code: Select all
UUID=DA9056C19056A3B3 /media/WinD ntfs defaults,nls=utf8,umask=000,uid=1000,windows_names 0 0
UUID=076426af-cbc5-4966-8cd4-af0f5c879646 /media/Data ext4 defaults,noatime 0 2


The way you use these are like this:

[1] Determine the correct UUID number for your partitions by running this command:
Code: Select all
sudo bklid -c /dev/null

[2] Create mount points for these partitions, for example:
Code: Select all
sudo mkdir /media/WinD

[3] Add to /etc/fstab the desired template correcting for the correct UUID and mount point.

[4] Then run the following command to see if there are any errors in the boot process:
Code: Select all
sudo mount -a

If everything works it should just come back to the prompt. If it doesn't it will tell you what's wrong.

Notes:

** There is no need to change ownership or permissions of the mount point before the partition is mounted. Mounted partitions don't inherit permissions from the unmounted mount point - it's the other way around.

** The permissions of a mounted ntfs partition are determined by the fstab expression itself.

** On ext4 partitions you can change ownership and permissions if you want but only after the partition is mounted.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6209
Joined: Tue Feb 03, 2009 10:27 am

Re: Press S to skip mounting or M for manual Recovery

Postby MartyMint on Tue Jun 24, 2014 2:37 pm

altair4 wrote:The short answer for the cause of your dilemma is the use of the "Disks" utility.

Don't use it.



Yep.

"Disks" should have been the answer to long-standing FSTAB problems people have faced...
Unfortunately, it's not.

Although manually setting FSTAB is the "best" way, we really still need a graphical tool that works.
User avatar
MartyMint
Level 4
Level 4
 
Posts: 481
Joined: Thu Dec 27, 2012 10:50 pm

Re: Press S to skip mounting or M for manual Recovery

Postby WinterTroubles on Tue Jun 24, 2014 2:45 pm

altair4

I hope you don't object, but, I've just used this quote
altair4 wrote:The short answer for the cause of your dilemma is the use of the "Disks" utility.

Don't use it.


here.. http://forums.linuxmint.com/viewtopic.php?f=90&t=170450&p=880410#p880410 in response to a recommendation to use the Disks utility to alter auto mounting. I also included a link to this topic to provide context.
Linux noob...lurking in the corner...reading quietly...absorbing hopefully...possibly learning..

Mint17Cinn32bit

http://www.copy.com 15 GB free storage + 5GB referral bonuses available
User avatar
WinterTroubles
Level 5
Level 5
 
Posts: 797
Joined: Fri Apr 11, 2014 6:25 am
Location: UK

Re: Press S to skip mounting or M for manual Recovery

Postby jettdigitals on Tue Jun 24, 2014 4:03 pm

Thank you! for your guidance.

As I said, learning linux and what better way than to make mistakes. Learn from them and then get the correct methods from folks like yourself.

Appreciate your input much. Will post back my outcome.
Being old has it advantages...
jettdigitals
Level 1
Level 1
 
Posts: 4
Joined: Thu Jun 19, 2014 9:20 am
Location: Texas

Re: Press S to skip mounting or M for manual Recovery

Postby jettdigitals on Tue Jun 24, 2014 4:43 pm

I forgot to ask:

Which line in the FSTab is causing my issue? Like to know for future reference if possible to tell.

Many thanks.
Being old has it advantages...
jettdigitals
Level 1
Level 1
 
Posts: 4
Joined: Thu Jun 19, 2014 9:20 am
Location: Texas

Re: Press S to skip mounting or M for manual Recovery

Postby jettdigitals on Tue Jun 24, 2014 5:09 pm

OK, think I have a handle on this issue and solved it.

Few days ago when I started this adventure had some extra partitions on one of my drives. During install/setup from LiveCD, those partitions were added to FSTab. Used Gparted and deleted partitions then resized another partition to use the unallocated space.

These partitions were not removed from FSTab:
Code: Select all
/dev/disk/by-uuid/e0814fe9-6baa-4278-8eac-bd269306eba0 /mnt/e0814fe9-6baa-4278-8eac-bd269306eba0 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/6c5d33b2-1438-4b88-bb8e-c0a8953d45ae /mnt/6c5d33b2-1438-4b88-bb8e-c0a8953d45ae auto nosuid,nodev,nofail,x-gvfs-show 0 0


I placed a # in front of the lines and now I have normal boot.

I of course followed the advice here and manually edited my FSTab. Everything working as should and now sharing with windows machines on the network is working:)

Many thanks for your help.
Being old has it advantages...
jettdigitals
Level 1
Level 1
 
Posts: 4
Joined: Thu Jun 19, 2014 9:20 am
Location: Texas

Re: Press S to skip mounting or M for manual Recovery

Postby reza on Sun Oct 05, 2014 2:17 am

altair4 wrote:The short answer for the cause of your dilemma is the use of the "Disks" utility.

Don't use it.

Use templates instead. Here are some generic templates for an ntfs and ext4 formatted partitions:
Code: Select all
UUID=DA9056C19056A3B3 /media/WinD ntfs defaults,nls=utf8,umask=000,uid=1000,windows_names 0 0
UUID=076426af-cbc5-4966-8cd4-af0f5c879646 /media/Data ext4 defaults,noatime 0 2


The way you use these are like this:

[1] Determine the correct UUID number for your partitions by running this command:
Code: Select all
sudo bklid -c /dev/null

[2] Create mount points for these partitions, for example:
Code: Select all
sudo mkdir /media/WinD

[3] Add to /etc/fstab the desired template correcting for the correct UUID and mount point.

[4] Then run the following command to see if there are any errors in the boot process:
Code: Select all
sudo mount -a

If everything works it should just come back to the prompt. If it doesn't it will tell you what's wrong.

Notes:

** There is no need to change ownership or permissions of the mount point before the partition is mounted. Mounted partitions don't inherit permissions from the unmounted mount point - it's the other way around.

** The permissions of a mounted ntfs partition are determined by the fstab expression itself.

** On ext4 partitions you can change ownership and permissions if you want but only after the partition is mounted.


I was cracking everything to get rid of this problem. And finally worked out. In "Disks" utility I changed my Windows 7 partition as automount off. Then restart & it resolved! But weird enough, in "Disk" for that partition I see it changed to on! Whatsoever, I think it might be dilemma of using "Disks"!
reza
Level 1
Level 1
 
Posts: 1
Joined: Sun Oct 05, 2014 2:11 am

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: eppoh, kbkatz1 and 10 guests