Installing w/o loosing /home contents?

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Installing w/o loosing /home contents?

Postby humaneasy on Thu Oct 02, 2008 8:56 am

Hi,

I posted at another section of this forum inside another more or less related topic the question mentioned in the subject above.

My current partition table is visible at a picture I posted there.

Can someone help me on this? It is somewhat urgent :mrgreen:
humaneasy
Level 1
Level 1
 
Posts: 27
Joined: Wed Jun 11, 2008 10:45 am
Location: Portugal

Linux Mint is funded by ads and donations.
 

Re: Installing w/o loosing /home contents?

Postby rivenought on Thu Oct 02, 2008 10:10 am

I have updated or reinstalled Mint several times and kept the exact same /home. All you need to do during the partitioning phase is to NOT format /home. I have never had a problem. Good luck.
rivenought
Level 5
Level 5
 
Posts: 780
Joined: Wed Apr 09, 2008 10:34 am

Urgent: Installing w/o loosing /home contents?

Postby humaneasy on Sat Oct 04, 2008 1:25 pm

I did the fresh install without formating my /home partition.

Now I don't have neither Ubuntu nor Mint :(

Errors:
  1. At startup message stating that "/etc/grub/message.elyssa" is missing but the file is there
  2. Mint booting screens are in a lower resolution than when using the live CD
  3. GDM is in english even if I defined the installation as PORTUGUESE and also redefined it the first time I used GDM (this won't happen with Ubuntu)
  4. Gnome splash uses a Gnome default theme and not Mint's one
  5. My environment is GNOME in english (partially) and not MINT's one (see screenshot attached)

What shall I remove from my /home directory or change so it works correctly?

Screenshot.png
My current messy desktop
Screenshot.png (38.65 KiB) Viewed 465 times
humaneasy
Level 1
Level 1
 
Posts: 27
Joined: Wed Jun 11, 2008 10:45 am
Location: Portugal

Urgent: Installing w/o loosing /home contents?

Postby humaneasy on Sat Oct 04, 2008 5:07 pm

Some errors are solved thanks to rivenought:

  • At startup message stating that "/etc/grub/message.elyssa" is missing but the file is there

rivenought wrote:To get the Elyssa message out of the way, you need to click Linux Mint Menu –> Terminal. When the Terminal screen pops up, key in:

Code: Select all
sudo cp /etc/grub/message.elyssa /boot/grub/


Press the Enter key, type in your password, and then click OK.

Now, you should type in:

Code: Select all
gksudo gedit /boot/grub/menu.lst


When the menu list pops up, scroll down to find the line that reads:

Code: Select all
gfxmenu=/etc/grub/message.elyssa


Change that line to read:

Code: Select all
gfxmenu=/grub/message.elyssa


Save the changes, close the terminal window, and reboot to verify the changes. The computer should boot right up to the log-in screen. This is a very common procedure in Mint with those of us who have separate /boot partitions.


My /etc is on a partition diferent than the one that boots so it is not mounted and files, obviously, cannot be found.

  • Mint booting screens are in a lower resolution than when using the live CD

rivenought wrote:In reference to resolutions, not sure if this is what you need but it is what I do:

First off, the exact resolution desired must be chosen. From this chart, pick the resolution necessary for your hardware. As an example, I need the 1024×768 16-bit resolution, so I choose the number 791.

Code: Select all
640×480    800×600    1024×768    1280×1024    1600×1200
    8bit    769    771    773    775    777
    15bit    784    787    790    793    796
    16bit    785    788    791    794    797
    24bit    786    789    792    795    798


Once you know your number, here is what needs to be done:

Click on the mintMenu and choose Terminal. In Terminal, key in (if you use GNOME):

Code: Select all
gksudo gedit /boot/grub/menu.lst


Enter your password and click OK. Scroll down the page until you get to the ## End Default Options ## section. The third line under there reads something similar to:

Code: Select all
kernel /vmlinuz-2.6.24-16-generic root=/dev/sda3 ro quiet splash


Put your resolution number at the end of that line so it reads something similar to:

Code: Select all
kernel /vmlinuz-2.6.24-16-generic root=/dev/sda3 ro quiet splash vga=791


Once you have this done, save the “menu.lst file” and close the Terminal. Reboot the computer to verify the changes. You should boot up into the correct resolution.


  • GDM is in english even if I defined the installation as PORTUGUESE and also redefined it the first time I used GDM (this won't happen with Ubuntu)

You need to click Linux Mint Menu –> Administration –> Language Support and select your own language on the "Supported Languages" panel.

Although the "Default Language" appears correctly as the one you choose on installation, only then the necessary files will be downloaded and installed.
This seems to me to be a bug in the Live installer.

  • Gnome splash uses a Gnome default theme and not Mint's one
  • My environment is GNOME in english (partially) and not MINT's one (see screenshot attached)

This last ones above are still unsolved, except on the language error. If someone else can have an hint... :D
humaneasy
Level 1
Level 1
 
Posts: 27
Joined: Wed Jun 11, 2008 10:45 am
Location: Portugal


Return to Installation & Boot

Who is online

Users browsing this forum: gold_finger and 12 guests