Several installations - report (edited twice)

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Several installations - report (edited twice)

Postby T J Tulley on Sun Oct 05, 2008 2:18 pm

Edits shown in red - 6/10/08-09:25
Second edit (at end) shown in blue - 7/10/08-13:05

This is intended to be helpful to the development team - if you don't want things like this, please let me know.
My 2 optical drives are EIDE Primary master and slave. hd0 and 1 are EIDE secondary master and slave. hd2 is a 500 GB SATA drive.

I have installed Elyssa at least 8 times for various reasons. Currently 3 of these are sometimes accessible. These are:
Elyssa3 on hd0,1 and 4; Elyssa4 on hd1,4 and 5; Elyssa6 on hd2,7 and 6.

Generally I have abandoned an installation when it became too prone to booting into BusyBox - sometimes there is a recovery from this, as has happened in Elyssa3, but it can't be depended upon. In Elyssa3 inadvertent keystrokes created a fault in Gnome so that application icons on the desktop became "documents" and stopped working. That was carried forward to Elyssa4 either by copying the whole /theo (user) folder or by importing during installation.

Currently I am working in Elyssa4 because Elyssa6 has failed (see below) - this gets as far as inviting log-on, then always reports "Your session lasted less than 10 seconds - - - " - but I did set a root password, so I can log on as root - very useful in emergency! At the moment it's my only access to the machine. Working as root gives me a (US?) keyboard with " and @ interchanged. This boot has survived hibernation - in spite of saying as usual that hibernation failed.
[BTW, is there any prospect of correcting the fault which prevents log-on as myself?].

My most recent installation is Elyssa6; - unusually, that has /boot/grub/device.map setting hd0=sda; hd1=sdb; hd2=sdc. More usually they are set as sdb, c and d. [Why the erratic performance of the installer?].

Elyssa6 worked perfectly and its demise I believe results from a silly mistake - I switched off power! However, after 2 attempts it re-booted from Recovery mode but after shut-down last night, this morning it booted every time into BusyBox, both from normal and recovery modes.

When I selected Shut down finally last night, the screen reported nearly a whole screenful of various processes - FAILED - too fast to see what they were. I've not seen this before. Now I have just mounted the root partition of that installation - /var/log/syslog there shows the final actions - among them is only one line saying Failed. Here it is:
Oct 4 23:51:34 TJT4Elyssa6 gdm[6409]: GLib-CRITICAL: g_hash_table_lookup_extended: assertion `hash_table != NULL' failed

One thing which worries me about that partition is that /initrd, /proc, /srv and /sys all show as containing 0 items. I've seen similar appearances before: they can be misleading.

However, if I set the terminal location in that partition and enter $ ls -al, one line shows:
lrwxrwxrwx 1 root 999 33 2008-10-02 22:04 initrd.img -> boot/initrd.img-2.6.24-16-generic
which is identical to the corresponding line with the terminal located in / - i.e. this working system.

BTW - a final question: Is there any way of copying all the updates and extra software for installation into a new system? This would save a lot of time and thought. I routinely install Gimp, Gramps 3.02 (not in the repository, but compatible with Hardy) and set up a number of dynamic links on the desktop. No way of saving these as a group, I suppose?

[I still hope to see a recovery of Elyssa6 - if not, yet another to do. I have routinely copied my Firefox & Thunderbird set-ups into a backup file on another drive].
Thanks to a suggestion to modify the /boot/grub/menu.lst entry the problem is now cured - see "About BusyBox - now solved" in Newbie Questions forum.
Yours hopefully -

Theo Tulley.
Using a PC with 2GB RAM, 3 hdds and a 1.7 GHz Celeron cpu.
User avatar
T J Tulley
Level 5
Level 5
 
Posts: 581
Joined: Wed Jul 18, 2007 10:18 am
Location: Hull, England

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: Derek_S, Resistor and 11 guests