Boot problem

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

Boot problem

Postby Layor on Mon Nov 24, 2008 1:27 pm

Hi, I've just installed Elyssa Mint and I am realy impressed. But... (there's always a but!!) It boots fine if the hard disc it is on is the only one connected. However, if I reconnect my XP OS disc (20Gb) and the SATA 500 Gb data disc and select the Mint H/D to boot from the boot menu when starting the computer(I do not want a dual boot), it gets stuck on the 'Busybox' and waits with the cursor flashing at the 'initramfs'.
Any help would be appreciated as I do not want to disconect the drives each time I want to start 'Mint'.
Many thanks, Layor.
Layor
Level 1
Level 1
 
Posts: 8
Joined: Mon Nov 24, 2008 11:43 am
Location: Llandrindod Wells, Wales

Linux Mint is funded by ads and donations.
 

Re: Boot problem

Postby guest on Mon Nov 24, 2008 4:56 pm

try option 5 for this=>http://www.linuxmint.com/wiki/index.php/Troubleshooting_your_Live_CD add the
Code: Select all
all_generic_ide


hope that helps
guest
 

Re: Boot problem

Postby Layor on Wed Nov 26, 2008 5:24 pm

Still no luck!
I tried installing 'Felicia' hoping it might help but no go. Although it now says cannot find 'init' file. But the same problem is still there as in it loads okay with the hard disc on its own, but not with other hard drives attached.
I think I might try installing 'Ubuntu' to see if the same thing happens.
If anyone has any other idea's I would be very grateful for any input :)
Layor
Layor
Level 1
Level 1
 
Posts: 8
Joined: Mon Nov 24, 2008 11:43 am
Location: Llandrindod Wells, Wales

Re: Boot problem

Postby Fred on Wed Nov 26, 2008 11:35 pm

Layor wrote:
It boots fine if the hard disc it is on is the only one connected... boot from the boot menu when starting the computer(I do not want a dual boot), it gets stuck on the 'Busybox'... I do not want to disconnect the drives each time I want to start 'Mint'.


Well... That is the way you installed it. It appears that you installed Mint with only the one drive connected. When you plug the other drives in, the drive partition designators change from what it was on a single drive to the multi drive setup. You say that you don't want a dual boot, but at the same time you don't want to have to manually swap drives. You can't have it both ways. If all the drives stay connected and you wish to select which of the two OSs to boot, that is by definition a dual boot system.

And yes, if you install Ubuntu the same way, you will get the same result. I would suggest you rethink what you want to accomplish, read some of the partitioning and dual boot threads in the forum, and take a look at the user guide and wiki. If you do this you will have a much better chance of having a stable, serviceable system regardless of which distro you choose to install.

Fred
Insanity: Doing the same thing over and over and each time expecting a different result.

Democracy is 2 wolves and a lamb voting on the menu. Liberty is an armed lamb protesting the electoral outcome. A Republic negates the need for an armed protest.
User avatar
Fred
Level 10
Level 10
 
Posts: 3356
Joined: Fri Jan 04, 2008 11:59 am
Location: NC USA

Re: Boot problem

Postby keithp on Thu Nov 27, 2008 5:35 am

My setup here is 2 hard drives. DriveA has XP and DriveB has Mint. As the BIOS boots, I use F8 to select which drive I want to use.

When I installed Mint, I too unplugged the XP drive. On replugging, I had the busybox problem.

Going to /boot/grub/menu.lst, I found that Mint was listed as sda (which was the wrong drive). I changed this to sdb.

All is now well.

I'm not saying that yours is similar, just telling you what I did.

Hope this helps.

Keith
keithp
Level 3
Level 3
 
Posts: 124
Joined: Wed Dec 27, 2006 6:17 am
Location: Cheshire, England

Re: Boot problem

Postby Guest on Fri Nov 28, 2008 5:55 pm

Hi Keith,
I think you may have the answer. I've checked the 'menu.lst' file and it does have an 'sda1' in it. Now my problem is getting it to let me change it! I'm not sure where the permissions are for doing that. I've tried several changes in the 'Administrations >Authorisations' but to no avail.
Can anyone help, please?
By the way, as I mentioned before, I have had this type of setup, XP and Linux, running on two separate HD's and just selecting the Linux on pressing the 'boot' key, with XP as the default start up OS. That way my better half could not accidentally start Linux via a dual boot screen.
Many thanks, Layor
Guest
 

Re: Boot problem

Postby Fred on Sat Nov 29, 2008 3:23 am

Layor,

My point was that you are still dual booting. You have two OSs and you can choose to run either of them. There are multiple ways of doing that, but you are still dual booting.

If you wish to edit your menu.lst file you can do so by running in a terminal:

gksu gedit /boot/grub/menu.lst

This will open that file for editing. I can't tell you what you need to change your boot sequence to though. That would depend upon how the bios reassigned the drive partition when it is in combination with the other drives.

If you will post screen shots of the partition tables for each drive when they are all connected I can tell you what to change your menu.lst to.

In the future, you don't have to disconnect drives to make installs and dual boot with the bios selections. ie using the F8 key or whatever key combination your system uses. When installing, select to install grub to the drive you are installing to with the "advanced" button on the screen of the installer before it starts the actual install. Then the installer will set everything up correctly for you.

Fred
Insanity: Doing the same thing over and over and each time expecting a different result.

Democracy is 2 wolves and a lamb voting on the menu. Liberty is an armed lamb protesting the electoral outcome. A Republic negates the need for an armed protest.
User avatar
Fred
Level 10
Level 10
 
Posts: 3356
Joined: Fri Jan 04, 2008 11:59 am
Location: NC USA

Re: Boot problem

Postby Layor on Sat Nov 29, 2008 9:28 am

Hi Fred,
Thanks for your advice. I know what you are saying about the dual boot, I guess what I was trying to say was, that I did not want an opening screen giving the choice of OS's to boot to. And if switched on the computer would just boot straight into the XP OS.
I had a nasty incident the last time I installed a Linux OS (Ubuntu) onto my system with the new 500Gb SATA drive attached. I ended up having to to a complete reinstall of XP and must have done something to the SATA drive as it refused to take the install and I'm now using a 30Gb HD as a separate OS system. It actually works out quite well as I have made a clone of the disk (hidden away in a dark room!) and if any lurgy strikes then I'm covered! It also means that the system is a lot faster to load.
The same goes for the Mint disc. If I bodge anything up it will not affect anything else.
I must admit though, I am really impressed with Mint and I imagine that I will be swapping a lot of my files over to it. Although I'll still keep using XP for the few games I have.
Many thanks, Layor :D
Layor
Level 1
Level 1
 
Posts: 8
Joined: Mon Nov 24, 2008 11:43 am
Location: Llandrindod Wells, Wales

Re: Boot problem

Postby lead67 on Sat Nov 29, 2008 10:59 am

this is for Keithp, on your post:
"...Going to /boot/grub/menu.lst, I found that Mint was listed as sda (which was the wrong drive). I changed this to sdb.

All is now well."

I had the same issue, since i am new to Linux i could not use the advance settings and found the easy way to unplug the other drive (Wvista Ultimate) what i do is the at the log in screen i see a line at the bottom and i entered the right letter for my drive which is sdb1 instead of sda1 and log in, now is it safe to just go into the menu.lst and enter the letter and that is it? i saw it but i was afraid to just type the letter and save, is it really safe to do just that? i found that at the bottom of the menu.lst i think that is where the change must take place, right?
i will appreciate it if you can help me w/this issue so that i don't have to be typing the letter everyday at the log in screen.

thanks,
Fabio
Mobo-EP-43-DS3L
CPU-Core 2 Quad Q9550 2.83GHz
RAM- 4gigs (2x1GB) ballistix 2.2v
PSU- Thermaltake 850W
HDD- 1 WD 120 gig/1 Seagate 120 gig
Linux Mint Isadora 9 64bits video driver 195.36.15
Vista Home premium
EVGA GTX 260 SC 896GB DDR3 driver 257.21
lead67
Level 2
Level 2
 
Posts: 82
Joined: Thu Nov 13, 2008 2:16 am
Location: san mateo, california

Re: Boot problem

Postby Layor on Sat Nov 29, 2008 2:20 pm

Hi all,
Many thanks for the help :D
I have edited the .menu.lst' file - after first doing a print-out of the original file, just in case! - and all is well.
It was such a simple solution to what seemed like a heck of a problem. If only everything were as straight forward :lol:
Hope I can help out someone one day.
Layor
Layor
Level 1
Level 1
 
Posts: 8
Joined: Mon Nov 24, 2008 11:43 am
Location: Llandrindod Wells, Wales

Re: Boot problem

Postby Layor on Sat Nov 29, 2008 2:28 pm

To Fabio...
If you copy and paste this:: gksu gedit /boot/grub/menu.lst :: into your terminal you can safely change the text. This is all credit to Fred, as it is what I did and it worked brilliantly.
You can always make a backup of the 'menu.lst' file and rename it to something like 'backupmenu', or something memorable incase things go wrong!
Layor
Layor
Level 1
Level 1
 
Posts: 8
Joined: Mon Nov 24, 2008 11:43 am
Location: Llandrindod Wells, Wales

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 22 guests