Mint - poweroff problem - Intel HDA sound driver a solution

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Mint - poweroff problem - Intel HDA sound driver a solution

Postby Happy in RetireMINT on Tue Nov 25, 2008 1:04 pm

I have been using Linux Mint since the Cassandra release. It has been a pleasurable experience in that it has always been a little snappier in performance compared to the Ubuntu releases. I discovered though that on attempting to power off, the splash screen would sit on the screen after the countdown bar had finished its task. I thought this was just a glitch and used the hard button shutdown during this time. In the meantime, I was trying a variety of other distributions to find one that I liked and that would power down properly. No matter which ones I tried, I was never as pleased as when I was using Mint. By this time, I was up to the Elyssa version. I have spent over a year searching forums and the web for a solution to this problem. It appears that the problem is related to all the Ubuntu kernels going back prior to Ubuntu 7.04.
I have tried the "apci" and "apm" options suggested without any luck. Even the "shutdown - ?" options.
I finally found a solution that works for me at https://bugs.launchpad.net/ubuntu/+sour ... +bug/43961. It appears that my Gateway 832 GM has an Intel HDA sound driver. I applied the suggestion as stated and I have been able to power down successfully using Linux Mint Elyssa and Linux Mint Felicia. See the quote from the bug forum that I used to resolve my problem.

Johan Holmquist wrote on 2008-10-23: (permalink)
Adding "rmmod snd_hda_intel" to the end of /etc/default/halt worked on my LG LW20 Express Laptop.
If you have the same kind of computer, just write this in a terminal window:
sudo gedit /etc/default/halt
enter your password (nothing will be shown, not even *, but it's still being written)
In the gedit window, add "rmmod snd_hda_intel" without the "" to the end of the last row.
Save.
'Shut down' and 'Hibernate' now works! Thanks StevenMcCoy for finding a solution and posting it here!


I hope that this will help those that have the same sound driver that I have.

To Clem and the Mint team - please keep up the excellent work on this project. I am 99% Windows free.
Happy in RetireMINT
Level 1
Level 1
 
Posts: 2
Joined: Sun Oct 07, 2007 12:56 pm
Location: Ste. Anne MB Canada

Linux Mint is funded by ads and donations.
 

Re: Mint - poweroff problem - Intel HDA sound driver a solution

Postby Husse on Wed Nov 26, 2008 8:22 am

Please always use gksu (kdesu) for GUI apps, you maight get into trouble in rare cases with sudo
I changed the subject a little to reflect the content
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Installation & Boot

Who is online

Users browsing this forum: BoDill, ClutchDisc, Minterator and 18 guests