Moved Bianca to external usb drive, won't boot

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Moved Bianca to external usb drive, won't boot

Postby pashabear on Mon Apr 09, 2007 11:59 am

Well, I rearranged my setup again, copied my Mint partition over to my external usb drive and installed Mepis on the internal (sorry, as I prefer KDE, Mepis is better for me, and 6.5 looks good so far). I want to keep my Bianca install, as it's got a bunch of extra stuff installed and I really like the system.

Previously I installed SLED 10 to my external drive and used a chainload from my internal (MBR) GRUB, that worked ok. In my naivety I thought overwriting that partition with the Mint one would be all I'd need to do. But of course it doesn't, can anyone give me an idea of what I need to change, if possible I'd like to avoid re-installing Mint.

Thanks
pb
User avatar
pashabear
Level 3
Level 3
 
Posts: 111
Joined: Fri Jan 05, 2007 11:59 pm
Location: Moscow, Russia

Linux Mint is funded by ads and donations.
 

Postby deppsche on Mon Apr 09, 2007 6:06 pm

copied my Mint partition over to my external usb drive


maybe you should reinstall Grub in your root-partion of the Mint-Install. and test chainload again
User avatar
deppsche
Level 1
Level 1
 
Posts: 2
Joined: Thu Apr 05, 2007 7:51 pm
Location: Germany - Hessen

Postby RobF on Tue Apr 10, 2007 6:47 pm

It sounds as though GRUB (or to be more precise the boot code of GRUB stage 1) had never been installed in the first sector of your external USB drive where it would have overwritten the original MS-DOS MBR.

I suppose you could go with deppsche's suggestion and again try to boot Mint from the GRUB on your internal drive, or you could install GRUB in the first sector of the external drive and boot from there.

If you want to do the latter, you could do that from the Mint live CD.

First, check the files device.map and menu.lst in /boot/grub of your Mint install on the USB drive to make sure they are correct.

device.map should list (hd0) /dev/sda and (hd1) /dev/sdb if your internal drive is a SATA drive, or (hd0) /dev/hda and (hd1) /dev/sda if your internal drive is an ATA drive.

When you boot directly into the external USB drive, the BIOS considers that drive to be the primary boot drive, and accordingly it should be designated (hd0) in GRUB terminology, whereas the internal drive should be (hd1). Therefore, in menu.lst the first stanza should be something like the following (I'm assuming that Mint resides in the first partition of the external drive and that the system device name of the external drive is sdb, if not revise accordingly)

title Linux Mint, kernel 2.6.17-10-generic
root (hd0,0)
kernel /boot/vmlinuz-2.6.17-10-generic root=/dev/sdb1 ro quiet splash
initrd /boot/initrd.img-2.6.17-10-generic
quiet
savedefault
boot

and the other stanzas should be edited similarly, if needed.

Then ascertain which mount point the Mint live CD has assigned to the Mint partition on the external drive (let's suppose it's /media/usbdisk) and accordingly run the following (assuming that the device name of the external drive is sdb)

$ sudo grub-install --root-directory=/media/usbdisk /dev/sdb

That will install the GRUB stage 1 boot code in the MBR of the external drive and make that partition and any others that are listed in the menu.lst accessible and potentially bootable. You may also want to set the boot flag for the Mint partition, using the Gnome Partition Editor (i.e. GParted).

Then make sure the option of booting from a USB HDD is enabled in the BIOS, reboot and hit F12 (or whatever the keycode is on your system for directly booting from a USB HDD). The GRUB menu for the external drive should come up, offering you the option of booting into Mint.
RobF
Level 1
Level 1
 
Posts: 3
Joined: Tue Apr 10, 2007 6:37 pm

Postby pashabear on Mon Apr 16, 2007 9:28 am

I'm trying to reinstall Grub in the root-partition, as per deppsche's suggestion, but I get the following error from Grub:
Code: Select all
grub> root (hd1,5)
 Filesystem type is ext2fs, partition type 0x83

grub> install (hd1,5)

Error 1: Filename must be either an absolute pathname or blocklist


Any ideas?
pb
User avatar
pashabear
Level 3
Level 3
 
Posts: 111
Joined: Fri Jan 05, 2007 11:59 pm
Location: Moscow, Russia

Postby Boo on Mon Apr 16, 2007 11:11 pm

try the device name

grub> install /dev/hdb5

or it could be hdb6
:)
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Postby pashabear on Tue Apr 17, 2007 1:16 pm

That doesn't work either...

Code: Select all
grub> install /dev/sda6

Error 15: File not found


(and yes, sda6 is my mint partition on my external drive)
User avatar
pashabear
Level 3
Level 3
 
Posts: 111
Joined: Fri Jan 05, 2007 11:59 pm
Location: Moscow, Russia


Return to Installation & Boot

Who is online

Users browsing this forum: austin.texas, edosan, expat_tony and 11 guests