GRUB doesn't recognize new Kernel

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

GRUB doesn't recognize new Kernel

Postby shaka_zulu on Sat Jan 17, 2009 11:36 am

Hi there

At first Mint didn't want to update to new Kernel and then i have tried in synaptic to do it on my own and i have completely remove Kernel version 2.6.27-7 which is default when you install new version of Felicia. Then i have found new Kernel i think 2.6.27-14 and i have manually installed this one also in synaptic. I thought that this will going to be enough but on reboot i have seen that actually grub shows only old version of Kernel. When i have tried to edit menu.lst i have also found that there is only old version of Kernel. After a while in synaptic i have found old kernel version installed even i have completely removed it previously.

Three days ago finally update has come and i have found in the list new kernel will be installed. After update no changes have happened. :) Old kernel is the only in the grub :)

Still GRUB shows old kernel version and i do not know what to do exactly about this.

Any help please?
shaka_zulu
Level 1
Level 1
 
Posts: 2
Joined: Fri Jan 16, 2009 9:30 pm

Linux Mint is funded by ads and donations.
 

Re: GRUB doesn't recognize new Kernel

Postby shaka_zulu on Sat Jan 17, 2009 6:12 pm

any answer please!?
shaka_zulu
Level 1
Level 1
 
Posts: 2
Joined: Fri Jan 16, 2009 9:30 pm

Re: GRUB doesn't recognize new Kernel

Postby newW2 on Sat Jan 17, 2009 11:09 pm

So what does
Code: Select all
uname -a
output for the kernel?
Once you have that information you'll need to edit menu.lst. If you are using gnome:
Code: Select all
sudo gedit/boot/grub/menu.lst
and replace the kernel version listed in menu.lst with the version listed from the uname -a output.
Hope that gets you going post back and let us know.

Btw are you doing this because of the following post? And are you following Husse's how-to?
User avatar
newW2
Level 6
Level 6
 
Posts: 1081
Joined: Fri Apr 06, 2007 10:24 am
Location: USA


Return to Installation & Boot

Who is online

Users browsing this forum: administrollaattori, dave_EE and 17 guests