Can't boot

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Can't boot

Postby Higatron on Thu Mar 12, 2009 10:43 pm

I am new to linux, but I'm having trouble getting Linux Mint to boot. I installed Linux Mint, the liveCD works fine, but after I install, and I try to run it, it gives me an error message /dev/sda1 does not exist, and then it puts me at a basic console. I'm on a toshiba satellite a65-s126 laptop. This is a clean install, no partitions or anything.
Higatron
Level 1
Level 1
 
Posts: 4
Joined: Thu Mar 12, 2009 10:32 pm

Linux Mint is funded by ads and donations.
 

Re: Can't boot

Postby Decemberdoom on Fri Mar 13, 2009 9:44 am

There must be SOME partitions, otherwise nothing would be able to install at all. Could you please post a screenshot of your partition table (boot up with the Live CD, then go to Menu>Administration>Partition Editor)

Also, a copy of your /boot/grub/menu.lst file would probably help us quite a bit.
[url]decemberdoom.wordpress.com[/url] Check out my blog.

You know you want to.
Decemberdoom
Level 3
Level 3
 
Posts: 109
Joined: Sat Feb 28, 2009 11:40 pm

Re: Can't boot

Postby Higatron on Fri Mar 13, 2009 3:11 pm

I'm sorry, by no partitions I meant that there weren't any additional partitions

Code: Select all
# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-legacy-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not change this entry to 'saved' or your
# array will desync and will not let you boot your system.
default      0

## Graphical boot menu location
gfxmenu=/boot/gfxmenu/default.message

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout      5

# Pretty colours
color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title      Windows 95/98/NT/2000
# root      (hd0,0)
# makeactive
# chainloader   +1
#
# title      Linux
# root      (hd0,1)
# kernel   /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=/dev/sda1 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,0)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(single-user) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title      Linux Mint 6, kernel 2.6.27-7-generic
root      (hd0,0)
kernel      /boot/vmlinuz-2.6.27-7-generic root=/dev/sda1 ro quiet splash
initrd      /boot/initrd.img-2.6.27-7-generic
quiet

title      Linux Mint 6, kernel 2.6.27-7-generic (recovery mode)
root      (hd0,0)
kernel      /boot/vmlinuz-2.6.27-7-generic root=/dev/sda1 ro single
initrd      /boot/initrd.img-2.6.27-7-generic

title      Linux Mint 6, kernel Last successful boot
root      (hd0,0)
kernel      /boot/last-good-boot/vmlinuz root=/dev/sda1 ro quiet splash  last-good-boot
quiet

title      Linux Mint 6, memtest86+
root      (hd0,0)
kernel      /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST
Higatron
Level 1
Level 1
 
Posts: 4
Joined: Thu Mar 12, 2009 10:32 pm

Re: Can't boot

Postby Higatron on Fri Mar 13, 2009 3:16 pm

and the pic didn't upload D:
Attachments
Partition.jpg
Partition.jpg (254.74 KiB) Viewed 517 times
Higatron
Level 1
Level 1
 
Posts: 4
Joined: Thu Mar 12, 2009 10:32 pm

Re: Can't boot

Postby distoaddict on Fri Mar 13, 2009 4:18 pm

That looks to me that it SHOULD boot. perhaps it is a grub problem.
we may be able to boot up in another way. i advise obtaining supergrub disk and gujin and trying them.
it might also be an idea to post your /etc/fstab
distoaddict
Level 4
Level 4
 
Posts: 212
Joined: Thu Dec 04, 2008 6:35 am
Location: Glasgow Scotland

Re: Can't boot

Postby Higatron on Fri Mar 13, 2009 5:14 pm

Code: Select all
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda1
UUID=981a8c7e-0912-4fba-b9bb-739cf8f5ba72 /               ext3    relatime,errors=remount-ro 0       1
# /dev/sda5
UUID=2ebfe023-77d2-4a1d-b9d3-dc9a189e104b none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0


That's my /etc/fstab

I'll try supergrub and gujin too
Higatron
Level 1
Level 1
 
Posts: 4
Joined: Thu Mar 12, 2009 10:32 pm

Re: Can't boot

Postby distoaddict on Fri Mar 13, 2009 5:34 pm

re your fstab.
i woud edit it from what you have to this.
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda1
/dev/sda1 / ext3 relatime,errors=remount-ro 0 1
# /dev/sda5
/dev/sda5 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

i had problems booting with uuids with supergrub disk
distoaddict
Level 4
Level 4
 
Posts: 212
Joined: Thu Dec 04, 2008 6:35 am
Location: Glasgow Scotland

Re: Can't boot

Postby Decemberdoom on Fri Mar 13, 2009 5:56 pm

Yea, everything DOES look in order with the configuration files...

My best guess is that something happened with the GRUB installation. I second the opinion of trying out Super Grub Disk. Try to see if you can boot into your Mint install from it, if so, that means GRUB just needs to be fixed. If you manage to boot into Mint with SGD, open up a terminal and type the following commands.

Code: Select all
grub

Code: Select all
root (hd0,0)
(From what I gather, Linux is installed on the first partition of your first hard disk)
Code: Select all
setup (hd0)

Code: Select all
quit


Now, take out the Super Grub Disk and reboot, hopefully everything will be well.
[url]decemberdoom.wordpress.com[/url] Check out my blog.

You know you want to.
Decemberdoom
Level 3
Level 3
 
Posts: 109
Joined: Sat Feb 28, 2009 11:40 pm

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: misGnomer and 14 guests