b43-phy0 ERROR

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

b43-phy0 ERROR

Postby minimint on Fri Mar 27, 2009 2:19 pm

hi every one,

when i try to install linux mint 6 on my 2133 KX870AT, it crashes, something about the wireless card, but how can i fix it if it doesnt let me write any command. Compatibility mode doesnt work neither.

please help

i took pictures of the error in case you want to know exactly what the error message says
Image
Image
minimint
Level 1
Level 1
 
Posts: 5
Joined: Fri Mar 27, 2009 2:10 pm

Linux Mint is funded by ads and donations.
 

Re: b43-phy0 ERROR

Postby merlwiz79 on Fri Mar 27, 2009 3:41 pm

Remove the card or disable it in the BIOS.
Then Install Linux Mint.
Here's how to get it working after Linux Mint is installed.
Then download http://packages.ubuntu.com/hardy/b43-fwcutter
Download http://downloads.openwrt.org/sources/br ... .0.tar.bz2

Then install
a) Install the DEB file
b) unpack the tar.gz file: tar xjf broadcom-wl-4.80.53.0.tar.bz2
c) access the new folder: cd broadcom-wl-4.80.53.0/kmod
d) run the command: export FIRMWARE_INSTALL_DIR="/lib/firmware"
e) install the firmware: b43-fwcutter -w "$FIRMWARE_INSTALL_DIR" wl_apsta.o
f) run the command: sudo chmod 755 /lib/firmware/b43
g) restart your computer
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: b43-phy0 ERROR

Postby minimint on Fri Mar 27, 2009 4:45 pm

i disabled my wireless card from BIOS, it didnt work. I upgraded my BIOS from f.05 to f.06 hoping that would fix it but negative. what else could it be :?:
minimint
Level 1
Level 1
 
Posts: 5
Joined: Fri Mar 27, 2009 2:10 pm

Re: b43-phy0 ERROR

Postby merlwiz79 on Fri Mar 27, 2009 6:13 pm

I guess you'll need to take out the card.
Are you sure you saved the settings?
Not sure why acpi=off doesn't work for you.
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: b43-phy0 ERROR

Postby merlwiz79 on Fri Mar 27, 2009 6:31 pm

Ok here's a way that may work for you.
Hit tab to edit the boot options and remove quiet splash --, then add break=top
Then at the (initramfs) prompt, type the following lines:
Code: Select all
echo "blacklist b43legacy" >> /etc/modprobe.d/blacklist
Code: Select all
echo "blacklist bcm43xx" >> /etc/modprobe.d/blacklist
Code: Select all
exit
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: b43-phy0 ERROR

Postby minimint on Fri Mar 27, 2009 7:50 pm

can you explain your procedure step by step, im new to linux and dont manage all the technical words. i mean, i dont know when to hit tab, or break=top

thanks for helping
minimint
Level 1
Level 1
 
Posts: 5
Joined: Fri Mar 27, 2009 2:10 pm

Re: b43-phy0 ERROR

Postby merlwiz79 on Fri Mar 27, 2009 8:51 pm

Once the Live cd starts hit Esc and then tab.
It'll show you the boot options.
Use the backspace to remove quiet splash --
Then type break=top and hit enter.
It'll start booting then stop and you'll be at the (initramfs) prompt
Type echo "blacklist b43legacy" >> /etc/modprobe.d/blacklist and hit enter
Type echo "blacklist bcm43xx" >> /etc/modprobe.d/blacklist and hit enter
Type exit and hit enter
It should now boot the live cd, I hope.
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: b43-phy0 ERROR

Postby minimint on Sat Mar 28, 2009 3:38 pm

i did those commands, then a black screen appears and nothing more
Last edited by minimint on Sat Mar 28, 2009 4:08 pm, edited 1 time in total.
minimint
Level 1
Level 1
 
Posts: 5
Joined: Fri Mar 27, 2009 2:10 pm

Re: b43-phy0 ERROR

Postby merlwiz79 on Sat Mar 28, 2009 4:25 pm

I just tried on the Fluxbox CE and it worked for me.
Also echo "blacklist bcm43xx" >> /etc/modprobe.d/blacklist needs to be echo "blacklist b43" >> /etc/modprobe.d/blacklist
You must be typing something wrong or you have a corrupt iso or bad burn.
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: b43-phy0 ERROR

Postby merlwiz79 on Sat Mar 28, 2009 4:57 pm

Maybe try some of these to get past the error:
Code: Select all
noapic
nolapic
noacpi
acpi=off
pci=noacpi
nopcmcia  #only if you have pcmcia
irqpoll
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: b43-phy0 ERROR

Postby minimint on Sat Mar 28, 2009 5:29 pm

ok, ill try again with these new commands
minimint
Level 1
Level 1
 
Posts: 5
Joined: Fri Mar 27, 2009 2:10 pm

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: Bolle1961 and 14 guests