Laptop Advent 5301 LiveCD problems

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Laptop Advent 5301 LiveCD problems

Postby vickybrierley on Wed May 06, 2009 6:17 am

Hi all

First post on forum [waves hi!], please be gentle with me, very much a newbie!

I have being having quite a spot of bother with getting Mint 6 on my laptop, an Advent 5301. Have installed 6 on my desktop pc, all good and working wonderfully.

But when I came to booting from the CD, gets so far - to the mint splash screen - and then freezes. This is not specific to Mint either, have tried Mandriva and Ubuntu (latest releases) with exactly the same effect.

After much head scratching have come to the conclusion that it is my SiS Mirage Graphics card that is causing the problem.

Googling around brings up that the driver is at fault and that this one sis_vga_2000807_ubuntu_7.04.tgz should at least enable 2d for a ubuntu distro.

So my questions are;

Would this work for mint? Secondly, the extension (*.tgz) worries me... is this a linux driver file extension? Again pls bear with me, very new to Linux!

Lastly, how do I get the distro at least working from the CD? I think I may need a little hand holding here :oops: Incidentally, have tried 'forcing' the display using xforcevesa - no dice.

Specs on laptop are: Pentium Dual Core T2370 1.73 GHz, 120 Gb hard disk, SiS Mirage graphics. Currently running Vista Home Premium.

Thanks very much in advance!

Vicky
vickybrierley
Level 1
Level 1
 
Posts: 3
Joined: Sun May 03, 2009 7:45 am

Linux Mint is funded by ads and donations.
 

Re: Laptop Advent 5301 LiveCD problems

Postby miket on Wed May 06, 2009 6:47 am

Hi Vicky,

Welcome to LinuxMint !

I am familiar with your 5301 Laptop as I have had to rebuild one for a client.
I have an Advent 9117 which uses all Intel graphics and works perfectly, the advent range with the all Intel hardware are the
best to buy for Linux as they work out the box :)

The only solution I found to installing linux on the Advent 5301 was to use the Ubuntu Alternative Installation CD which
uses a text based installer instead of a GUI based installer. The net result is the same OS installed but without the problems !

If you grab Ubuntu alternative 32bit CD you will find it installs ok, then once installed all you will need to do is install the
SIS graphics driver via synaptic and you will be there.

Unfortunately since mint doesn't have a text based installer I have *never* been able to get Mint to install on the Advent 5301.

Sorry for the bad news !

Mike.

vickybrierley wrote:Hi all

First post on forum [waves hi!], please be gentle with me, very much a newbie!

I have being having quite a spot of bother with getting Mint 6 on my laptop, an Advent 5301. Have installed 6 on my desktop pc, all good and working wonderfully.

But when I came to booting from the CD, gets so far - to the mint splash screen - and then freezes. This is not specific to Mint either, have tried Mandriva and Ubuntu (latest releases) with exactly the same effect.

After much head scratching have come to the conclusion that it is my SiS Mirage Graphics card that is causing the problem.

Googling around brings up that the driver is at fault and that this one sis_vga_2000807_ubuntu_7.04.tgz should at least enable 2d for a ubuntu distro.

So my questions are;

Would this work for mint? Secondly, the extension (*.tgz) worries me... is this a linux driver file extension? Again pls bear with me, very new to Linux!

Lastly, how do I get the distro at least working from the CD? I think I may need a little hand holding here :oops: Incidentally, have tried 'forcing' the display using xforcevesa - no dice.

Specs on laptop are: Pentium Dual Core T2370 1.73 GHz, 120 Gb hard disk, SiS Mirage graphics. Currently running Vista Home Premium.

Thanks very much in advance!

Vicky
User avatar
miket
Level 5
Level 5
 
Posts: 524
Joined: Tue Mar 04, 2008 5:50 am
Location: UK & France

Re: Laptop Advent 5301 LiveCD problems

Postby vickybrierley on Thu May 07, 2009 5:06 am

Thanks Mike for your help on this one but unfortunately, it did not work.

I downloaded the iso and played around with the various settings.

ACPI=off resulted in a PnPBios fatal error alert. However I did manage to get it to the flickering screen stage!

I then duly used: pnpbios=off which resulted in a hang..

NOAPIC and EDD=ON both resulted in system 'hangs' too whilst NOLAPIC stated that it was forcing the use of dummy APIC then onto flickering screen again.

I feel I have a chicken in the egg situation here.. I obviously need to update graphic driver but how do I do that without Linux installed?

I have one new pointer in that the bios may be out of date so will try to get that sorted.

But if anyone does have any suggestions then I would be ever so happy!

Cheers guys
vickybrierley
Level 1
Level 1
 
Posts: 3
Joined: Sun May 03, 2009 7:45 am

Re: Laptop Advent 5301 LiveCD problems

Postby miket on Thu May 07, 2009 6:53 am

Hi Vicky,

Are you saying the text based installer didn't work ?
I've never known the text based installer not to work on any machine as it is not driver dependent at all.
Can you confirm the text based installer has failed to run or do you mean it has installed but will not boot once installed ?

Thanks.

Mike.

vickybrierley wrote:Thanks Mike for your help on this one but unfortunately, it did not work.

I downloaded the iso and played around with the various settings.

ACPI=off resulted in a PnPBios fatal error alert. However I did manage to get it to the flickering screen stage!

I then duly used: pnpbios=off which resulted in a hang..

NOAPIC and EDD=ON both resulted in system 'hangs' too whilst NOLAPIC stated that it was forcing the use of dummy APIC then onto flickering screen again.

I feel I have a chicken in the egg situation here.. I obviously need to update graphic driver but how do I do that without Linux installed?

I have one new pointer in that the bios may be out of date so will try to get that sorted.

But if anyone does have any suggestions then I would be ever so happy!

Cheers guys
User avatar
miket
Level 5
Level 5
 
Posts: 524
Joined: Tue Mar 04, 2008 5:50 am
Location: UK & France

Re: Laptop Advent 5301 LiveCD problems

Postby vickybrierley on Fri May 08, 2009 10:51 am

Hiya Mike

Yes, that's correct - I cannot boot from the alt ubuntu at all. Apart from two options ACPI=OFF and NOLAPIC all I see is a black screen with a blinking cursor top left.

I did leave the laptop like this for a few hours last night as a sanity check to ensure that nothing happened. Nothing happened. No writes/reads from hard-drive. The DVD drive spun down and stayed like that.

With those other two options I get an amount of text before a madly flickering screen.
vickybrierley
Level 1
Level 1
 
Posts: 3
Joined: Sun May 03, 2009 7:45 am


Return to Installation & Boot

Who is online

Users browsing this forum: gaviao, Spinner912 and 12 guests