LiveCD boots to prompt instead of x

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

LiveCD boots to prompt instead of x

Postby dlocpuwons on Mon Jun 15, 2009 11:10 am

Hey all, I'm currently away from my computer but I'll give all the specifics I can.

Regardless of wether I boot normally, in compatibility mode or the Installer Only option, I see a loading screen and then a prompt. I believe X can't start because of nvidia drivers. I have two 7800GTs but I don't necessarily care about SLI at this point, I'd just like to get into X. Their pci addresses are 4:0:0 and 5:0:0. When I try startx I get "Fatal error no screens found" and a "No devices detected". I've tried doing things like

sudo apt-get install nvidia-glx-180
sudo nvidia-xconfig
/etc/init.d/gdm restart
exit

but that doesn't seem to work.

Commenting out Load "glx" in the xorg.conf doesn't seem to work either. Also in the file it tells you to check for more errors after a startx (forget the name right now) it says found multiple devices and it isn't sure which one to use, I forget exactly what it said, but could that be related to the fact that there are two cards?

I've also tried using envy which use to work well on ubuntu so I figured it would work well here, but it didn't seem too. Any ideas?
dlocpuwons
Level 1
Level 1
 
Posts: 1
Joined: Mon Jun 15, 2009 10:58 am

Linux Mint is funded by ads and donations.
 

Re: LiveCD boots to prompt instead of x

Postby richyrich on Wed Jun 17, 2009 7:52 pm

I remember reading somewhere in Mint forums (can't seem to find it right now), that one community member removed the secondary vga card, installed Mint, installed the recommended NVidia drivers, rebooted to make sure all was right. Then shut down, and re-installed the secondary card. He was then able to configure both through the nvidia-settings gui.
I don't know if this will work for you, but it might be something to try?

good luck, Richard
User avatar
richyrich
Level 13
Level 13
 
Posts: 4921
Joined: Mon May 04, 2009 8:31 pm
Location: Pirating somewhere along the North Saskatchewan River, Canada


Return to Installation & Boot

Who is online

Users browsing this forum: Yahoo [Bot] and 19 guests