grub error 15 [SOLVED]

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

grub error 15 [SOLVED]

Postby Appock_ on Sat Jun 20, 2009 3:16 pm

Newbie warning! I've played around with Gloria for a couple days and really wanted to make the jump from windows to dual boot and since my hard drives were a mess, I've been forced to wipe the slates clean and install from an empty disk. Thought it would be simple, but I've found an error that I'm unsure how to get around.

Following the process of d/l the iso and burning it (worked fine with md5 verification) and boots fine from the disk. I start the install, but choose the manual partitions and set them up similar to what was suggested in this thread: http://forums.linuxmint.com/viewtopic.php?f=42&t=358.

Everything seemed to be fine. When I pull the cd out and reboot when prompted, I get a grub error 15 that sits on my screen. Looked it up and it means "file not found." All I can think of is that the boot file didn't get written in the /boot partition that I created. Any ideas on what I may have missed?

I'm going to try the install from the disk again with the same partition setup. If that doesn't work again, I'll wipe the drive clean again and just have Mint install like it wants. It isn't preferable given the info in the thread above, but I don't know what else to do.
Last edited by Appock_ on Sat Jun 20, 2009 7:15 pm, edited 1 time in total.
Appock_
Level 1
Level 1
 
Posts: 6
Joined: Sat Jun 20, 2009 3:06 pm

Linux Mint is funded by ads and donations.
 

Re: grub error 15

Postby emorrp1 on Sat Jun 20, 2009 3:23 pm

Can you describe the partitioning setup you used? i.e. sda1=Windoze, sda2=...
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Re: grub error 15

Postby Appock_ on Sat Jun 20, 2009 3:46 pm

Here's what I setup:

/dev/sdb1 ext3 /boot 128mb
/dev/sdb2 ext3 / 10gb
/dev/sdb3 fat32 /windows 128gb (was thinking of using this for winxp after getting Mint setup)
/dev/sdb4 extended partition
/dev/sdb5 ext3 /usr 25gb
/dev/sdb6 ext3 /opt 10gb
/dev/sdb7 ext3 /srv 10gb
/dev/sdb8 ext3 /var 10gb
/dev/sdb9 ext3 /home 128gb
/dev/sdb10 swap 4gb (since I have 2gb of system ram)
/dev/sdb11 empty partition the rest of the drive (630gb or so)

Thanks for spending the time! :D
Appock_
Level 1
Level 1
 
Posts: 6
Joined: Sat Jun 20, 2009 3:06 pm

Re: grub error 15

Postby emorrp1 on Sat Jun 20, 2009 4:17 pm

using a live CD, can you find the /boot/grub/menu.lst file, and paste it here? Also, just a warning: XP likes to be the only system on the disk, so be careful when you install it, and even then it'll overwrite your grub loader, which you'll need to restore using:
Code: Select all
sudo grub
root (hd0,0)
setup (hd0)

from a liveCD afterwards, which is why everyone always says to install windows first. Personally, I'd consider that partitioning setup overkill (you've got 65GB for your install, mint only needs about 3, unless you plan on installing almost every game available) but you're welcome to it.
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Re: grub error 15

Postby Appock_ on Sat Jun 20, 2009 4:33 pm

I did find this wiki page and I went through the steps to 'repair' the menu.lst file, which went through the same steps that you suggest. I haven't tried rebooting yet though. I'm gonna try that now!

Here's 'menu.lst' in it's current incarnation:

Code: Select all
# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-legacy-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not change this entry to 'saved' or your
# array will desync and will not let you boot your system.
default      0

## Graphical boot menu location
gfxmenu=/boot/gfxmenu/linuxmint.message

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout      10

# Pretty colours
color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title      Windows 95/98/NT/2000
# root      (hd0,0)
# makeactive
# chainloader   +1
#
# title      Linux
# root      (hd0,1)
# kernel   /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=/dev/sdb2 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd1,0)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(single-user) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## specify if running in Xen domU or have grub detect automatically
## update-grub will ignore non-xen kernels when running in domU and vice versa
## e.g. indomU=detect
##      indomU=true
##      indomU=false
# indomU=detect

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title      Linux Mint 7 Gloria, kernel 2.6.28-11-generic
root      (hd1,0)
kernel      /vmlinuz-2.6.28-11-generic root=/dev/sdb2 ro quiet splash
initrd      /initrd.img-2.6.28-11-generic
quiet

title      Linux Mint 7 Gloria, kernel 2.6.28-11-generic (recovery mode)
root      (hd1,0)
kernel      /vmlinuz-2.6.28-11-generic root=/dev/sdb2 ro single
initrd      /initrd.img-2.6.28-11-generic

title      Linux Mint 7 Gloria, memtest86+
root      (hd1,0)
kernel      /memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title      Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sdc1
#title      Windows NT/2000/XP
#rootnoverify   (hd2,0)
#savedefault
#makeactive
#map      (hd0) (hd2)
#map      (hd2) (hd0)
#chainloader   +1


After looking a bit at it, I see there is an entry for windows. I wanted to comment that entry out, but I'm not sure how to when I'm running from LiveCD cause the editor gives me an error when I try to save it (don't have permissions). Not sure what to make of that...
Appock_
Level 1
Level 1
 
Posts: 6
Joined: Sat Jun 20, 2009 3:06 pm

Re: grub error 15

Postby Appock_ on Sat Jun 20, 2009 4:41 pm

So I just tried rebooting and I get the menu to pick which OS to boot into. I tried Mint, but now I get an error 17 message: Couldn't mount partition. So I think there is still something in the grub setup that is wierd.

In the grub menu I selected edit and I get the following for the first Mint option in the menu:
Code: Select all
root (hd1,0)
kernel /vmlinuz--2.6.28-11-generic root=/dev/sdb2 ro quiet splash
initrd /initrd.img-2.6.28-11-generic
quiet


So to me that means hd1 is my second hard drive installed (the one that has the partitions mentioned above) and is pointing to the first partition on the drive. This should be the boot partition. So that seems ok to me. I'm not sure what the other lines are doing.
Appock_
Level 1
Level 1
 
Posts: 6
Joined: Sat Jun 20, 2009 3:06 pm

Re: grub error 15

Postby emorrp1 on Sat Jun 20, 2009 5:19 pm

Well, that's good news, once you've got grub, it should be easier (though I assume you used (hd1,0) rather than (hd0,0) like I suggested :oops: ) You can edit the various lines directly from that grub entry you found, just select the appropriate line and hit e, then change what you want, hit enter, then b for boot. Basically just try fiddling with the root numbers until it boots, I'd try matching them i.e. change (hd1,0) to (hd1,1) first, then there's other combinations you can try. I seem to remember gloria coming with the -7 kernel (though I could be wrong). To check it's not a mismatched kernel version, just change the first bit of the kernel line to /vmlinuz and similarly change the next to /initrd.img As a summary, here'd be the first entry I tried:
Code: Select all
root (hd1,1)
kernel /vmlinuz root=/dev/sdb2 ro quiet splash
initrd /initrd.img
quiet

Once you get a combination that works, make the change permanent by putting it in the menu.lst file. Also you should check out the info on grub error 17 now, see if any of those hits help you.
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Re: grub error 15

Postby newW2 on Sat Jun 20, 2009 5:54 pm

Isn't this missing a boot in the stanza? Instead of:
root (hd1,0)
kernel /vmlinuz--2.6.28-11-generic root=/dev/sdb2 ro quiet splash
initrd /initrd.img-2.6.28-11-generic
quiet

It should be:
root (hd1,0)
kernel /boot/vmlinuz--2.6.28-11-generic root=/dev/sdb2 ro quiet splash
initrd /boot/initrd.img-2.6.28-11-generic
quiet
User avatar
newW2
Level 6
Level 6
 
Posts: 1081
Joined: Fri Apr 06, 2007 10:24 am
Location: USA

Re: grub error 15

Postby emorrp1 on Sat Jun 20, 2009 6:55 pm

good spot newW2! yes, it should have the /boot in it. I didn't notice because I use the /vmlinuz shortcut anyway, my bad.
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Re: grub error 15

Postby Appock_ on Sat Jun 20, 2009 6:56 pm

I'm not sure I fully understand why this happened, but I applied both suggestions (adding /boot at the beginning of the paths and started trying different combination's for (hd1,0)). I tried (hd1,1) and incrementing the second number several times, but didn't work.

What did work was (hd0,0). Any ideas why?

I thought I had a better understanding of how my hard drives are setup but maybe I don't. I have 2 SATA drives and one IDE drive and the drive that has the boot partition is sensed with the liveCD as sdb rather than sda so that led me to believe that the drive I wanted was (hd1,0) in the grub boot description. But I guess that doesn't correlate. Hmmm...

Anyway, I was trying to change menu.lst to make these changes permanent, but now I can't save the file due to permissions (I'm logged in as me which is the only account and has the root password). Do I need to use "sudo grub" again? If so, how do I change menu.lst that way? In the mean time I think I'll try to find documentation about grub.

Thanks for spending the time to help me!
Appock_
Level 1
Level 1
 
Posts: 6
Joined: Sat Jun 20, 2009 3:06 pm

Re: grub error 15

Postby emorrp1 on Sat Jun 20, 2009 7:05 pm

Hi, you didn't tell us about the other drives, the mix of sata and ide is very indicative of this issue: http://www.linuxmint.com/wiki/index.php ... annot_boot What linux mounts as sda v sdb depends on the order it notices the drives, the correlation with the grub (hdx) is defined in /boot/grub/device.map, hence why I suggested playing around with the numbers. As for changing the menu.lst: gksudo gedit /boot/grub/menu.lst should do the trick, then hopefully this will be solved!
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Re: grub error 15

Postby Appock_ on Sat Jun 20, 2009 7:14 pm

Thank you so much! I'm now confidently running Mint!
Appock_
Level 1
Level 1
 
Posts: 6
Joined: Sat Jun 20, 2009 3:06 pm

Re: grub error 15 [SOLVED]

Postby newW2 on Sat Jun 20, 2009 8:04 pm

All is well that ends well - as they say. In the future Appock is sure to help us with asking the right questions and helping the next newbie that is lost.
emorrp1, as usual, great job of sticking to it till the end. I suspected the mix of SATA and IDE when comparing the grub drive numbering and the device names and seeing /dev/sdb#, but didn't ask. In retrospect I should have helped with a question. :oops: :oops:
User avatar
newW2
Level 6
Level 6
 
Posts: 1081
Joined: Fri Apr 06, 2007 10:24 am
Location: USA

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 22 guests