Active partition of Linux Mint won't Boot

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Active partition of Linux Mint won't Boot

Postby menuhin on Fri Jun 26, 2009 1:08 pm

Hi all,

I'm new to Linux Mint.
I've installed Linux Mint onto my hard drive using a USB thumb.

/dev/hda1 --- Vista
/dev/hda2 --- OSX86
/dev/hda3 --- LinuxMint
/dev/hda4 --- DATA

But during installation, I chose the advanced option NOT TO INSTALL BOOTLOADER.
After installation, I marked /dev/hda3 active, and reboot.

What I got is "missing operating system"...

Can some guru answer me following questions?

1. How can I boot into my /dev/hda3 linux system in this scenario? (I have LiveUSB of LinuxMint 7)
2. Do I need to install GRUB to boot into /dev/hda3? And if yes, why GRUB is need instead of just marking the partition active?

Thanks a lot!

- J
menuhin
Level 1
Level 1
 
Posts: 38
Joined: Fri Jun 26, 2009 12:52 pm

Linux Mint is funded by ads and donations.
 

Re: Active partition of Linux Mint won't Boot

Postby garda on Fri Jun 26, 2009 1:16 pm

You need a boot loader to boot and load an OS. That's why you should've chosen to install GRUB. Since you haven't done anything with your fresh install, I'd recommended you just re-run the install from the LiveUSB.
User avatar
garda
Level 5
Level 5
 
Posts: 744
Joined: Sat Aug 30, 2008 2:55 am
Location: /root

Re: Active partition of Linux Mint won't Boot

Postby menuhin on Fri Jun 26, 2009 1:26 pm

Because I'm planning to use another bootloader

I want to do
grub-install /dev/sda3
NOT
grub-install /dev/sda

But in the installation option, I don't know how to choose such an option during the installation.
menuhin
Level 1
Level 1
 
Posts: 38
Joined: Fri Jun 26, 2009 12:52 pm

Re: Active partition of Linux Mint won't Boot

Postby altair4 on Fri Jun 26, 2009 1:45 pm

In step 7 - Advanced button - there should be a combo box that would have all the partitions listed including sda3.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5804
Joined: Tue Feb 03, 2009 10:27 am

Re: Active partition of Linux Mint won't Boot

Postby garda on Fri Jun 26, 2009 1:49 pm

Once a partition is marked active, it will be searched for a boot loader by the BIOS. What you have to do now is boot from the Live USB, run Partition Editor and mark as active another partition that already has a boot loader (very likely /dev/hda). Then you configure whatever boot loader that you want to use. Judging by the variety of operating systems that you've got, I presume you're planning to do something like this, right? If my guess is right, you don't have to use GRUB, so no need to reinstall Mint.
User avatar
garda
Level 5
Level 5
 
Posts: 744
Joined: Sat Aug 30, 2008 2:55 am
Location: /root

Re: Active partition of Linux Mint won't Boot

Postby StanTheMan on Fri Jun 26, 2009 5:46 pm

When you have Vista , it usually has a hidden partition that uses up one of your Primary partitions.
You are better to create Logical partitions for all your Linux partitions.
The would be numbered like ' sda5 sda6 sda7 ' or similar.
I normally leave Vista partition set as active. Grub disregards the Active tag.
StanTheMan
Level 5
Level 5
 
Posts: 577
Joined: Fri Feb 13, 2009 7:07 pm

Re: Active partition of Linux Mint won't Boot

Postby menuhin on Sat Jun 27, 2009 12:49 pm

Thanks all Gurus!

I'm on Linux Mint right now! :)

- J
menuhin
Level 1
Level 1
 
Posts: 38
Joined: Fri Jun 26, 2009 12:52 pm

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: emigrates and 9 guests