Linux Mint doesn't boot [SOLVED]

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Linux Mint doesn't boot [SOLVED]

Postby vivi.hot on Sat Jun 27, 2009 3:07 am

Hello. I recently went to install Windows 7 in another partition apart from the Linux Mint 7 one. The thing is now I get no boot menu and go directly to Windows 7. I used the Ubuntu Live CD to try to modify the grub appears and defaults to 4. The Linux partition is still there but no way to get back access. How do I modify grub from Windows to Linux is the default? How do I return to see the boot menu?

Another thing is when I go to system settings in the boot "tab" I just get Windows 7 as operating system, not Mint. Is it normal to not see a Linux operating system detected by Windows, just like the partitions formatted with ext?

P.s.:My partition is ext4.

Can someone help me please? I want Linux Mint 7 back without reinstalling it? :cry: :?
Last edited by vivi.hot on Sun Jun 28, 2009 3:43 pm, edited 1 time in total.
Image
User avatar
vivi.hot
Level 1
Level 1
 
Posts: 8
Joined: Sat Jun 27, 2009 2:38 am

Linux Mint is funded by ads and donations.
 

Re: Linux Mint doesn't boot

Postby Husse on Sat Jun 27, 2009 6:14 am

This is normal - if you install Windows after Linux
Windows does not give a damn about other operating systems so it just writes over MBR
You have to repair grub - described here
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

How to repair GRUB

Postby vivi.hot on Sat Jun 27, 2009 4:04 pm

I do everything the link says but it doesn't let me modify it. I also tried the Auto super grub, but it doesn't install very well in windows 7.
Image
User avatar
vivi.hot
Level 1
Level 1
 
Posts: 8
Joined: Sat Jun 27, 2009 2:38 am

Re: Linux Mint doesn't boot

Postby Husse on Sat Jun 27, 2009 4:55 pm

but it doesn't let me modify it.

How so?
I'll try myself shortly
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19714
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Nah

Postby vivi.hot on Sat Jun 27, 2009 6:46 pm

I deleted both OS
Last edited by vivi.hot on Sat Jun 27, 2009 6:49 pm, edited 1 time in total.
Image
User avatar
vivi.hot
Level 1
Level 1
 
Posts: 8
Joined: Sat Jun 27, 2009 2:38 am

Nah

Postby vivi.hot on Sat Jun 27, 2009 6:48 pm

I deleted both OS, I intalled Windows 7 first and later I plan to reinstall Mint. I didn't have important files, so what the heck. Thanks for your help, though. :) The problem was that when I writed grub> find /boot/grub/stage1 says error command.
Image
User avatar
vivi.hot
Level 1
Level 1
 
Posts: 8
Joined: Sat Jun 27, 2009 2:38 am


Return to Installation & Boot

Who is online

Users browsing this forum: Stickytoffeedog and 20 guests