Grub error 22

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

Grub error 22

Postby SilverFox on Fri Jul 24, 2009 6:49 pm

Hi my first post and problem :) i do apologise if this has been covered before, but i did do a search with no joy.

My current system dual boots XP,Vista. i have 3 sata drives, first has 2 partitions with XP on 1 and Vista on the other, the other 2 are just storage.

Using disk manager on vista i shrank 1 of my storage disc's to give me 100GB free space for my first go at Linux.

Installed LM and on reboot during grub loading i got error 22, so at this point all i could boot into was the live cd after reading ways to fix the problem,

i installed GAG cant remember why as this was not any error 22 fix i had read, but it did give me back my 2 Windows systems.

So i tried agian this time i installed Grub in the / Partition as GAG requires and this time i get into the GUI of Grub, but when i select to boot LM i get error 22 no such partition.

Any help would be much appreciated.
SilverFox
Level 1
Level 1
 
Posts: 4
Joined: Fri Jul 24, 2009 6:07 pm

Linux Mint is funded by ads and donations.
 

Re: Grub error 22

Postby DrHu on Fri Jul 24, 2009 9:31 pm

I think your /boot/grub/menu.1st may be mis-configured
--I would check that first
I don't know what GAG does to grub which I think is likely being used by GAG to boot the Linux bootloader for Mint

Grub errors
http://www.uruk.org/orig-grub/errors.html

Check your system and partitions
--a guide to explain an install and Grub multiboot install.. (Ubuntu)
http://members.iinet.net.au/~herman546/p23.html
GAG, as a boot manager is also manipulating partitions to hide/unhide them, so exactly what it does to grub, I don't know for sure

The usual way to start a second bootloader, is to use the boot menu and within its menu structure (contents) to use, which transfers the first bootloader or boot manger's control to the second partition and allowx (grub)its menus to work
for example grub (mint_-->chainloader +1 Windows OS
chainloader +1
..other OS data to boot
boot
--or in GRUB itself, you just change the boot order
--to set Mint or Windows as the default (selection 0) menu selection, the top item in the grub menu list on the screen at boot..
http://www.linuxselfhelp.com/gnu/grub/h ... rub_4.html

My /boot/grub/menu.1st
Code: Select all
## ## End Default Options ##

title      Linux Mint 7 Gloria, kernel 2.6.28-13-generic
root      (hd0,4)
kernel      /boot/vmlinuz-2.6.28-13-generic root=/dev/sda5 ro quiet
initrd      /boot/initrd.img-2.6.28-13-generic
quiet

title      Linux Mint 7 Gloria, kernel 2.6.28-13-generic (recovery mode)
root      (hd0,4)
kernel      /boot/vmlinuz-2.6.28-13-generic root=/dev/sda5 ro single
initrd      /boot/initrd.img-2.6.28-13-generic

title      Linux Mint 7 Gloria, kernel 2.6.28-11-generic
root      (hd0,4)
kernel      /boot/vmlinuz-2.6.28-11-generic root=/dev/sda5 ro quiet splash
initrd      /boot/initrd.img-2.6.28-11-generic
quiet

title      Linux Mint 7 Gloria, kernel 2.6.28-11-generic (recovery mode)
root      (hd0,4)
kernel      /boot/vmlinuz-2.6.28-11-generic root=/dev/sda5 ro single
initrd      /boot/initrd.img-2.6.28-11-generic

title      Linux Mint 7 Gloria, memtest86+
root      (hd0,4)
kernel      /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title      Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title      Microsoft Windows XP Professional
rootnoverify   (hd0,0)
savedefault
makeactive
chainloader   +1 


As you can see my /boot/grub/menu.1st boots my windows XP
--from the first hard drive hd0,0 (the c:\ drive)
    rootnoverify (hd0,0)
    savedefault
    makeactive
    chainloader +1
User avatar
DrHu
Level 17
Level 17
 
Posts: 7110
Joined: Wed Jun 17, 2009 8:20 pm

Re: Grub error 22

Postby SilverFox on Sun Jul 26, 2009 5:57 pm

Thank you DrHu for such a quick reply :)

I followed the instructions in the link for dual booting and reinstalled LM about 10 times still same error 22 when Grub was starting.
I only use GAG because grub does not start so i am unable to start any of my Windows system's, i am not planning on using GAG permanently.

I downloaded and ran Super Grub and tried to fix Grub, now Grub starts but still gives me error 22 "No such partition" when i try to start LM. I can however select start Linux from the super Grub menu and it will boot into LM so im kinda at a loss as to what the problem is.

I will put my menu.lst below and maybe you can comment on whether it looks ok or not.
thanks.

## ## End Default Options ##

title Linux Mint 7 Gloria, kernel 2.6.28-11-generic
root (hd2,1)
kernel /boot/vmlinuz-2.6.28-11-generic root=/dev/sdc2 ro quiet splash
initrd /boot/initrd.img-2.6.28-11-generic
quiet

title Linux Mint 7 Gloria, kernel 2.6.28-11-generic (recovery mode)
root (hd2,1)
kernel /boot/vmlinuz-2.6.28-11-generic root=/dev/sdc2 ro single
initrd /boot/initrd.img-2.6.28-11-generic

title Linux Mint 7 Gloria, memtest86+
root (hd2,1)
kernel /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Windows Vista (loader)
rootnoverify (hd0,0)
savedefault
makeactive
chainloader +1
SilverFox
Level 1
Level 1
 
Posts: 4
Joined: Fri Jul 24, 2009 6:07 pm

Re: Grub error 22

Postby SilverFox on Sat Aug 01, 2009 7:11 pm

Hi, ok after a little research i found that DrHu original suggestion of the Menu.lst file being mis-configured to be the problem.

i found this by selecting "e" in the grub menu, and editing the Hard Drive number then trying to boot LM until i found the correct HD number that did successfully boot LM.

now all i need to do is edit my menu.lst and change (hd2,1) to (hd1,1).

Sounds easy if your not a n00b but i cant save the menu.lst file after editing it in Text Editor, says i dont have permission. So i thought i've read enough "how to's" in the newbie section i will just sudo su and edit it in the terminal.

well all i've managed to do is create a folder called menu.lst that i cant delete :oops: so i thought i better just ask how to edit the menu.lst file and delete the folder i created.

any help would be much appreciated thanks.
SilverFox
Level 1
Level 1
 
Posts: 4
Joined: Fri Jul 24, 2009 6:07 pm

Re: Grub error 22

Postby DrHu on Sat Aug 01, 2009 11:09 pm

SilverFox wrote:well all i've managed to do is create a folder called menu.lst that i cant delete :oops: so i thought i better just ask how to edit the menu.lst file and delete the folder i created

I would check /boot/grub/menu.1st file as the first step, fix that up before deleting any menu.1st folders..
--just don't mix them up (in your mind..)

Open as root in nautilus (file manager), the parent directory of that menu.1st folder, and move to trash or delete..

Easiest way is probably use nautilus file manager, go to the /boot/grub directory (folder), right-click and open as root
--the file manager background will change to red after you have entered your user login password (as that first user is in the root and admin groups), and has system access functions available

Select /boot/grub/menu.1st , edit then save the file (remember you opend as root), so it will save changes

Or just go direct, alt F2 to open a run dialog, then gksu gedit /boot/grub/menu.1st
--same as above, edit, then save
User avatar
DrHu
Level 17
Level 17
 
Posts: 7110
Joined: Wed Jun 17, 2009 8:20 pm

Re: Grub error 22

Postby SilverFox on Fri Aug 07, 2009 3:37 pm

Hi, just wanted to say that worked a treat everthing working as should now.
thanks for your help DrHu :D
SilverFox
Level 1
Level 1
 
Posts: 4
Joined: Fri Jul 24, 2009 6:07 pm


Return to Installation & Boot

Who is online

Users browsing this forum: austin.texas and 11 guests