Grub Not Loading [Triple Boot XP, Windows 7, Mint 7]

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Grub Not Loading [Triple Boot XP, Windows 7, Mint 7]

Postby uglyy2 on Sat Jul 25, 2009 3:15 am

Hi everyone,

I'm new.

I have 2 Hard disks of 250 mb each and I've already installed XP and Windows 7 on one of them.

I tried installing Mint 7 Gloria on the same disk. (The Live CD works just fine.)

I followed all the instructions (format partition with ext3> install os and bootloader> reboot) The installation doesn't show any errors, but after the reboot I don't see the Grub menu. It goes directly to the Windows 7 boot screen.

Here's how I tried to reinstall Grub using instructions I googled.

1. Mount Disk
2. Navigate to /media/disk/boot/grub
3. cat menu.lst , where I found 'linux Mint 7 Gloria Kernel 2.6.8-11-generic' installed in (hd0,3)
it also showed that my Windows 7 (Windows Vista Bootloader) was at (hd1,1) (i don't know why it's hd1, when I boot into 7 it clearly shows linux is on the same drive. Could this be a problem?)
4. next, sudo grub > root (hd0,3) > setup (hd0)

Once again, the installation didn't show any errors. But when I reboot, Grub still doesn't load.

What am I doing wrong?

Am I installing Grub in the wrong partition?

P.S. > I've tried reinstalling Mint7. Didn't work.
uglyy2
Level 1
Level 1
 
Posts: 4
Joined: Sat Jul 25, 2009 2:52 am

Linux Mint is funded by ads and donations.
 

Re: Grub Not Loading [Triple Boot XP, Windows 7, Mint 7]

Postby Boo on Sat Jul 25, 2009 8:16 am

I expect this is an "intelligent" bios boot order problem.
Are the 2 disks sata?
do you choose which disk to boot from at boot?
or do you change the disk boot order in the bios?

what im getting at is that no matter what order you set the disks to boot or change at boot, hardware will always present them in their real order.
linux will also see them in the real order, but can also get confused with live installs and normal ones too.
it is best not to change the disk boot order.
you also have to watch multiple sata controllers and ports.
keep disks on the same controller.

try taking out the second disk first and see what happens. if nothing then reinstall mint again on the disk (with the other missing).
it looks like the OS's are on the second disk (hd1) and you changed the MBR on the first to grub.
you could use grub to set mint to hd1,3 and put grub on the MBR of the second disk.

see all this disk ordering stuff is getting complex.

Boo
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Re: Grub Not Loading [Triple Boot XP, Windows 7, Mint 7]

Postby uglyy2 on Sun Jul 26, 2009 3:19 am

Hey.

I fixed it!

Yes, you're right. It WAS an 'intelligent' boot order problem

However, I didn't need to reinstall Mint. :-)

Instead, I booted directly into linux using a 'SuperGrubDisk' boot cd and modified the menu.lst file. (swapped the hd numbers)

This fixed the Mint loading, but Windows showed an ntldr missing error and wouldn't load. So I edited the windows entry too.

It works perfectly now! ;-)

Thanks!
uglyy2
Level 1
Level 1
 
Posts: 4
Joined: Sat Jul 25, 2009 2:52 am


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 14 guests