Problem using live distro

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Problem using live distro

Postby dkettle on Fri Aug 07, 2009 10:02 am

Hi! I was trying to use the live distro DVD that came with the August issue of "Linux Format". It booted without problem on my laptop, but when I tried it in my desktop machine, it got as far as displaying the splash screen and the progress bar, but when it reached the end of the progress bar and tried to open the desktop, the screen just went blank, no mouse cursor or anything. I suspect it may be due to the fact that I've got a Wacom graphics tablet and mouse installed on my desktop and I need appropriate drivers for it to boot properly. Can anyone confirm this? Would I have better luck with the "Main" edition rather than the "Universal" edition? I don't want to install it yet, until I've played around with it some. So I can't install any other drivers yet (assuming they're even available).

Thanks.
dkettle
Level 1
Level 1
 
Posts: 5
Joined: Fri Aug 07, 2009 9:53 am

Linux Mint is funded by ads and donations.
 

Re: Problem using live distro

Postby richyrich on Fri Aug 07, 2009 11:47 am

Info about Wacom :
https://help.ubuntu.com/community/Wacom

Do you know what model/type of graphics card you have?
It may be a graphics driver issue . .
Boot the Live CD, on the initial Green screen ( counting down the seconds ) , hit the spacebar, and choose Compatibility Mode
User avatar
richyrich
Level 13
Level 13
 
Posts: 4635
Joined: Mon May 04, 2009 8:31 pm

Re: Problem using live distro

Postby dkettle on Mon Aug 10, 2009 7:46 pm

Thanks. I tried your advice, but I regret to say, it didn't help. A whole bunch of messages scrolled by, most of them too quickly for me to read, but I didn't see any that looked like error messages. The end result was the same, when it reached the point of starting up the desktop, the screen just went blank and everything appeared to be frozen. I'm not really sure what "compatibility mode" means, but it didn't seem to work any better.

I have an Intel 82845G Graphics Controller and an Acer X203W LCD monitor. I didn't investigate the link to the Wacom stuff, since you said the problem was more likely due to some graphics-related problem. Any other ideas?

David.
dkettle
Level 1
Level 1
 
Posts: 5
Joined: Fri Aug 07, 2009 9:53 am

Re: Problem using live distro

Postby richyrich on Sat Aug 15, 2009 9:13 am

David, sorry for not getting back to you sooner.

Have you tried installing without the Wacom connected?
User avatar
richyrich
Level 13
Level 13
 
Posts: 4635
Joined: Mon May 04, 2009 8:31 pm

Re: Problem using live distro

Postby dkettle on Mon Aug 17, 2009 8:42 pm

Thanks, but it didn't help. I disconnected the Wacom tablet and tried booting in compatibility mode, but got exactly the same result. Is there supposed to be something in the stream of console messages that might tell me what the problem is? As I said, I didn't see anything that looked like an error message, but some of the lines scrolled by too quickly to read.
dkettle
Level 1
Level 1
 
Posts: 5
Joined: Fri Aug 07, 2009 9:53 am

Re: Problem using live distro

Postby richyrich on Mon Aug 17, 2009 9:01 pm

David,
When you get to the initial boot screen (counting down the seconds), and hit the spacebar, there are some other options shown, can you run the memtest ? It'll take awhile, let it run it's passes. Let us know the results, as this will confirm or remove this as a possible trouble spot.
User avatar
richyrich
Level 13
Level 13
 
Posts: 4635
Joined: Mon May 04, 2009 8:31 pm

Re: Problem using live distro

Postby pcdoctor on Mon Aug 17, 2009 9:19 pm

I have a Wacom bamboo.
Try these settings in your xorg.conf.
(These settings are from ubuntu 7.10 but of course 8.04 xorg.conf looks totally different.)
With 8.04 I never had to do anything to get my Wacom to work.

HOW TO: Bamboo & Bamboo Fun under 7.10
New guide! If you already have your tablet working, please don't go through this guide. This is for people who are newly installing Linux Wacom.

---------------------------------------------

Plug in your tablet, then open a terminal (Applications > Accessories > Terminal). As you follow through the steps, paste the code (line-by-line) into the terminal and press enter after each line. If it prompts you for your password, type in your password (which will not show up as you type it) then press enter.

1.
Code:

uname -r

Make sure the output has "2.6.22-14" in it.

2.
Code:

lsusb | grep -i wacom

Look for the part of that line in the form "056a:####" ("#" being 0-9 or a-f)
Make sure yours is listed here: "056a:0017", "056a:0018", "056a:0065", "056a:0069"

3.
Code:

mkdir wacom
cd wacom

4.
Code:

sudo apt-get install linux-headers-`uname -r` build-essential x11proto-core-dev libxau-dev libxdmcp-dev x11proto-input-dev x11proto-kb-dev xtrans-dev libx11-dev x11proto-xext-dev libxext-dev libxi-dev linux-libc-dev libc6-dev libncurses5-dev xserver-xorg-dev tk8.4-dev tcl8.4-dev

It may ask you for your password

5.
Code:

wget http://prdownloads.sourceforge.net/linu ... -7.tar.bz2
tar xjf linuxwacom-0.7.9-7.tar.bz2
cd linuxwacom-0.7.9-7/

6.
Code:

./configure --enable-wacom
make
sudo make install

7.
Code:

cd ..
cp /etc/X11/xorg.conf .
gksudo gedit /etc/X11/xorg.conf

8. Find the section that looks like this (should start at the third section in the file)
Code:

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

9. Replace those lines with this
Code:

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
Option "USB" "on"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
Option "USB" "on"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
Option "USB" "on"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "pad"
Option "Device" "/dev/input/wacom"
Option "Type" "pad"
Option "USB" "on"
EndSection

10. Find the section that looks like this (should be near the end of the file)
Code:

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"

11. Replace those lines with
Code:

# Uncomment if you have a wacom tablet
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
InputDevice "pad" "SendCoreEvents"

12. Save the file (Ctrl-S) and close Gedit (Ctrl-Q)

13.
Code:

for kern in `ls /lib/modules`; do
cp /lib/modules/$kern/kernel/drivers/input/tablet/wacom.ko wacom.ko.$kern
sudo cp linuxwacom-0.7.9-7/src/2.6.22/wacom.ko /lib/modules/$kern/kernel/drivers/input/tablet/wacom.ko
done

You may get a couple errors such as "cp: cannot stat[...]" or "cp: cannot create regular file[...]" but you can just ignore those.

These may yield errors ("No such file or directory" or "Cannot create regular file"), but you may safely ignore them.

14.
Code:

sudo depmod -e

This command should have no output. If it does, please post with the output.

15.
Code:

cd linuxwacom-0.7.9-7/prebuilt
sudo ./uninstall
sudo ./install

16.
Code:

cd ../..
wget 'http://git.debian.org/?p=users/ron/wacom-tools.git;a=blob_plain;f=debian/xserver-xorg-input-wacom.udev;hb=master' -O wacom.udev
cp /etc/udev/rules.d/50-xserver-xorg-input-wacom.rules wacom.udev.backup
sudo cp wacom.udev /etc/udev/rules.d/50-xserver-xorg-input-wacom.rules

17. Reboot your computer

18. If you want to configure your tablet, open the terminal again and run this:
Code:

wacomcpl
pcdoctor
Level 1
Level 1
 
Posts: 38
Joined: Sat Dec 27, 2008 6:49 am

Re: Problem using live distro

Postby dkettle on Tue Aug 18, 2009 8:28 am

I started running the memory test, although I didn't wait for it to complete (wasn't sure how long it would take). I can try it again, but I don't think that's the problem. I've already got Windows XP and Ubuntu Linux 7 installed on the hard drive, and they both seem to be running OK (at least as well as you'd expect, in the case of Windows).

Somebody else suggested editing the settings in xorg.conf, but unless it boots successfully, I don't see how I can do that, apart from the fact that I'm trying to run in from a DVD and don't want to install it yet. And since I unplugged the Wacom, it's irrelevant anyway. By the way, the Wacom does work under Ubuntu Linux, without my having to do anything.
dkettle
Level 1
Level 1
 
Posts: 5
Joined: Fri Aug 07, 2009 9:53 am

Re: Problem using live distro

Postby richyrich on Tue Aug 18, 2009 1:23 pm

I would suggest that you download the Mint 7 Main iso , check the md5sum, and burn to CD as slow as possible.
Cause if Ubuntu installed correctly, there shouldn't be any problems with Mint. Maybe the difference is between DVD & CD ???

stumped . . Richy
User avatar
richyrich
Level 13
Level 13
 
Posts: 4635
Joined: Mon May 04, 2009 8:31 pm

Re: Problem using live distro

Postby dkettle on Tue Aug 18, 2009 2:46 pm

Could be a defective DVD, maybe. It's one of the flexible "Eco Discs", I don't know how reliable they are. I'll try your suggestion when I have time, maybe on the weekend.

Thanks for your help.
dkettle
Level 1
Level 1
 
Posts: 5
Joined: Fri Aug 07, 2009 9:53 am

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: katherinepatrice and 13 guests