Cassandra install to USB drive still fails!

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Cassandra install to USB drive still fails!

Postby bitbanger on Fri Jun 08, 2007 7:55 pm

Tried the install to usb again with Cassandra and trashed the mbr on the hard disk again. I think LinuxMint is REALLY missing a bet here. Many potential users of the product are going to run away after such an experience. Not everyone has a second expendable computer to experiment upon.

Since I have learned that you can get a correct usb install by disconnecting the hard drive this should be a solvable problem. If you are inheriting the behavior from ubuntu this is another place you need to do your own code.

I would love to have more of my friends try LinuxMint but when I tell them that they have to go into the box and make adjustments they get nervous. As for the people with laptops such a temporary modification would scare me. I do the install on another desktop and then port the usb device. Some tweeking is required but it is the safest approach that I can find.
User avatar
bitbanger
Level 2
Level 2
 
Posts: 82
Joined: Sat Apr 07, 2007 2:46 pm
Location: California, U.S.A.

Linux Mint is funded by ads and donations.
 

Postby mattrixx on Sat Jun 09, 2007 12:36 am

When you say "install to usb", do you mean a flash/thumb drive ?
Or, are you refering to an external USB HDD?

I have just freshly installed "Cassandra" over my previous "Bianca" on an external (W.D. 40GB 7200RPM) HDD, that I have in a Bytecc USB 2.0
enclosure, with absolutely NO problem!

Yes, I first unplugged the power cables to all 4 of my internal hdd`s including 1 SATA 250GB drive.
I installed using the Mint 3.0 "LiveCD" INSTALL feature, to the now sole listed (USB) HDD, which in my case was listed as: SCSI3 (0,0,0) (sda).

I did a "Guided-use entire disk" installation, which then Formatted and Partitioned automatically, and setup the GRUB bootloader on that same drive.
No other drives present to put a bootloader.... except the USB drive!

I should mention that my Asus system has a "quick boot" feature, which allows me to *select* any drive to boot from during startup or a reboot.
In this case on startup, I just select my external 40 GB W.D. HDD when I want MINT!
Default bootup still continues pre-determined by the order set in the BIOS as per normal. And the Windows MBR was never touched.

Matt
mattrixx
Level 2
Level 2
 
Posts: 72
Joined: Sat Apr 07, 2007 6:42 pm

USB Clarification

Postby bitbanger on Sat Jun 09, 2007 12:38 pm

Thanks for your response Matt. I have done installs to both USB-HDD and USB-FlashDrives. Both Cassandra and Bianca.

I repeat that it is very un-user friendly to require that all other disks on the system be disconnected. This is frightening to many users. Particularly those with laptops.

The real zen question is: Why does the resulting install work when the hard drives are disconnected but fails to work if this is not done? Something that is required on the installed usb drive is written to the wrong place when available but goes to the correct place if no alternative is present? Very strange!
User avatar
bitbanger
Level 2
Level 2
 
Posts: 82
Joined: Sat Apr 07, 2007 2:46 pm
Location: California, U.S.A.

Postby mattrixx on Sat Jun 09, 2007 2:11 pm

Bitbanger

In my case, I initially had trouble with my BIANCA external HDD installation.
I believe (I can`t remember for sure, but I think I did) I had my internal drives connected,
but the "live CD" installer would only get as far as 15% and then fail at most of my early attempts.
Or, I would get further on, but then stall or error messages somewhere along the way.
This was frustrating to say the least, but I perservered.

I tried several completely *different* install variations, but would get error messages etc. Finally I think I ended up having to first *unmount* my external USB drive,
which later (during the install), showed up on the "LiveCD" desktop again, though this time labled as: *TARGET* !!

I also somehow ended up installing to: (hd3,0) just for a successfull install to the USB drive, but then when booting up, GRUB couldnt find the install!
Grub did however, list several options including EDITING (press"E").

I edited GRUB from (hd3,0) to *(hd0,0)* and it would FINALLY boot to my Mint BIANCA install!!
This worked fine, but I would have to do this edit each time I booted up!

Later on while in BIANCA and at the command line, I permanently changed GRUB from (hd3,0) to (hd0,0) using first: sudo gedit /boot/grub/menu.lst
Backspacing the unwanted line(s) and adding the new.
I hope I`m not confusing you? I`m just trying to remember any pertinent information.
I dont know if I just stumbled my way into a successfull USB HDD installation of BIANCA or what ?

Mind you, I did NOT have any of this with my Cassandra installation, as everything went smooth and efficiently as I described in my earlier post,
though as I have said, I did pull the power cables to all internal drives before the install.

Hope this helps?

Matt
mattrixx
Level 2
Level 2
 
Posts: 72
Joined: Sat Apr 07, 2007 6:42 pm

Postby bitbanger on Sat Jun 09, 2007 10:31 pm

To all,

I have a successful installation of Cassandra to several USB drives. This is because I had the foresight to disconnect the internal drives.

My intent in adding this post was to address my concerns to the architects, designers and their fellows. LinuxMint is a delightful system that covers the needs of many computer users without the unjustified expense associated with Windows. I only grieve that many of these potential users will never make the attempt because the installation cannot succeed without some sleight of hand. This should not be the case!

Will the guiding lights of the LinuxMint enterprise please fix this deficiency?
User avatar
bitbanger
Level 2
Level 2
 
Posts: 82
Joined: Sat Apr 07, 2007 2:46 pm
Location: California, U.S.A.

Postby merlwiz79 on Thu Jun 21, 2007 2:03 am

I have Linux Mint 3.0 Xfce Community Edition(I'm currently working on) installed on a 6GB USB hard drive.
I also have 3 internal and another external drive.
I never have to disconnect any drives to install(I have installed many times).
You have to click advanced on the install page that list your details for the install.
It normally says (hd0) I always have to change to (hd3) so it installs on my 2nd USB HD.
I am not sure the settings for your setup.

After install I have to edit Grub from (hd3,0) to (hd0,0)

I have to do this every Linux install.
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)


Return to Installation & Boot

Who is online

Users browsing this forum: Google Adsense [Bot], Tridariel and 20 guests