HP multi function and Gloria hplip-3.9.2

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

HP multi function and Gloria hplip-3.9.2

Postby solar1951 on Fri Aug 14, 2009 11:42 am

Have just upgraded from Elyssa to Gloria - a little late I know - and in one aspect I should not have bothered.
I have a HP Multifunction Photosmart C5280 printer and one of its abilities is to print CD's. The hplip shipped with gloria will not let you print CD's as it does not recognise the cd tray. I have done lots of searching and even tried to downgrade to hplip 2.8.7 shipped with Elyssa but ended up with a dependancy nightmare and broke the system. Even trying to upgrade to the latest hplip-3.9.8 from the hplip website did not solve the problem. Apparently the problem is solved in the Karmic repos so i will have to wait for karmic to be released before I can print CD's again.

Just thought I would let you all know that if you have one of these printers do not upgrade to Gloria, wait for Mint 8.
solar1951
Level 4
Level 4
 
Posts: 259
Joined: Wed Oct 03, 2007 4:14 am
Location: France

Linux Mint is funded by ads and donations.
 

Re: HP multi function and Gloria hplip-3.9.2

Postby solar1951 on Sun Aug 16, 2009 6:09 am

I have found the bug report about the problem here https://bugs.launchpad.net/hplip/+bug/380858

There is a patch available here http://launchpadlibrarian.net/28140718/set-media-type.diff

Being a "no brain user" I do not know what file to patch and how to carry out the patch.

Could one of you kind experts out there help me out please :roll:
solar1951
Level 4
Level 4
 
Posts: 259
Joined: Wed Oct 03, 2007 4:14 am
Location: France

Re: HP multi function and Gloria hplip-3.9.2

Postby solar1951 on Mon Aug 17, 2009 6:15 am

Update - I have got the printer to work correctly by forcing the download of hpijs to 2.8.7 - way to go !
HOWEVER:
Now whenever I try and use synaptic to download and install other progs it highlights hpijs-2.8.7 as having broken dependancies and tries to upgrade to latest.
I have tried pinning the level of hpijs by editing /etc/apt/preferences but to no avail.

This now means that I cannot install anything through synaptic without upgrading hpijs and thereby breaking my printing again.

HELP :cry:
solar1951
Level 4
Level 4
 
Posts: 259
Joined: Wed Oct 03, 2007 4:14 am
Location: France

Re: HP multi function and Gloria hplip-3.9.2

Postby mike2039 on Tue Aug 18, 2009 4:38 am

You probably need to down the tarball for hplip 3.9.8 and install that way.

If you don't want to do that, post your system spcs and I'll email you a deb.
mike2039
Level 1
Level 1
 
Posts: 14
Joined: Tue Jul 28, 2009 5:47 am

Re: HP multi function and Gloria hplip-3.9.2

Postby solar1951 on Tue Aug 18, 2009 6:09 am

mike2039 wrote:You probably need to down the tarball for hplip 3.9.8 and install that way.

If you don't want to do that, post your system spcs and I'll email you a deb.

Thanks for the reply.
I have tried the 3.9.8 from the Hplip website which still does not work :x
Do you have the tarball from the Karmic repos, if so that may work.
I have a 32bit i386 machine - Asus Vintage VH1 with Celeron proc - old but works for me !
solar1951
Level 4
Level 4
 
Posts: 259
Joined: Wed Oct 03, 2007 4:14 am
Location: France


Return to Installation & Boot

Who is online

Users browsing this forum: Bing [Bot] and 10 guests