System hangs after grub screen, Mint 8 32bit

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

System hangs after grub screen, Mint 8 32bit

Postby Jeff91 on Wed Feb 03, 2010 12:18 am

Howdy All,

So I just did a fresh install of Mint 8 on my media pc - anywho for some reason when the system boots it seems to be hit or miss whether or not it actually makes it past the grub screen and actually starts booting. I see the words "Grub Loading" flash on the screen and then nine times out of ten it just goes to a black screen with the white flashing line in the upper left hand corner...

I'm open to suggestions on how I can go about resolving this issue - once the system actually boots it runs like a champ. It just takes more than a few tries to actually get it to do so. Quite annoying :-/

~Jeff
User avatar
Jeff91
Level 3
Level 3
 
Posts: 156
Joined: Sun Jul 19, 2009 6:37 pm
Location: Blue Island, IL

Linux Mint is funded by ads and donations.
 

Re: System hangs after grub screen, Mint 8 32bit

Postby remoulder on Wed Feb 03, 2010 10:11 am

When you manage to boot successfully, edit the /etc/default/grub file as root (gksu gedit /etc...) and remove the quiet splash options on the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" so it reads GRUB_CMDLINE_LINUX_DEFAULT="", then save and in a terminal issue sudo update-grub. Now when you boot you will get all the boot messages and you can see where it hangs and report back.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: System hangs after grub screen, Mint 8 32bit

Postby Jeff91 on Wed Feb 03, 2010 11:50 am

Ahh, good idea. I was unable to get it to boot this morning after ten tries and it also failed to boot from the Mint live disc...

I know my hardware is good, because I have a Windows based disc that it boots fine from. Going to try a Fedora live disc later today to see if it will boot from that - I am still open to suggestions on how I might get Mint working again, as I prefer Ubuntu based distros

Regards,
~Jeff
User avatar
Jeff91
Level 3
Level 3
 
Posts: 156
Joined: Sun Jul 19, 2009 6:37 pm
Location: Blue Island, IL

Re: System hangs after grub screen, Mint 8 32bit

Postby Jeff91 on Wed Feb 03, 2010 6:57 pm

Alrighty so here is the status: Pressing escape at "grub loading" yields nothing, the system just moves right along to the white flashing line on the black background.

I have a giant stack of Live discs sitting in my drawer and none of them boot in the system:

Linux Mint 8:
stdin: error 0
/init: line 1: can't open /dev/sdc: No medium found...
Shadow passwords are now on.

Fedora 12:
ACPI: Expecting a [Reference] package element, found type 0
ata3: softreset failed (device not ready)

Sabayon 4.2:
Hangs at "initializing the kernel"

Knopix 5.3:
I get two tuxes in the upper left hand corner of the screen

The disc drive works however - I know this because my Vista 32bit disc loads right up on the sucker. What one earth could have happened to both cause my system to stop booting into Mint and no longer be able to boot off of a live cd at the same time? I am truly confused.

Regards,
~Jeff
User avatar
Jeff91
Level 3
Level 3
 
Posts: 156
Joined: Sun Jul 19, 2009 6:37 pm
Location: Blue Island, IL

Re: System hangs after grub screen, Mint 8 32bit

Postby Jeff91 on Wed Feb 03, 2010 7:44 pm

Alrighty, at last I have pin-pointed my issue. Just not sure how to resolve it. I recently inserted a new hard drive and formatted it from ntfs to ext4. I had not connected the issue occurring after this addition until now.

When I open the system up and dis-connect the second hard drive the system boots into the install operating system just fine... However I need the second drive (it is a 1.5tb disc I bought for storage purposes) What might be causing the issue and how can I resolve it?

EDIT: And lastly upon reattaching the drive the system now boots just fine as it did before... I've rebooted it twice now and it came right back online both times. I am truly confused at to what was causing/caused the issue. I am not used to these kind of random stability issues on my Linux based computers - normally they only break when the hardware goes out or I change something. If anyone has insight into what might have happened/what I did to fix it exactly please feel free to enlighten me.

~Jeff
User avatar
Jeff91
Level 3
Level 3
 
Posts: 156
Joined: Sun Jul 19, 2009 6:37 pm
Location: Blue Island, IL

Re: System hangs after grub screen, Mint 8 32bit

Postby breaker on Thu Feb 04, 2010 2:52 am

You probably fixed it when you reseated the connector, common electronic device issue... you think you have a solid connection, at least it looks that way, but really, something (connector pins) weren't tight. At least that's what it usually is in my experience.
rtfm - read the fine manual...
Boot info script: http://ubuntuforums.org/showthread.php?t=1291280
grub2 https://help.ubuntu.com/community/Grub2
PC-BIOS based booting, mbr, boot records; http://thestarman.pcministry.com/
breaker
Level 5
Level 5
 
Posts: 613
Joined: Sun Mar 16, 2008 5:28 am


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 14 guests