[SOLVED] Cannot boot into Helena

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

[SOLVED] Cannot boot into Helena

Postby skambale on Wed Feb 03, 2010 6:23 pm

It seems like after a recent upgrade of the Grub to 1.98 experimental the grub file got screwed up and i could not boot into any OS since.
For all the 3 OS, it says error: file not found

Setup is as follows
80GB HDD1 - Windows, 320GB HDD2 ==> Gloria LM 7 x64 + Helena LM 8 x32

I was able to run a SuperGrub disk and fix the Grub to be able to boot into LM7.
But now the Grub cannot even recognize LM8. Even after doing a grub-update from LM7 which found kernel of LM8 i am not able to boot into LM8 because i am trying to boot into a 32bit OS using 64 bit kernel (i digged that up using the loop error seen in recovery mode)

What i noticed is that the grub in LM8 is now grub.cfg file while LM7 is still menu.lst.

Need tips to get back to LM8.
Last edited by skambale on Sat Feb 06, 2010 1:04 pm, edited 1 time in total.
Core i7 + Gigabyte X58 MoBo GA-EX58-UD3R + 4GB XMMS 2x2 RAM, EVGA Nvidia GeForce 8800GT
80GB HDD1 - Windows, 320GB HDD2 ==> LM 11 x32 + LM 9 x64 + NTFS
Ext 400GB HDD
skambale
Level 1
Level 1
 
Posts: 39
Joined: Wed Dec 24, 2008 7:58 pm
Location: Germantown, MD

Linux Mint is funded by ads and donations.
 

Re: Cannot boot into Helena

Postby Jeff91 on Wed Feb 03, 2010 11:32 pm

What does your partition layout/menu.list/grub.cfg look like? To find the first of these run
Code: Select all
df -h
in terminal and post the out put here. When you boot you see your menu.lst entries correct? This means that legacy grub is being used as your boot loader - we just need to point it to grub2/mint8

EDIT: Also you might want to look into The Grub2 Basics it really is better than legacy grub.

Regards,
~Jeff
User avatar
Jeff91
Level 3
Level 3
 
Posts: 156
Joined: Sun Jul 19, 2009 6:37 pm
Location: Blue Island, IL

Re: Cannot boot into Helena

Postby skambale on Thu Feb 04, 2010 10:28 pm

here is the df -h output

Filesystem Size Used Avail Use% Mounted on
/dev/sdb7 19G 4.2G 14G 25% /
tmpfs 2.0G 0 2.0G 0% /lib/init/rw
varrun 2.0G 300K 2.0G 1% /var/run
varlock 2.0G 0 2.0G 0% /var/lock
udev 2.0G 160K 2.0G 1% /dev
tmpfs 2.0G 96K 2.0G 1% /dev/shm
lrm 2.0G 2.7M 2.0G 1% /lib/modules/2.6.28-11-generic/volatile
/dev/sr1 4.4M 4.4M 0 100% /media/CDROM
/dev/sdb5 258G 135G 124G 53% /media/HDD2
/dev/sdb8 21G 13G 6.7G 66% /media/Mint 8
/dev/sda1 75G 38G 38G 51% /media/Windows

I see grub1 menu and it seems like it also recognized Mint 8 although it displays it as "Linux Mint 7 Gloria x64 bit generic pae" I get to the LM8 icon but it hangs there.

Attached is the menu.lst
Attachments
menu.txt.tar.gz
(2.07 KiB) Downloaded 15 times
Core i7 + Gigabyte X58 MoBo GA-EX58-UD3R + 4GB XMMS 2x2 RAM, EVGA Nvidia GeForce 8800GT
80GB HDD1 - Windows, 320GB HDD2 ==> LM 11 x32 + LM 9 x64 + NTFS
Ext 400GB HDD
skambale
Level 1
Level 1
 
Posts: 39
Joined: Wed Dec 24, 2008 7:58 pm
Location: Germantown, MD

Re: Cannot boot into Helena

Postby skambale on Sat Feb 06, 2010 1:03 pm

ok..i fixed this.
modified the menu.lst to point to /sdb8 for first two options. booted into recovery mode for Helena and did a grub recovery.
Core i7 + Gigabyte X58 MoBo GA-EX58-UD3R + 4GB XMMS 2x2 RAM, EVGA Nvidia GeForce 8800GT
80GB HDD1 - Windows, 320GB HDD2 ==> LM 11 x32 + LM 9 x64 + NTFS
Ext 400GB HDD
skambale
Level 1
Level 1
 
Posts: 39
Joined: Wed Dec 24, 2008 7:58 pm
Location: Germantown, MD


Return to Installation & Boot

Who is online

Users browsing this forum: wafer5 and 22 guests