HELP? Installed Grub2 to sda1!

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

HELP? Installed Grub2 to sda1!

Postby kernel_panic on Sat Feb 06, 2010 11:29 pm

I managed to find myself doing a reinstall of grub2. That went well, other then the fact that I installed grub2 to my windows partition as well as my MBR.

WindowsXP Home is now a circular reference.

How can I fix this? Its a client computer and I have no backup, as I'm usually VERY careful when doing this however my hand hit 1 and enter out of some strange desire to fix something that wasn't broken.

Any ideas?

Using Mint 8
Lastly, the lack of modem detection (Toshiba A05-2061) from Mint installer is enough for me to not push Mint as a main Windows Replacement. I haven't yet learned how to compile modem drivers. I found gnome-PPP, but getting the modem up and running is not something I can do quickly; which given the circumstances, I need to do.
kernel_panic
Level 1
Level 1
 
Posts: 2
Joined: Sat Feb 06, 2010 11:24 pm

Linux Mint is funded by ads and donations.
 

Re: HELP? Installed Grub2 to sda1!

Postby kernel_panic on Sun Feb 07, 2010 12:35 am

OK. Simple fix.

Windows Recovery Console can repair MBR's and PBR's.

fixmbr rewites the MBR and fixboot fixes the partition boot record.
kernel_panic
Level 1
Level 1
 
Posts: 2
Joined: Sat Feb 06, 2010 11:24 pm


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 21 guests