Simple problem on dual-booting and the simple solution

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Simple problem on dual-booting and the simple solution

Postby msnthrp on Tue Feb 09, 2010 10:16 pm

Using Linux Mint 8 (64-bit) dual-booting with WinXP. My wife likes XP and I like Linux.

The grub2 default boot is to Mint. To maintain domestic tranquillity, I needed the default to be XP. Searched for the solution but did not find it in this forum or others.

Solution: Open etc/default/grub with gedit or another editor. E.g., "sudo gedit etc/default/grub"

Change "default=0" to "default=5" and save the file.

Run "sudo update-grub" in a terminal.

Exit, reboot, and the XP option should be the default.

If you want other operating systems

If you have multiple operating systems in the grub menu, count the lines from the first one and use that instead of the 5 above.

Good luck
msnthrp
Level 1
Level 1
 
Posts: 4
Joined: Thu Feb 04, 2010 5:41 pm

Linux Mint is funded by ads and donations.
 

Re: Simple problem on dual-booting and the simple solution

Postby Aging Technogeek on Wed Feb 10, 2010 8:00 am

You can install Start Up Manager from Synaptic Package Manager (search startupmanager). It will give you a GUI interface to change grub default boot , boot wait time, and several other parameters.
Image

Registered Linux User 483387
User avatar
Aging Technogeek
Level 13
Level 13
 
Posts: 4605
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here


Return to Installation & Boot

Who is online

Users browsing this forum: SJLPHI and 16 guests